Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-22-2009, 04:46 PM   #1
Senior Member
 
denochs's Avatar
 
Fleetwood Owners Club
Join Date: Oct 2009
Location: North Carolina
Posts: 690
Onan Generator

We have a 10K genset in our 03 American Eagle. The Onan has a fault code of 24 - Coolant level/temp. After running approx. 5 minutes it shuts down. I can override the code just by restarting after verifying it is full and not overheating.

Can anyone refer me to information that will show where these sensors are located so I can replace them? Also, it now has over 1200 hours on it and the manual calls for replacing the radiator cap at 1000 hours. Could that cause the same code? I'm assuming the o'rings wear out and will not allow pressure to build up in the cooling system.
__________________

__________________
David & Gail Salisbury, NC
2003 American Eagle 42'
denochs is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-23-2009, 02:48 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 9,815
Most likely the temp sensor is bad and is located at the upper radiator hose/thermostat housing on the engine.
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 350 ISC w/ Banks = 450Hp & 1330# torque
06 Saturn Vue & 06 Chevy Z71 4x4 toads
RV Wizard is offline   Reply With Quote
Old 10-24-2009, 04:59 AM   #3
Senior Member
 
denochs's Avatar
 
Fleetwood Owners Club
Join Date: Oct 2009
Location: North Carolina
Posts: 690
Onan Generator

Thanks Mike, any thoughts on the radiator cap? Does it really have to be replaced at the 1000 hour interval? Could it cause the same code?
__________________
David & Gail Salisbury, NC
2003 American Eagle 42'
denochs is offline   Reply With Quote
Old 10-25-2009, 02:29 AM   #4
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 9,815
Replacing the radiator cap would not hurt but it probably is not the culprit in the 5 minutes you say it goes into fault. It certainly would be worth a try. If you find that it improves slightly, you may want to drain, clean and flush the cooling system and refill with fresh 50/50 propylene glycol and distilled water.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 350 ISC w/ Banks = 450Hp & 1330# torque
06 Saturn Vue & 06 Chevy Z71 4x4 toads
RV Wizard is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan MicroQuiet 4000 generator questions JC Andrews RV Systems & Appliances 10 06-17-2013 06:56 PM
Onan diesel generator stops after about a minute Bob&AnnaMari MH-General Discussions & Problems 2 10-05-2009 02:38 PM
Generator Question - Propane Onan Suddenly Misfiring...... RBAJJK Spartan Motorhome Chassis Forum 1 08-04-2009 08:00 PM
Onan Generator Quits On Start With No Load Birddog Pilot Alpine Coach Forum 26 08-11-2008 10:49 AM
Onan Generator / Wiring Problem Doggie MH-General Discussions & Problems 2 12-23-2006 11:04 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

RV & Travel Trailer Communities

Our RV & Travel Trailer sites encompasses virtually all types of Recreational Vehicles, from brand-specific to general RV communities.

» More about our RV Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, vBulletin Solutions, Inc.