RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-27-2018, 03:26 AM   #1
Senior Member
 
Piros1's Avatar
 
Join Date: Dec 2015
Location: Dittmer, MO 63023
Posts: 150
Onan generator wonít start

Not sure if Iím on the right forum or not but I donít think my problem is coach specific but if you all think it is I will move it. So here we go. I have a 2005 Country Coach Affinity 770 with a Onan 12,500 gem set. It started out I could start the generator but it would not shut down from any of the control start stop switches even the switch on the generator. I was able to shut it down by disconnecting the fuel solinoid. Now it wonít start at all. Before trying the fuel solinoid I tried shutting off the coach power and the chassis power with no effect, it kept running. Now it will not restart but the switch is flashing. Also my coach has a Silverleaf total coach system any ideas would be helpful!
__________________

__________________
2005 CC Affinity 770, 2006 Jeep TJ
Piros1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-27-2018, 06:11 AM   #2
Member
 
Join Date: Oct 2018
Location: Iowa
Posts: 87
Silverleaf total coach system?

The Silverleaf system controls everything? Not familiar with the total coach system. If it were me I would try a power down of the control wait 30 seconds to a minute and then power it back up.

I'm making the assumption that the control of the generator's start and stop goes thru the Silverleaf Instead of the factory controls. Either the wiring harness going to the generator is disconnected or damaged or that particular module of the Silverleaf control has the problem.


If possible I would power down the silverleaf do the wait period and power it back up. If the generator is still non-functional. I would look at the generator for the control wiring if added or possibly look for a link going to the control(Silverleaf) or some type of connection from the original generator control switches if it was equipped with such.
__________________

Coachmen Joe is offline   Reply With Quote
Old 10-28-2018, 12:12 AM   #3
Senior Member
 
Piros1's Avatar
 
Join Date: Dec 2015
Location: Dittmer, MO 63023
Posts: 150
Yes the Silverleaf is the control center for most of the coach. I double checked and it is called a Total Coach System. The gen set is controlled through the system. I have checked the wiring as best I can while on the road but will do a more thorough job once I get to my destination. I seem to be pleaged with these little gremlins, story of my life. Having slid issues as well but have that figured out and under control. Not related to the gen set. What I have found so for was a mouse nest in the gen set. I did not see any chewed wires but will check in a day or two as well as give Silverleaf a call Monday when they are open.
__________________
2005 CC Affinity 770, 2006 Jeep TJ
Piros1 is offline   Reply With Quote
Old 11-04-2018, 09:30 AM   #4
Senior Member
 
Rkesselus's Avatar
 
Tiffin Owners Club
Join Date: Aug 2016
Location: Bastrop Texas
Posts: 844
When you disconnected the fuel solenoid you may have caused a loss prime situation. Listen to the fuel pump and try to determine if it is pushing fuel against pressure. If not you might try replacing the fuel filter, after filling it with fuel, then listening to see if the fuel pump picks up a load. It does not take much to keep the fuel from being delivered to the injectors.
__________________
2000 Allegro Bus 35R 3126 Cat 300 Allison 3060MD 6 speed
Rkesselus is offline   Reply With Quote
Old 11-04-2018, 10:05 AM   #5
Senior Member
 
Join Date: Jul 2018
Posts: 409
Quote:
Originally Posted by Piros1 View Post
Yes the Silverleaf is the control center for most of the coach. I double checked and it is called a Total Coach System. The gen set is controlled through the system. I have checked the wiring as best I can while on the road but will do a more thorough job once I get to my destination. I seem to be pleaged with these little gremlins, story of my life. Having slid issues as well but have that figured out and under control. Not related to the gen set. What I have found so for was a mouse nest in the gen set. I did not see any chewed wires but will check in a day or two as well as give Silverleaf a call Monday when they are open.

I think you've identified a significant suspect, if a reset of the Silverleaf system doesn't correct the problem.


It's not the nest itself but the damage of chewed wire insulation, wires chewed through, and the corrosive action of mouse urine on control boards. Note that the damaged wiring may not be at the generator but elsewhere between it and the Silverleaf interface/control board.
__________________
2005 Four Winds Majestic 23A
ďTo the world you may be one person; but to one person you may be the world.Ē - Dr Suess
Solo_RV_Guy is offline   Reply With Quote
Old 11-05-2018, 05:53 AM   #6
Member
 
knit's Avatar
 
Join Date: Jan 2017
Posts: 82
Get your Oman manual. Count the flashing lights as that is likely an error code. Find the code in the manual.
knit is offline   Reply With Quote
Old 11-05-2018, 06:01 AM   #7
Senior Member
 
Hit_the_Rhod's Avatar


 
Join Date: Oct 2014
Location: Salvisa, KY
Posts: 3,348
When you state that it "Now won't start at all",
do you mean that it cranks, but will not fire?
Or do you mean it won't crank?

These are two distinctly different problems, with distinctly different remedies, and trouble shooting. Which problem do you have?
__________________
Scot & Laura Kellersberger
Newmar 4 wheel drive Dutch Star 3891, 2005 GMC Canyon. Demco Tow Bar & Baseplate U.S.Army (ret)
1985 - 2006
Hit_the_Rhod is offline   Reply With Quote
Old 11-06-2018, 12:02 AM   #8
Senior Member
 
Piros1's Avatar
 
Join Date: Dec 2015
Location: Dittmer, MO 63023
Posts: 150
Quote:
Originally Posted by Hit_the_Rhod View Post
When you state that it "Now won't start at all",
do you mean that it cranks, but will not fire?
Or do you mean it won't crank?

These are two distinctly different problems, with distinctly different remedies, and trouble shooting. Which problem do you have?
It does do anything, you hit the start button inside or out on the generator there is no response. Like pushing a button that is not connected to anything. I have not had an opportunity to do any diagnostics since I posted this but will in the next couple of days. Iím hoping it has a loose connection or something of that nature. So for on my trip I have not needed it. Running on shore power at this time and the coach kept the batteries up while driving. Thank goodness something still works. Lol
__________________
2005 CC Affinity 770, 2006 Jeep TJ
Piros1 is offline   Reply With Quote
Old 11-06-2018, 06:54 AM   #9
Junior Member
 
Join Date: Feb 2013
Posts: 13
Quote:
Originally Posted by Piros1 View Post
It does do anything, you hit the start button inside or out on the generator there is no response. Like pushing a button that is not connected to anything. I have not had an opportunity to do any diagnostics since I posted this but will in the next couple of days. Iím hoping it has a loose connection or something of that nature. So for on my trip I have not needed it. Running on shore power at this time and the coach kept the batteries up while driving. Thank goodness something still works. Lol
Check and see make sure you didn't acttivate your battery disconnect.
sadtime is online now   Reply With Quote
Old 11-06-2018, 09:51 AM   #10
Senior Member
 
OLYLEN's Avatar
 
Monaco Owners Club
Join Date: Jan 2008
Location: Olympia, Wa
Posts: 2,722
Driver side top forward on the Gen under the control panel there are fuses. Might check them.

LEN
__________________
2004 Clss C 31' Winnebgo
OLYLEN is offline   Reply With Quote
Old 11-09-2018, 12:29 AM   #11
Senior Member
 
Piros1's Avatar
 
Join Date: Dec 2015
Location: Dittmer, MO 63023
Posts: 150
Quote:
Originally Posted by OLYLEN View Post
Driver side top forward on the Gen under the control panel there are fuses. Might check them.

LEN


My generator must be different, no control panel or fuses. I did a test start today and it started and ran fine but still wonít shut down at the generator or in all three starting locations in the coach. Just for the record my generator is a 2005 model 12,500 watt quiet run diesel. I have as stated before a Silverleaf Total Coach control system that handles most coach functions. Pump, tank levels, tank drain, power, generator, and more. I feel it is in the generator controls but nothing obvious when I did a physical inspection. The self test for codes comes up negative. The Silverleaf system shows no faults. I will probably wait until I get back home to dig deeper. If I need it in the trip home I can start it but will have to shut down by discotheque fuel solenoid. Not the best option but the only one right now unless someone has a better one. I have spent a fair amount of my trip dealing with issues and as long as I can get by I think I will.
__________________
2005 CC Affinity 770, 2006 Jeep TJ
Piros1 is offline   Reply With Quote
Old 11-11-2018, 11:49 PM   #12
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 14,873
All that sounds like a poor ground somewhere. FWIW, over 80% of all 12V issues are the result of a poor/missing ground.
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG retired;PPA,Good Sam Life member,FMCA."We the people are the rightful masters of both the Congress and the Courts - not to overthrow the Constitution but to overthrow men who pervert the Constitution. "Abraham Lincoln"
Ray,IN is offline   Reply With Quote
Old 11-12-2018, 12:29 AM   #13
Senior Member
 
Piros1's Avatar
 
Join Date: Dec 2015
Location: Dittmer, MO 63023
Posts: 150
Quote:
Originally Posted by Ray,IN View Post
All that sounds like a poor ground somewhere. FWIW, over 80% of all 12V issues are the result of a poor/missing ground.


I would agree with the ground but it will start and run just wonít shut down without disconnecting the fuel solenoid to the engine. No codes, starts normally, puts out power, just canít turn it off with any of the four switches even the switch on the generator. Th figured out the reason it would not restart required manually cycling the switch. When you disconnect the fuel solenoid it puts a code in the generator that gas to be cleared to restart.
__________________
2005 CC Affinity 770, 2006 Jeep TJ
Piros1 is offline   Reply With Quote
Old 11-12-2018, 09:13 PM   #14
Junior Member
 
texaslime's Avatar
 
Join Date: Sep 2017
Location: texas
Posts: 10
You might try unplugging 1 switch at a time to see if it will shut off. You may have 1 of your 4 switches shorted not letting it to shut off. Just a thought.
__________________

texaslime is online now   Reply With Quote
Reply

Tags
generator, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oman Generator Site Glass pallencollin Entegra Owner's Forum 17 05-15-2018 06:04 PM
12.5 KW Oman Generator pallencollin RV Systems & Appliances 4 02-26-2017 06:46 PM
Oman won't start Ront77 Class A Motorhome Discussions 2 09-15-2016 07:54 AM
Oman 5500 generator new pheacoxsr RV Systems & Appliances 5 05-26-2015 10:53 AM
Oman 6.5 generator Schnau-pal RV Systems & Appliances 2 07-11-2014 04:10 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.