Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-24-2006, 06:47 AM   #1
Member
 
Join Date: May 2003
Posts: 30
My Onan 5KW generator runs fine until i shut it off. When i try to restart it, it starts but as soon as I take my hand off of start button it kills. If I leave my hand on start button it runs.
After sitting for about 2 hours it will start again. Any suggestion please
__________________

__________________
Ron G is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-24-2006, 06:47 AM   #2
Member
 
Join Date: May 2003
Posts: 30
My Onan 5KW generator runs fine until i shut it off. When i try to restart it, it starts but as soon as I take my hand off of start button it kills. If I leave my hand on start button it runs.
After sitting for about 2 hours it will start again. Any suggestion please
__________________

__________________
Ron G is offline   Reply With Quote
Old 09-24-2006, 07:03 AM   #3
Senior Member
 
Retired and Happy's Avatar
 
Join Date: Feb 2004
Location: Stone Mountain, GA
Posts: 941
Mine is in the shop as I write this. Same symptoms, except mine died on its own. They say it's the rotor and maybe the stator. They also say they will need to rebuild it or find a rebuilt one because the new ones won't fit in the compartment. So far it's about $2400 to repair. I'll bet it goes higher than that. I just had the starter replaced a week before for nearly $500.
__________________
Ken, Judy, and the Angels--2005 Fleetwood Southwind--2008 Cargo Trailer--2003 EZGO Golf Cart
Retired and Happy is offline   Reply With Quote
Old 09-24-2006, 09:17 AM   #4
Senior Member
 
Tom N's Avatar
 
Winnebago Owners Club
Pond Piggies Club
Appalachian Campers
Mid Atlantic Campers
Join Date: Dec 2002
Location: Sarver, PA/Crystal River, FL/Shelocta, PA
Posts: 4,604
I had the same "take my finger off the start button and it dies" symtom with my old coach's Onan 7kw. Took it to Onan/Cummins for service and they had to replace the electronic module on the generator. The module was ~$200 and it just plugs in.
__________________
Sarver, PA/Crystal River, FL/Shelocta, PA FMCA 335149 W3TLN
2005 Suncruiser 38R W24, no chassis mods needed 2013 Honda Accord EX-L 2008 Honda Odyssey EX-L

Tom N is offline   Reply With Quote
Old 09-24-2006, 01:28 PM   #5
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
This symptom can be the result of any number of conditions. I would recommend you check the oil level and also the type of oil if it was just changed. I say this because you say that after a couple hours at rest it restarts. Good luck and let us know what you find.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 09-24-2006, 02:39 PM   #6
Senior Member
 
Fossilhog's Avatar
 
Join Date: Feb 2006
Location: Howell, New Jersey
Posts: 360
Send a message via AIM to Fossilhog
I just had a similar problem like that. Here's what I did.....from the outside, pull the wire off the oil pressure sensor and try to start it, then see if it stays running. I my case, it did. I reconnected the wire and it stopped. I had changed the oil and filter not more than a month ago and all was correct, the oil was not diluted either. I tapped the sensor with a wrench, connected the wire and all is fine. Hope that helps. Let us know.
__________________
Tim ,Retired Police Lt. 2002 Winnebago Adventurer+16' Trailer
Harley Road King and Heritage Classic+,Trik-L-start,Hughes Autoformer. Blue Tick Coon hound
Fossilhog is offline   Reply With Quote
Old 02-13-2007, 06:47 PM   #7
Member
 
Join Date: May 2003
Posts: 30
The problem was the control board. I took it off and cleaned it and now it runs fine. Thanks for all the suggestions.
__________________

__________________
Ron G is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan Generator pdrduz Monaco Owner's Forum 6 01-05-2009 04:48 PM
Onan Generator joatmon Winnebago Industries Owner's Forum 10 09-13-2008 10:17 AM
generator Onan sal avitabile RV Systems & Appliances 5 07-10-2007 12:13 PM
onan generator Kevin f MH-General Discussions & Problems 4 06-22-2005 12:34 AM
Onan Generator RV Systems & Appliances 6 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:26 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.