Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-09-2008, 11:56 AM   #1
Junior Member
 
Join Date: Feb 2008
Posts: 7
I have an Onan 500 Marquis in my 1994 Fleetwood. I was running it on a trip home. After stopping for a visit for a half hour it wouldn't restart. I have gotten the manual but don't know where to start. When I try to start it it makes a clicking sound but won't turn over. Also, I don't know how I'll service it because it's built into a cramped compartment; no slide tray.

Any thoughts??
__________________

__________________
1994 Fleetwood Southwind 34M
musikfans is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-09-2008, 11:56 AM   #2
Junior Member
 
Join Date: Feb 2008
Posts: 7
I have an Onan 500 Marquis in my 1994 Fleetwood. I was running it on a trip home. After stopping for a visit for a half hour it wouldn't restart. I have gotten the manual but don't know where to start. When I try to start it it makes a clicking sound but won't turn over. Also, I don't know how I'll service it because it's built into a cramped compartment; no slide tray.

Any thoughts??
__________________

__________________
1994 Fleetwood Southwind 34M
musikfans is offline   Reply With Quote
Old 08-09-2008, 06:47 PM   #3
Junior Member
 
Join Date: Aug 2008
Posts: 11
Had the same problem on my 2002 winnebago. First I found that my batteries were low so I put them on my charger to get them charged, the generator started. However, that was short lived and I ended up putting a new starter in the unit.
__________________
Shamong Shepherds is offline   Reply With Quote
Old 08-10-2008, 06:37 AM   #4
Junior Member
 
Join Date: Feb 2008
Posts: 7
It made me think of a low battery, too. When my auto battery is tapped the starter will click in the same manner. I hooked up a charger to the batteries and loaded them. It did the same thing. I'm thinking it must be the starter. Does anyone know how to access it? My generator is built into the compartment.
__________________
1994 Fleetwood Southwind 34M
musikfans is offline   Reply With Quote
Old 08-10-2008, 11:24 AM   #5
Senior Member
 
Join Date: Oct 2002
Location: Traveling in the East
Posts: 533
Check electrical connections to be sure they are clean and tight.

Joe
full-timer is offline   Reply With Quote
Old 08-13-2008, 03:56 AM   #6
Senior Member
 
NAUTIQUE's Avatar
 
Ford Super Duty Owner
Georgie Boy Owners Club
Join Date: Mar 2007
Location: Southeastern MA.
Posts: 116
Make sure you have battery power.
Genny will only start from house batteries with the battery switch is set to "use" or start from chassis battery with ignition key on.
Guess why I'm telling you to double-check this??
Cleaned and power-washed my genny, thought I had messed something up when it was only clicking.
Forgot house battery switch was on "store"
Hope your fix is that easy!
__________________

__________________
The Portable Summer Cottage II * 2000 GBM/99 F53. Steer-Safe, Ultra-Trac, Bilsteins, Sumitomo's, CHF, & Eternabond. Mod it & keep her rolling! Pics & Mods:http://s69.photobucket.com/user/scot...20Cottage%20II
NAUTIQUE is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan Generator Quits On Start With No Load Birddog Pilot Alpine Coach Owner's Forum 26 08-11-2008 11:49 AM
Onan Gas Generator won't start John Hilley Winnebago Industries Owner's Forum 3 12-03-2007 06:24 PM
My Onan 4.0 won't start, HELP! twinbubba Toy Haulers Discussion 8 04-25-2007 09:50 AM
Onan won't start racer0624 MH-General Discussions & Problems 12 10-28-2006 11:13 AM
Onan Generator Quits On Start With No Load MH-General Discussions & Problems 26 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.