Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-26-2006, 08:11 PM   #1
Junior Member
 
Join Date: Jun 2006
Location: Boise
Posts: 4
Have a '99 Class C Winnebago with an Onan Microlite generator. Genset has 420 hours. Ran fine since we bought last fall. Mem. weekend, ran for 3 days then just died. When first started, runs for about 5 minutes. Then it just dies. Try to start again, and it won't start. After a lot of trouble shooting, we found that once it shuts off, it has no spark from the magneto. It is a KY Spec H. Could it possibly be the capacitor on the magneto? Any help would be greatly appreciated...
__________________

__________________
fanblade is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-26-2006, 08:11 PM   #2
Junior Member
 
Join Date: Jun 2006
Location: Boise
Posts: 4
Have a '99 Class C Winnebago with an Onan Microlite generator. Genset has 420 hours. Ran fine since we bought last fall. Mem. weekend, ran for 3 days then just died. When first started, runs for about 5 minutes. Then it just dies. Try to start again, and it won't start. After a lot of trouble shooting, we found that once it shuts off, it has no spark from the magneto. It is a KY Spec H. Could it possibly be the capacitor on the magneto? Any help would be greatly appreciated...
__________________

__________________
fanblade is offline   Reply With Quote
Old 06-27-2006, 12:32 AM   #3
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
fanblade, welcome to our website and forum. We are glad to have youjoin us here and look forward to reading of your adventures and experiences. The trouble with the generator could be a bad voltage regulator to loose wiring. Be sure the right oil and amount are in genset too. There is a service manual that you can purchase on this unit from Onan. Good luck and let us know the outcome. From time to time we get a couple Onan people checking the forum and they might be of more help.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 06-27-2006, 05:35 AM   #4
Junior Member
 
Join Date: Jun 2006
Location: Boise
Posts: 4
Thank you Mike and Amy. The problem seems to be heat related... We have spark to the plug when the genset is cold. After running for about 5 minutes or reaching operating tempature it quits. at this point we get no spark to the plug except when you release the starter switch it will spark once. We checked the coil and it is good, I ordered a service manual for my spec H from Onan and the one the sent only goes up to G......? You mention voltage regulator,, when it does run, we are getting system voltage to the coach. Would the VR cause it to shut the unit down? Thank you< Randy
__________________
fanblade is offline   Reply With Quote
Old 06-27-2006, 08:53 AM   #5
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
If the voltage regulator were going bad it could shut the genset down. If you think it is heat related make sure the covers are in place and that the air flow is not restricted.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 07-02-2006, 06:29 AM   #6
Senior Member
 
Workhorse Chassis Owner
Join Date: Jun 2003
Location: Palisade CO
Posts: 3,562
My last motor home had the same generator model.
It had a similar problem and it turned out to be associated with the oil foaming. The manual says 30 weight oil but many people use 10W 30. I bought the motor home used and didn't know what was in it. I changed to 30w and the problem went away. The foaming confused the oil level switch and it was shutting down the generator.

You can check to see if the oil level switch is involved by unplugging it and running the generator. The switch shuts the generator down by connecting a circuit to ground, so if it's causing the spark to go away unhooking it will prevent that.
__________________
Clay WA5NMR - Ex Snowbird - 1 year, Ex Full timer for 11 years - 2004 Winnebago Sightseer 35N Workhorse chassis. Honda Accord toad.
Clay L is offline   Reply With Quote
Old 07-03-2006, 05:14 AM   #7
Junior Member
 
Join Date: Jun 2006
Location: Boise
Posts: 4
Thanks Clay on the oil tip. I have a KY spec H and it does not have the oil level switch. But that is good info to remember on the weight of the oil. after spending about ten hours all together trouble shooting..... we think it is the Mag. today,, July the third, we are taking it to a pro to change out the mag.. we will see. by the way, happy and safe fourth to all. The Wrights
__________________
fanblade is offline   Reply With Quote
Old 07-08-2006, 05:45 PM   #8
Junior Member
 
Join Date: Jul 2006
Location: Wedowee,Alabama.36278
Posts: 1
My Onan has 38 hours on it and have only had This RV for a Couple of months and getting ready to take trip to Penn. next month and was checking it out and generator will run about a hour then makes all kind of Rattling sound an shuts down,have checked oil level and air flow looks clean,I don't know what to do and the dealer had as is where is on paper work,I did hear it run but not long. AL Lyle
__________________
Al Lyle is offline   Reply With Quote
Old 07-09-2006, 02:08 AM   #9
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Al Lyle, welcome to iRV2.com. We are glad to have you join us here and look forward to reading of your adventures and experiences. I do not quite understand what you are saying about the dealer and the genset. If it is in warranty, have the generator checked out as it could be serious. Good luck and enjoy the website.
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan 4BGE 4000 gen set mustang Winnebago Industries Owner's Forum 6 11-08-2008 07:15 AM
Onan 2.8 microlite generator for TT J Link Travel Trailer Discussion 1 10-15-2008 11:28 AM
Onan 4000 circuit breaker bad? Jerry J Winnebago Industries Owner's Forum 5 05-02-2008 07:22 PM
Onan 4000 Gen Set RayT MH-General Discussions & Problems 5 02-08-2008 05:25 PM
Onan 4000 Microquiet oil Jerry J Winnebago Industries Owner's Forum 9 08-19-2007 03:11 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.