Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-27-2010, 05:17 PM   #1
Senior Member
 
ImagineIF's Avatar
 
Join Date: May 2010
Posts: 1,045
ONAN "Need Service Code"

I have a 10KW Diesel Onan genset and every time I initially start it it runs for a minute or so and stops displaying 3 quick flashes which means needs service. I can immediately restart it and it runs fine. Any idea what this could be?
__________________

__________________
Gil
99 Country Coach
Prevost XL 45 Conversion
ImagineIF is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-27-2010, 05:24 PM   #2
Senior Member
 
Vegasdan's Avatar
 
National RV Owners Club
Freightliner Owners Club
Join Date: Oct 2009
Posts: 1,873
Quote:
Originally Posted by ImagineIF View Post
I have a 10KW Diesel Onan genset and every time I initially start it it runs for a minute or so and stops displaying 3 quick flashes which means needs service. I can immediately restart it and it runs fine. Any idea what this could be?
When's the last time you had it serviced?
__________________

__________________
2001 National Tradewinds 7370 300 Cat
2011 Jeep Wrangler Unlimited Sport
Officially fulltiming. The Journey Begins
Vegasdan is offline   Reply With Quote
Old 08-27-2010, 05:33 PM   #3
Senior Member
 
denochs's Avatar
 
Fleetwood Owners Club
Join Date: Oct 2009
Location: North Carolina
Posts: 702
When you restart it, does it continue to run? If so, the temp sensor allows you to override the code by restarting it right away. You should have those codes in your Onan manual. My genny is completely encased by a cover. However, it is not difficult to remove and replace that sensor.

Dave
__________________
David & Gail Salisbury, NC
2003 American Eagle 42'
denochs is offline   Reply With Quote
Old 08-28-2010, 05:55 AM   #4
Senior Member
 
H. Miller's Avatar
 
Monaco Owners Club
Texas Boomers Club
Join Date: Jan 2009
Posts: 2,523
We were having approx the same problem. The "start" switch has a "prime" position and we now prime for 20-30 seconds and then start. It was acting like the gas line had siphened back to the tank. No problem now.
If there is in fact a real problem, the Onan owners manual describes how to get the secondary specific code (more lights flashing) for the actual descrepancy.
__________________
Hal & Ginny Miller '04 Beaver Santiam PRT40
'04 Saturn Vue - US Gear Brake - Blue Ox tow
4"girls" (3 Irish Setters - 1 Retriever) - RIP Annie
H. Miller is offline   Reply With Quote
Old 08-28-2010, 06:30 AM   #5
Senior Member
 
denochs's Avatar
 
Fleetwood Owners Club
Join Date: Oct 2009
Location: North Carolina
Posts: 702
Hal is correct, you can use the start switch on the generator to get the specific code. Have the genny slide out, start it from the cockpit or outside, and when it stops, hold the switch in the up (opposite from start) position for 5 seconds. You have to do this immediately after it stops as you only have a certain amount of time. Just remember to use the switch on the genny to get the code.

Dave
__________________
David & Gail Salisbury, NC
2003 American Eagle 42'
denochs is offline   Reply With Quote
Old 08-28-2010, 01:36 PM   #6
Senior Member
 
ImagineIF's Avatar
 
Join Date: May 2010
Posts: 1,045
Hal/Dave, thanks. I'll check out the actual code. The unit was recently serviced, so not suspecting routine service items.

Gil
__________________

__________________
Gil
99 Country Coach
Prevost XL 45 Conversion
ImagineIF is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan 1,000 hour service questions CWHTRAINS RV Systems & Appliances 9 08-03-2010 10:14 PM
First experience at PI Service Center Jim & Bona Excel Owner's Forum 9 04-18-2009 03:21 PM
Caution - Coach-Net Road Service Restrictions jimlawman Monaco Owner's Forum 14 11-15-2008 09:39 AM
FL Factory Service (Gaffney) Gary RVRoamer Freightliner Motorhome Chassis Forum 10 04-27-2007 01:36 PM
Workhorse Builds Diesel Service Network While Expanding Service Support DriVer RV Industry Press 1 04-07-2005 04:59 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.