Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-09-2008, 04:00 PM   #1
Senior Member
 
bdpreece's Avatar
 
Monaco Owners Club
Join Date: Mar 2000
Location: Woodburn Oregon USA
Posts: 2,598
I have an Onan 7500 quiet diesel that was running fine when I put it to bed the first part of November. Now when I connect the batteries up the light comes on like the generator is running but it is not and the generator will not crank. I reset the circuit breaker but this did not fix. I then found in the manual where there are fuses under the plate where the coolant cap is. When I move the coolant system hoses and the wires around them the generator will start and run for various times before stopping then I go through the whole moving process again and it will start again. I have tried to remove the front cover from the generator to access the wires but it will move but not come off like there is a slide post or something I need to clear but I cannot see. Has anyone had the front cover off and if so what am I missing. Or if you have any other ideas how to solve my problem I am open to suggestions.
__________________

__________________
Brian, Loretta & Daisy (Golden Retriever)
2008 Holiday Rambler Endeavor 40 PDQ , ISL 400
2014 Ford Explorer toad
bdpreece is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-09-2008, 04:00 PM   #2
Senior Member
 
bdpreece's Avatar
 
Monaco Owners Club
Join Date: Mar 2000
Location: Woodburn Oregon USA
Posts: 2,598
I have an Onan 7500 quiet diesel that was running fine when I put it to bed the first part of November. Now when I connect the batteries up the light comes on like the generator is running but it is not and the generator will not crank. I reset the circuit breaker but this did not fix. I then found in the manual where there are fuses under the plate where the coolant cap is. When I move the coolant system hoses and the wires around them the generator will start and run for various times before stopping then I go through the whole moving process again and it will start again. I have tried to remove the front cover from the generator to access the wires but it will move but not come off like there is a slide post or something I need to clear but I cannot see. Has anyone had the front cover off and if so what am I missing. Or if you have any other ideas how to solve my problem I am open to suggestions.
__________________

__________________
Brian, Loretta & Daisy (Golden Retriever)
2008 Holiday Rambler Endeavor 40 PDQ , ISL 400
2014 Ford Explorer toad
bdpreece is offline   Reply With Quote
Old 01-09-2008, 04:55 PM   #3
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 12,324
Hi Brian,
The plate that hides the radiator cap and what you are looking for is held in place by 2 screws? If so you have the same as me. After removing the two screws (on the bottom of the plate) it will remain in position because of a slider flap on the top. Swing the bottom out just enough so the bracket that holds the radiator cap will clear the front cover (just above the on/off switch). With your right hand slide the cover/cap assembly down toward the on/off switch. At the same time, with your left hand hold and twist the radiator cap hose (I forget if it is clockwise or counter clockwise). The radiator cap/hose must be freed from the cover plate. They are in a bracket attached to the plate. Once the cap/hose is free of the cover plate you will be able to access the area you are looking to investigate.
__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 01-09-2008, 07:07 PM   #4
Senior Member
 
bdpreece's Avatar
 
Monaco Owners Club
Join Date: Mar 2000
Location: Woodburn Oregon USA
Posts: 2,598
I guess I was not clear in what I have already done. I have that part off and can pull the hoses and wires with fuses up enough to access them. I have cleaned the fuse pins and checked the wires I can get to. Some where in this mess of wires is either a short or open. If I move everything around the gen will start and run for anywhere from a few seconds to several minutes. I need to figure out how to get the entire front panel of the generator off to be able to access the rest of the wiring. I am pretty sure this is where my problem is I just can't get to it.
__________________
Brian, Loretta & Daisy (Golden Retriever)
2008 Holiday Rambler Endeavor 40 PDQ , ISL 400
2014 Ford Explorer toad
bdpreece is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan 7.5 QD (Quiet Diesel) Generator GStream40 RV Systems & Appliances 11 06-15-2008 08:10 PM
Onan Hybrid Quiet Diesel HighwayRanger MH-General Discussions & Problems 13 02-29-2008 04:07 PM
Onan 4K -- not so quiet GLWilliams58 Boondocking 9 09-05-2007 06:09 PM
The Quiet(er) Onan... Steady Eddie MH-General Discussions & Problems 3 05-09-2006 05:45 AM
High dollar ONAN Quiet Diesel not worth it! Dale Tomlinson Winnebago Industries Owner's Forum 2 05-17-2005 07:24 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.