Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-01-2006, 03:48 AM   #1
Senior Member
 
Join Date: Jan 2005
Location: Destin, Fl
Posts: 530
Onan was fixed yesterday at Cummins Power South in Atlanta. It was a broken pin in one of the multipin connectors under the cover.

Great folks at Cummins Power South.

John, 2005 4502 Essex, heading home
__________________

__________________
John,
2015 LADP, Destin, Fl
2010 Buick Enclave, SMI AFOne
racer0624 is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-01-2006, 03:48 AM   #2
Senior Member
 
Join Date: Jan 2005
Location: Destin, Fl
Posts: 530
Onan was fixed yesterday at Cummins Power South in Atlanta. It was a broken pin in one of the multipin connectors under the cover.

Great folks at Cummins Power South.

John, 2005 4502 Essex, heading home
__________________
John,
2015 LADP, Destin, Fl
2010 Buick Enclave, SMI AFOne
racer0624 is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Onan 4.0 won't start, HELP! twinbubba Toy Haulers Discussion 8 04-25-2007 09:50 AM
Onan won't start racer0624 MH-General Discussions & Problems 12 10-28-2006 11:13 AM
Onan Emerald Plus won't start RonTon Winnebago Industries Owner's Forum 7 12-13-2005 11:08 AM
9/2 UPDATE: Xantrex/auto gen start installation update.. kind of long.. John_Canfield Winnebago Industries Owner's Forum 7 09-03-2005 06:48 PM
Onan Emerald Plus won't start RV Systems & Appliances 7 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.