Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-16-2009, 11:34 AM   #1
Member
 
WVCoalminer's Avatar
 
Newmar Owners Club
Join Date: Mar 2009
Posts: 31
PowerGear Levelers won't retract

I put the levelers down in auto mode and when I went to retract them all the lights on the panel flash. I have tried turning it on and off and turned the engine on and off nothing works. It is a model #140-1226. Motorhome setting beside our house.
__________________

__________________
Bill
2008 Newmar Grandstar 3750 Fred
2008 Smart Car
WVCoalminer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-16-2009, 12:06 PM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Try a reset; turn panel on and push all four diamond shape buttons at the same time untill panel resets. Push retract all jack button. What happens?
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 05-16-2009, 01:16 PM   #3
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 22,832
Power Gear makes both electric and hydraulic jacks. Now if yours are electric, stop reading NOW

Hydraulic if you locate the pump/tank you will find 3, yes 3 valves (I know there are 4 jacks, ti's a tripod system, two jacks are "Common")

You can unscrew the black caps.. And, though I did not try it, I"m guessing you can then push the plunger under the cap to retract the jacks.. I will try it next week, When I next raise jacks. Just to see if it works that way

You might also click this link http://www.powergearus.com/

Alas I see only SOME models have the manual override option. IF you can not get them up any other way you can "Crack" (loosen) he hose fittings, this will let the hydraulic fluid leak (Please use a bucket) and enable you do raise the jacks and visit your friendly service center... Don't forget the check book (ouch)
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 05-17-2009, 10:00 PM   #4
Junior Member
 
JWRunz's Avatar
 
Winnebago Owners Club
Join Date: Apr 2009
Posts: 3
Quote:
Originally Posted by WVCoalminer View Post
I put the levelers down in auto mode and when I went to retract them all the lights on the panel flash. I have tried turning it on and off and turned the engine on and off nothing works. It is a model #140-1226. Motorhome setting beside our house.
Here's a link for the manual for your model controller: http://www.powergearus.com/DATA/p%20...20140-1226.pdf

Are your jacks retracting and the lights remain on, or are they stuck down? I just bought an Itasca 35J and we took it out for the first time this weekend and we had a similar problem. The jacks retracted, but the warning light wouldn't turn off and the thing went crazy (warning bells and lights) when we tried to drive (I did a visual and the jacks were up, and we needed to get somewhere, so I decided to put up with the noise). After a few minutes, the lights and noise went off and we continued on our way.

When I got home, I looked at the link above, and started trying to trouble shoot (before I resort to the dealer and waranty repair). I found I was able to loosen the sensor by hand, and when I retightened it (to approximately 1 1/4 to 1 1/2 past finger tight) the system now appears to work correctly. I ran the autoleveler and retracted and they now appear to be working as designed.

Sorry for the long answer, but look at the back of the link above for some troubleshooting Q/As. Also, the tip sheets (in my case, #81) explained how to remove and install the sensor (if this turns out to be your problem).

Sorry for the long answer, and hope this helps.

- JWRunz
__________________
Jeff, Tina, Zach, Amanda, Patches and Buddy
2009 Itasca Sunova 35J
JWRunz is offline   Reply With Quote
Old 05-18-2009, 12:38 PM   #5
Member
 
WVCoalminer's Avatar
 
Newmar Owners Club
Join Date: Mar 2009
Posts: 31
Rv Wizard,
Thank you, that worked. All jacks are up and I can move again. The powerGear manual is missing from my Newmar box. I had looked on their website and they didn't have this tip. Thanks to everyone for your replys, thats whats great about this forum.
Thanks Again, Bill
__________________
Bill
2008 Newmar Grandstar 3750 Fred
2008 Smart Car
WVCoalminer is offline   Reply With Quote
Old 05-19-2009, 04:20 AM   #6
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Bill, you are welcome. Take care and keep us posted.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 05-19-2009, 06:36 PM   #7
Junior Member
 
Join Date: Mar 2008
Posts: 16
Just a follow up - I had the same problem and took my manual to the dealer to see if there was anything I was missing. It seems that there was an update to the manual (which the dealer downloaded off their site) which now addresses this very problem. He gave me a photocopy to insert into my manual. You can try their site and look under manuals which you can download.
__________________

__________________
Benandlar is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Gear Levelers JOMARFL (FMCA 401058) Class A Motorhome Discussions 0 05-07-2009 06:01 AM
Camco Tri-leveler or Lynx Levelers? brianeco03 MH-General Discussions & Problems 4 05-03-2009 07:10 PM
Levelers wouldnt retract Chuck Linn Thor Industries Owner's Forum 13 06-30-2008 02:08 PM
HWH Levelers RocketDork Winnebago Industries Owner's Forum 7 10-27-2007 06:19 PM
Atwood Electric Levelers Ground Clearance Jim Martin PA Ford Motorhome Chassis Forum 1 05-30-2006 03:26 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.