Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-05-2010, 08:53 PM   #1
Senior Member
 
Wanabee FTer's Avatar
 
Gulf Streamers Club
Ford Super Duty Owner
Join Date: Jul 2010
Location: Golden Village Palms, CA
Posts: 1,988
Blog Entries: 12
Question about KIB systems monitor

I recently purchased my coach but did not get the owners manual for the systems monitor. It is a KIB unit that appears to be original to the coach. I just got all the gray and black water sensors operating properly, the LP and FW tank sensors and monitor LED's are working fine.
I am not sure how the LED's should display on the battery monitor. There is an LED next to C, G, F, and C. C appears to be a green charge indicator light when 120 volts is available, G has a Green LED but what does that mean? F is orangish? assume that is a battery full light, but should it be green or red? L displays a red LED but the batteries are new deep cycle and fully charged.
I went to KIB's website, but found no info. Any help on how the battery systems monitor is supposed to operated would be greatly appreciated.
__________________

__________________
John
'98 Gulf Stream Sunsport 325, 7.5L Banks Power Pack, Koni FSD's, Air Bags, ReadyBrute Elite,
2000 Honda Accord

Wanabee FTer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-06-2010, 02:35 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
You are correct in that "C" is charge. "G" = Good "F" = Fair "L" = Low This row is similar in operation in that the light start at the bottom and get filled in the more voltage the monitor sees. So a charging battery will have all the light in this row lit up.
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 10-06-2010, 08:25 AM   #3
Senior Member
 
Wanabee FTer's Avatar
 
Gulf Streamers Club
Ford Super Duty Owner
Join Date: Jul 2010
Location: Golden Village Palms, CA
Posts: 1,988
Blog Entries: 12
Thanks Mike,
So it works like all the other holding tank monitored systems, the more battery lights the better.
__________________
John
'98 Gulf Stream Sunsport 325, 7.5L Banks Power Pack, Koni FSD's, Air Bags, ReadyBrute Elite,
2000 Honda Accord

Wanabee FTer is offline   Reply With Quote
Old 10-06-2010, 06:25 PM   #4
Senior Member
 
Wanabee FTer's Avatar
 
Gulf Streamers Club
Ford Super Duty Owner
Join Date: Jul 2010
Location: Golden Village Palms, CA
Posts: 1,988
Blog Entries: 12
Found something strange when I was looking at the systems monitor today, the C- Charge light is staying on with land line disconnected and without engine or genset running. I could have swore last time I checked the C light was off when in self contained mode. Could it be a sticking solenoid or faulty convertor circuit board?
Not sure if I should be concerned about this.
__________________
John
'98 Gulf Stream Sunsport 325, 7.5L Banks Power Pack, Koni FSD's, Air Bags, ReadyBrute Elite,
2000 Honda Accord

Wanabee FTer is offline   Reply With Quote
Old 10-07-2010, 02:31 AM   #5
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
No need to be concerned. The surface charge of the battery might keep the "C" light lit for a little while but not long and the monitoring of the battery voltage is only fair for accuracy.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 10-07-2010, 10:50 AM   #6
Senior Member
 
Wanabee FTer's Avatar
 
Gulf Streamers Club
Ford Super Duty Owner
Join Date: Jul 2010
Location: Golden Village Palms, CA
Posts: 1,988
Blog Entries: 12
KIB just emailed me a nifty trouble shooting guide for the systems monitor, thought I would post incase anyone else has same concerns as me.

For systems monitor manufactured Jan '92 and later, the LED light will come on when the following voltages are seen in the coach batteries.

C - CHARGE 12.7 volts
G - GOOD 11.9 volts
F - FAIR 11.2 volts
L - LOW 6.0 volts
__________________
John
'98 Gulf Stream Sunsport 325, 7.5L Banks Power Pack, Koni FSD's, Air Bags, ReadyBrute Elite,
2000 Honda Accord

Wanabee FTer is offline   Reply With Quote
Old 07-20-2016, 03:14 PM   #7
Junior Member
 
Join Date: Jul 2016
Location: Hesperia, CA
Posts: 8
KIB K193 board

So I discovered the other day that the black and gray tanks are not connected to the corresponding display (black is in the gray column and gray is in the black column). Now this isn't mission critical but I do like to have things show what they should be showing.
Does anyone know which wires coming off the board connector is connected to the black sensor and which one goes to the gray sensor?
Or, does anyone have the installation/wiring schematic for this board?
Troy
__________________

__________________
k123911 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about "Monitor" TV used in 06? Alpines dgerstel Alpine Coach Owner's Forum 5 04-09-2008 05:30 PM
Vena Tank Monitor installation on Monaco Diplomat Dutch Star Don MH-General Discussions & Problems 2 05-09-2006 03:09 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.