Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-16-2008, 08:06 PM   #1
Senior Member
 
Join Date: Sep 2007
Location: FL
Posts: 124
My MH has the small automotive style horns in the engine bay area up front. They work fine. However, the chromed roof mounted horn does not work. Checked the horn fuse in the engine compartment and all looked good.

Any suggestions on how to trouble shoot this problem?
__________________

__________________
NavlAv8r is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-16-2008, 08:06 PM   #2
Senior Member
 
Join Date: Sep 2007
Location: FL
Posts: 124
My MH has the small automotive style horns in the engine bay area up front. They work fine. However, the chromed roof mounted horn does not work. Checked the horn fuse in the engine compartment and all looked good.

Any suggestions on how to trouble shoot this problem?
__________________

__________________
NavlAv8r is offline   Reply With Quote
Old 03-17-2008, 03:26 AM   #3
doc
Senior Member
 
doc's Avatar
 
Appalachian Campers
Join Date: Sep 2002
Location: Dixie !! (north Georgia) USA
Posts: 2,953
Are these air horns? If so check: switch that turns on compressor, compressor working? fuse to compressor, hose from compressor to horns, ground wire for system, debris in the tube//bell of horn
__________________
doc is offline   Reply With Quote
Old 03-17-2008, 04:54 AM   #4
Senior Member
 
Bob (WA0MQE)'s Avatar
 
Monaco Owners Club
Join Date: Jun 2003
Location: Between Colorado Springs, CO & Fulton, TX
Posts: 1,515
Blog Entries: 1
Did you by chance disconnect the ignition buzzer by pulling the wire off the fuse connector under the dash? I did this very thing awhile back because I didn't like the buzzer and realized abit later this also powered the simulated air horns on top of the mh. Or it could be this fuse that's blown also.
__________________
Bob 2006 Monaco Camelot 40PDQ
US Navy Carrier Battlegroup 1959/1963
Summer in Colorado, Winter Texas Gulf Coast
Bob (WA0MQE) is offline   Reply With Quote
Old 03-17-2008, 06:37 PM   #5
Senior Member
 
Join Date: Sep 2007
Location: FL
Posts: 124
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Did you by chance disconnect the ignition buzzer by pulling the wire off the fuse connector under the dash? I did this very thing awhile back because I didn't like the buzzer and realized abit later this also powered the simulated air horns on top of the mh. Or it could be this fuse that's blown also </div></BLOCKQUOTE>

Have not touched anything under the dash or anything to turn off any buzzers. The buzzers seem to sound every time I turn the ignition on. Also checked all the fuses I could find and none were blown.

Also, for Doc . . .

No, it must not be an air horn, as the MH is a gasser and I cannot find a small compressor anywhere.
__________________
NavlAv8r is offline   Reply With Quote
Old 03-24-2008, 05:31 PM   #6
Senior Member
 
Join Date: Sep 2007
Location: FL
Posts: 124
Follow up on my initial post.

Had a tech look at the horns today. He said there is power to the horns but the horns are bad. Seems strange to me that these roof horns, which should be designed for exposure to the elements, would fail within 4-5 years.

Anyway, I will get replacement horns in the near future.
__________________
NavlAv8r is offline   Reply With Quote
Old 07-07-2008, 08:10 PM   #7
Junior Member
 
Join Date: Jan 2006
Location: So California
Posts: 1
I have a '04 PA with roof horns that did not work either. Found that the tone adjustment on the horns were screwed all the way down to prevent the sound vibrator from working. Have adjusted them and they are working fine. Never could find the electricals that everyone suggested looking for, but don't have to now.
__________________
Earl T is offline   Reply With Quote
Old 07-07-2008, 09:08 PM   #8
Senior Member
 
LVJ58's Avatar
 
Join Date: Jul 2000
Location: Las Vegas, NV
Posts: 2,146
If yours are like mine, there's a small valve actuated by a solenoid that releases air from the tank to the horns. Mine quit working so I checked and was getting voltage to the solenoid. I disassembled the valve and found moisture and non use had caused it to stick. Cleaned & lubricated it with silicone spray, reassembled it and it worked. Before you buy new horns, you might want to check the air release valve first.

Best of luck, Jim
__________________

__________________
Jim & SherrySeward

2000 Residency 3790 v10 w/tags 5 Star tune & Banks system Suzuki XL7 toad
LVJ58 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
roof horns no worky cannon man National RV Owner's Forum 13 07-15-2008 04:41 PM
Air Horns bfisch MH-General Discussions & Problems 4 04-16-2008 07:29 AM
horns , and other gremlins WALLY NJ Winnebago Industries Owner's Forum 2 08-25-2007 05:25 AM
Air horns Jarhead1 MH-General Discussions & Problems 2 07-21-2007 02:43 PM
electric roof horns gordon23 MH-General Discussions & Problems 9 10-09-2005 10:50 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.