Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-01-2014, 02:39 PM   #1
HNA
Member
 
HNA's Avatar
 
Join Date: Mar 2012
Posts: 83
RVComfort.ZC Problem

I searched the forums and tried the recommended troubleshooting to no avail. My issue seems to be a little different then I have seen on here.

My problem is only with zone 1. A/C specifically. zone 2 works fine. If I try to change the temperature setting on zone 1, the thermostat locks up and the display shows two dashes and a 0. the only way to clear it is to remove the fuse. Does this sound like a thermostat problem, or something worse? What is the recommended replacement for this unit. Picture attached. Thanks!
Attached Thumbnails
Click image for larger version

Name:	photo.jpg
Views:	62
Size:	285.2 KB
ID:	69623  
__________________

__________________
Art and Heather
2001.5 Fleetwood Discovery 37u 330 Cat
HNA is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-01-2014, 05:05 PM   #2
Senior Member
 
gripper's Avatar
 
Fleetwood Owners Club
Join Date: Nov 2009
Location: Lutz, FL
Posts: 772
I'm having the same problem! I have an '05 Fleetwood providence and have two spare t-stats, the same type as you show. For the past 5 years, I have been switching stats, when I see the "00" show up, or the stat, simply freezes up. I have been unplugging the existing one and plugging in a spare. I read another post by Pat Geddes, that spoke of the same problem. He finally found that one could order an electronic part, from Fleetwood (Choke Filter, #355469), and the cost was only $20.00. He said that solved the electronic interference problem, usually a flourescent ceiling light. I plan to do just that, when my Providence gets out of the shop, at LazyDays, in Tampa. If you are interested, the Fleetwood number is 800-322-8216.

Pat's post is "Heat/AC Thermostat Reads 00". Do a search of previous posts, if you want to read what he had to say.
__________________

__________________
Roland & Jerri, with Maggie & Mollie, our Pups; '05 Fleetwood Providence, 39' DP; '08 Saturn. "The difference between genius and stupidity is genius has it's limits" (Einstein)
gripper is offline   Reply With Quote
Old 08-01-2014, 07:08 PM   #3
HNA
Member
 
HNA's Avatar
 
Join Date: Mar 2012
Posts: 83
Thanks for the info. It doesn't seem to be a fluorescent problem because they are not on and I'm still having the problem. Maybe I need to find a new t stat. It doesn't appear this model is available.
__________________
Art and Heather
2001.5 Fleetwood Discovery 37u 330 Cat
HNA is offline   Reply With Quote
Old 08-01-2014, 07:25 PM   #4
Senior Member
 
gripper's Avatar
 
Fleetwood Owners Club
Join Date: Nov 2009
Location: Lutz, FL
Posts: 772
I didn't mean that florescent lighting was the only problem, just typically one of the things that could cause DC interference, with the t-stat (usually a bad ballast). A tech, at Lazy Days, told me to check all DC equipment. Could be a charger or any piece of equipment plugged into a cig. lighter, etc. Good luck. I purchased two additional t-stats, at different times and have been swapping all 3 of them out, for years. I still have the problem.

If you wanted to send me an IM, with your email, I could forward the letter from the LD tech, with the info he sent me, on how to find the DC interference. However, I didn't find any on mine, but my RV is now, in the shop, getting a new front A/C.
__________________
Roland & Jerri, with Maggie & Mollie, our Pups; '05 Fleetwood Providence, 39' DP; '08 Saturn. "The difference between genius and stupidity is genius has it's limits" (Einstein)
gripper is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel supply problem Ford 460 PaceMaker96 Ford Motorhome Chassis Forum 39 04-20-2014 10:00 AM
Problem with 1998 Dutch Star side windows Alberta Al Class A Motorhome Discussions 3 03-27-2014 10:33 AM
04 Essex gen starter problem ryankaty Newmar Owner's Forum 1 03-18-2014 09:10 AM
Hadley problem Dave999 Class A Motorhome Discussions 1 01-12-2014 04:57 PM
Fridge Problem Rossi6998 Winnebago Industries Owner's Forum 22 01-10-2014 09:02 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.