Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-05-2011, 07:13 PM   #1
Senior Member
 
Dunner's Avatar
 
Join Date: Jun 2011
Location: Phx, Arid~zona
Posts: 11,106
Speedo Problems

[Moderator Edit]
I'm talking about a speedometer problem. My 2004 F53 National Sea Breeze speedo jumps to 42 MPH and stays there as soon as I start moving. I found and re-seated 3 connectors on the transmission 5+ times and won't know if that helped until tomorrow when I go get my new Toyo tires. It does drop to zero after I stop.

Is this a know issue with the F53 chassis?
__________________

__________________
2004 32' National Sea Breeze 1311 Class A on a F-53 Chassis, CHF, TST TPMS, 5Star Tune.
If Dunner (RVM23) can't fix it, it ain't broke!
Cheap Handling Fix Poll. Click Here to vote?
Dunner is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-06-2011, 03:42 PM   #2
Senior Member
 
Dunner's Avatar
 
Join Date: Jun 2011
Location: Phx, Arid~zona
Posts: 11,106
Re-seating the connectors fixed my speedo.
__________________

__________________
2004 32' National Sea Breeze 1311 Class A on a F-53 Chassis, CHF, TST TPMS, 5Star Tune.
If Dunner (RVM23) can't fix it, it ain't broke!
Cheap Handling Fix Poll. Click Here to vote?
Dunner is offline   Reply With Quote
Old 10-06-2011, 03:46 PM   #3
Senior Member
 
RJay's Avatar
 
Newmar Owners Club
Join Date: Jan 2010
Posts: 4,589
That's great! Thanks for letting us know what fixed it.
__________________
2007 Newmar DSDP 4023
Discovery is seeing what everyone else has seen and thinking what no one else has thought.
If you want to see what man made go East; if you want to see what God made go West.
RJay is offline   Reply With Quote
Old 10-06-2011, 03:49 PM   #4
Senior Member
 
Dunner's Avatar
 
Join Date: Jun 2011
Location: Phx, Arid~zona
Posts: 11,106
Found out years ago that re-seating and/or a hammer are the first steps in trouble shooting.
__________________
2004 32' National Sea Breeze 1311 Class A on a F-53 Chassis, CHF, TST TPMS, 5Star Tune.
If Dunner (RVM23) can't fix it, it ain't broke!
Cheap Handling Fix Poll. Click Here to vote?
Dunner is offline   Reply With Quote
Old 10-06-2011, 04:01 PM   #5
Senior Member
 
RJay's Avatar
 
Newmar Owners Club
Join Date: Jan 2010
Posts: 4,589
The problem with using a hammer is that after awhile everything starts looking like a nail.
__________________
2007 Newmar DSDP 4023
Discovery is seeing what everyone else has seen and thinking what no one else has thought.
If you want to see what man made go East; if you want to see what God made go West.
RJay is offline   Reply With Quote
Old 10-15-2011, 02:18 PM   #6
Senior Member
 
rver98's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Dec 2010
Posts: 482
"Speedo Problems" - I switched to boxer briefs several years ago and don't feel so cramped up.

Sorry couldn't resist the opportunity
__________________
05 Tiffin Phaeton 40 QDH Cat 350+ ScanGuage D
MP-8, Aero Muffler, AFE Filter, Koni FSD, MCU's, Reflex SS, Ready Brake Elite, Ford F150 4x4 EcoBoost
rver98 is offline   Reply With Quote
Old 10-15-2011, 02:43 PM   #7
Elf
Senior Member
 
Elf's Avatar
 
Tiffin Owners Club
Join Date: Oct 2010
Location: Spokane, WA
Posts: 239
Quote:
Originally Posted by Dunner View Post
Found out years ago that re-seating and/or a hammer are the first steps in trouble shooting.
For many items my first step is to check the position of the "on/off" switch.
__________________
Ethan and Lisa
2005 Allegro Bus 38DP
2012 Honda CRV
Elf is offline   Reply With Quote
Old 10-15-2011, 04:42 PM   #8
Senior Member
 
Dunner's Avatar
 
Join Date: Jun 2011
Location: Phx, Arid~zona
Posts: 11,106
That's a good idea, especially if you are changing engine oil.
__________________
2004 32' National Sea Breeze 1311 Class A on a F-53 Chassis, CHF, TST TPMS, 5Star Tune.
If Dunner (RVM23) can't fix it, it ain't broke!
Cheap Handling Fix Poll. Click Here to vote?
Dunner is offline   Reply With Quote
Old 10-15-2011, 05:06 PM   #9
Senior Member
 
Join Date: Sep 2009
Posts: 524
Would someone show ELF where the on/off switch on his speedo is. I don't have the time to do it.
__________________
Wayne MD is offline   Reply With Quote
Old 10-16-2011, 05:42 AM   #10
Elf
Senior Member
 
Elf's Avatar
 
Tiffin Owners Club
Join Date: Oct 2010
Location: Spokane, WA
Posts: 239
Quote:
Originally Posted by Wayne MD View Post
Would someone show ELF where the on/off switch on his speedo is. I don't have the time to do it.
That's why it's MANY...not ALL.
__________________

__________________
Ethan and Lisa
2005 Allegro Bus 38DP
2012 Honda CRV
Elf is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical problems due to switches.. Zbugsii Monaco Owner's Forum 1 06-07-2011 03:19 PM
Major electrical problems jackthebear Class A Motorhome Discussions 2 05-22-2011 07:02 PM
wiper problems bobeb Newmar Owner's Forum 2 11-07-2010 09:33 PM
Brake Problems lera Alpine Coach Owner's Forum 4 04-05-2009 01:07 PM
Transmission Problems Duner Workhorse and Chevrolet Chassis Motorhome Forum 7 10-21-2008 05:44 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.