Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-29-2010, 08:20 AM   #1
Member
 
FOSJ's Avatar
 
Monaco Owners Club
Join Date: Aug 2010
Location: Lake Mead Recreation Area, Nv
Posts: 89
Blog Entries: 10
Splendide 2100...Won't Spin???????

Joan and I took the RV out to a local park for the weekend and invited the grandkids to come along. After a full day of swimming we wanted to dry the towels so they could be used again the next day. This was the first occassion to use the washer/dryer since we bought the RV in August. Read through the user manual and attempted to use the "Dry' cycle. The unit turned on and began to heat up, but would not spin. On our unit there are 3 dry cycles, Tried all 3 with the same result: unit heated up, but no spin. Then tried the Spin Cycle. No luck there either. I could hear the unit doing something, but no Spin.

Any suggestions?
__________________

__________________
Joan & Steve www.fosj-steve.blogspot.com
'05 Monaco Knight 40PLQ, '08 HD StreetGlide & 2014 Jeep Rubicon Unlimited 4x4
FOSJ is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-29-2010, 10:16 AM   #2
Senior Member
 
Elkhartjim's Avatar


 
Newmar Owners Club
Texas Boomers Club
Freightliner Owners Club
Join Date: Jul 2008
Location: Don't mess with Texas
Posts: 3,116
Give support at Westland Sales a call. I understand they are very helpful.

Their number is near the bottom of the page.

Splendide Laundry Centers Customer Support Center
__________________

__________________
Jim with Judy
2017 Newmar Ventana 4369, 2005 Jeep Wrangler (Rock Crawler), 2016 Jeep Wrangler (Mall Crawler)
Elkhartjim is offline   Reply With Quote
Old 11-29-2010, 04:50 PM   #3
paz
Senior Member
 
paz's Avatar
 
Join Date: May 2005
Location: Full-timers - Home is where we park it.
Posts: 4,716
It could be one of several things bad motor, bad belt or maybe a bad circuit board. It's sometimes a little hard to get through to Westland sales, but if you leave a message, they'll call back.

They are very helpful once you get hold of them. They helped me track down 2 simultaneous problems and went out of their way to get parts shipped overnight even though it was after the regular UPS pickup time.
__________________
2015 DRV Tradition 375KPS
2015 Chevy Duramax 3500HD LTZ Dually
Full-timers...Home is where we park it.
Check out our blog: Living Our Dream
paz is offline   Reply With Quote
Old 11-29-2010, 05:04 PM   #4
a k
Registered User
 
Newmar Owners Club
Join Date: Jun 2009
Posts: 1,142
Pull the top off and see if, I think,is a blue wire pulled off the dry sensor.. You should be getting a code that tells you why it is screwed up.
__________________
a k is offline   Reply With Quote
Old 11-30-2010, 04:29 AM   #5
Senior Member
 
Jackm's Avatar
 
Workhorse Chassis Owner
Join Date: Nov 2005
Posts: 627
Sounds like the belt might have fallen off. Be careful when you put it on. It's easy to get pinched real hard (guess how I know). To access the belt, pull the unit out and take off the rear panel. Best of luck.

Jack
__________________
2004 Winnebago Brave 34D with the usual add-ons
Jackm is offline   Reply With Quote
Old 11-30-2010, 06:38 PM   #6
Member
 
FOSJ's Avatar
 
Monaco Owners Club
Join Date: Aug 2010
Location: Lake Mead Recreation Area, Nv
Posts: 89
Blog Entries: 10
Thanks all for your input. And special thanks to Jackm; took the dryer out of the shelf, removed the back and the belt had indeed fallen off the pulley. 15 minutes and we were up and running.
Thanks again.
__________________

__________________
Joan & Steve www.fosj-steve.blogspot.com
'05 Monaco Knight 40PLQ, '08 HD StreetGlide & 2014 Jeep Rubicon Unlimited 4x4
FOSJ is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Splendide 2100 drying cycle adj RV Systems & Appliances 4 12-22-2009 07:05 AM
Splendide 2100 How full should the drum be???? Latitude MH-General Discussions & Problems 5 03-25-2009 08:12 PM
Splendide 2100 washer combo Yappy Newmar Owner's Forum 9 08-28-2007 05:50 PM
Splendide 2100 powermower Winnebago Industries Owner's Forum 4 07-11-2007 06:17 AM
Splendide 2100 in 2004 Horizon arkaussie Winnebago Industries Owner's Forum 17 02-20-2006 07:06 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:19 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.