RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-27-2009, 08:05 PM   #15
Senior Member
 
Join Date: Oct 2009
Location: Franklinville NY
Posts: 163
My Onan Emerald generator has 43hrs on it in 20 years . Would not start no spark no gas. My dad hadn't run it in 15yrs he owned it and it had no fuel shut off. Years of varnish in the carb. Cleaned the points with a file and then took the bottom off the carb and cleaned all the gunk out and a oil change now runs like new. Fix/elemnate one problem at a time.
1 Check for spark .............. A if yes go right to the carb
B if no clean points/ electronics then see #1
__________________

__________________
Mike
Have Flyrod Will Travel
87 Coachman Leprechaun
ischua is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-27-2009, 10:59 PM   #16
Senior Member
 
KC1BUD's Avatar
 
Winnebago Owners Club
Join Date: May 2008
Posts: 497
Quote:
Originally Posted by Big Dan View Post
Hal,
It's supposed to run on gasoline from the chassis tank, but shut off at 1/4 tank so that one can't run themselves out of gas with the generator. From what I've read here, that seems to be a fairly standard mode of operation, yes?

I normally go at a problem like this from the standpoint that it needs fuel, spark, and compression, timed properly, to start and run. But being so green to this, I'm hoping I'm just overlooking something really simple. Like, should I unplug the shore power? Or should the engine be running to start the genset? Ignition key in the accessory postition, perhasps? I can't imagine why it would need to, but I'm learning really quickly just how much I don't know. I am, however, lovin' every minute of it.

Thanks for your reply, and please keep 'em coming.

Dan
Dan,


I must admit I like your name. Here is what you do. If it is a generator that runs on gasoline follow the gas line from the generator's carburetor back to the motor-home gas tank. There should be some kind of a fuel shut off that is off.
Go even further back generators had winter/summer settings that could affect the running of them.

I had an 1985 motor home that had a generator older than the motor home. It had a fuel bowl(for trapping dirt and water) and the winter/summer switch, all of these things had a direct outcome on whether the generator ran or not.If you look on line you might find a rudimentary owners manual to help you in situations like these.

I hope this helps.

Happy New Year!
__________________

KC1BUD is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RV genset to power house during power outage McDanie1 Newmar Owner's Forum 8 07-16-2009 08:54 AM
Onan Genset 5500 gas HGJAB model not starting always udbe2 RV Systems & Appliances 9 05-19-2009 06:55 PM
Genset Emerald I onan, problems starting Hemi Vintage RV's 12 04-06-2008 07:12 AM
ONAN Genset starting issue Fried MH-General Discussions & Problems 15 11-21-2007 02:15 PM
GENSET starting problem (SOLVED) Belgique Winnebago Industries Owner's Forum 5 06-25-2007 10:51 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.