Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-16-2010, 06:29 PM   #1
Junior Member
 
Join Date: Jul 2009
Posts: 1
Tansfer Switch problem???

I have a 08 newmar Kountry star 3910 and was wondering if anyone has run in to the problem of not being able to hook up shore power for more than 10 seconds without transfer switch disconnecting? Everything works fine in coach when generator is running
__________________

__________________
BirdBus 08 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-16-2010, 07:25 PM   #2
Senior Member
 
Country Coach Owners Club
Vintage RV Owners Club
Florida Cooters Club
Join Date: Aug 2010
Location: Central Florida
Posts: 337
BireBus 08,
WITH THE SHORE POWER DISCONNECTED AND NO GENERATOR RUNNING:

1. Open up the transfer switch and tighten all leads.
2. Check the spring-loaded switch for loose play, weak springs, or carbon on the contacters on both sides of the feed.
3. Clean everything up, button up the switch and try it again on shore power.

Hope this helps...
Jim
__________________

__________________
Jim and Fran in Central Florida
1989 Country Coach Sedona Mark V
Turbocharged Detroit Diesel 8.2L "Fuel Pincher"
Good man is offline   Reply With Quote
Old 09-16-2010, 07:30 PM   #3
a k
Registered User
 
Newmar Owners Club
Join Date: Jun 2009
Posts: 1,142
Do you have a surge protector problem maybe?
__________________
a k is offline   Reply With Quote
Old 09-17-2010, 03:45 AM   #4
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
I would suspect the pedestal has a problem of not wired correctly or a loose connection, tripped breaker. Have you tried more than one site or pedestal connection?
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 09-19-2010, 01:06 PM   #5
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,096
Your coach may have a power line monitor built into the transfer switch - mine does. If it detects a problem, e.g. a improperly wired pedestal or low voltage, it automatically disconnects. The problem could be in the camp site pedestal, or could be a short in your shore power cord. Does this problem happen in different campsites, or only one particular place?
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Cut-off Switch Problem chiefdave MH-General Discussions & Problems 3 06-28-2009 04:00 AM
Brake light switch installation and part number GTHill Alpine Coach Owner's Forum 12 01-29-2009 09:15 AM
Heater problem again - repeated 'limit switch' failure. What to do? EAB 5th Wheel Discussion 5 03-02-2008 07:02 PM
Allison 1000 Overdrive On/Off Switch troth Workhorse and Chevrolet Chassis Motorhome Forum 31 07-12-2006 11:53 AM
Generator switch problem. resqguy Winnebago Industries Owner's Forum 3 09-28-2005 05:04 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:06 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.