Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 04-11-2009, 08:51 AM   #1
Junior Member
Brad10's Avatar
Join Date: Jul 2008
Posts: 13
Water Pump Problem

My water pump will not turn off when connected to shore water supply. It does not run all the time, only when a faucet is turned on or when I change the valve configuration for filling the tank and the water is actually flowing into the tank.

My water pump has 3 different switch locations, I suppose they operate a relay. When the switches are operated the indicator light on the switch comes on or off like it should. If off and I connect and fill the tank the light on the switch comes on as if it has been turned on or if off and I turn on a faucet it automatically comes on, even if connected to shore water.

Anyone with any advice on this phenom.

Brad & Monica,
Jamie 15, Sam13 and Jesse 6
1999 40' American Eagle
Brad10 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-11-2009, 02:19 PM   #2
Senior Member
GaryKD's Avatar
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 11,772
Hi Brad,
This may sound like a dumb suggestion, but please make sure all the water pump switches are in the off position. Some coaches (like mine) are wired so all switches must be in the off position for the pump to be really off.

The next question is did this just start happening or has it been this way for a long time?

2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 04-12-2009, 06:16 AM   #3
Junior Member
Brad10's Avatar
Join Date: Jul 2008
Posts: 13
Come to think of it, I have never verified that they all were off. They are instantaneous switches and I just assumed..... I will check all switch positions. I bought the coach used 2 years ago and it was happening then.

Brad & Monica,
Jamie 15, Sam13 and Jesse 6
1999 40' American Eagle
Brad10 is offline   Reply With Quote
Old 04-26-2009, 08:54 PM   #4
Senior Member
EasyDoesIt's Avatar
Fleetwood Owners Club
Join Date: Mar 2008
Location: Wisconsin
Posts: 163
It sounds to me like there may be a pressure sensing switch on your pump (perhaps a replacement pump) that has been wired to the momentary on circuit of your pump. It would then turn on when you have a faucet turned on because of the drop in pressure. Also when filling the tank, the pressure on the pump is relieved which would turn it on.
2008 Fleetwood Providence 39R - Great Floorplan
2010 GMC Acadia Toad w/SMI Air Force One Brake - Roadmaster Stowmaster - 3 minute hookup!
EasyDoesIt is offline   Reply With Quote
Old 04-26-2009, 09:23 PM   #5
Senior Member
Join Date: Oct 2005
Posts: 1,047
I would check the latching relay.The momentary switches activate the latching relay and if it is stuck it will not disengage.
bldrbob is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fix for Water pump on UFO Rear Engine Chassis gatayloe@prodigy.net Workhorse and Chevrolet Chassis Motorhome Forum 65 07-26-2009 08:34 PM
Water pump problems Overlander MH-General Discussions & Problems 5 07-03-2008 04:26 PM
Water pump whacked? Bruce and Jenna Excel Owner's Forum 11 04-24-2008 12:42 PM
Water pressure problem machman72 Class A Motorhome Discussions 4 05-31-2007 03:52 AM
Shuroflo Water Pump Acting Up Tom Norman RV Systems & Appliances 4 12-15-2005 05:30 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:13 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.