Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-18-2008, 09:00 AM   #15
Senior Member
 
Workhorse Chassis Owner
Join Date: Dec 2001
Posts: 985
Im glad it helped. I probly got the info from this site sometime in the past. You guys are right, this site is very informative.
__________________

__________________
2004 adventurer/22.5 workhorse....
jdsr is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-18-2008, 09:13 AM   #16
Senior Member
 
Workhorse Chassis Owner
Join Date: May 2004
Posts: 348
My display was changed two weeks ago. I have the "new" orange display and I see no dark area in the center such as Drifterpilot mentioned.

We are all so quick to be critical of Workhorse that I need to say that, in my case, I'm very pleased that they covered the replacement under waranty and North Trail (Fort Myers, FL) did an outstanding job of completing the repair in two days, which I did not think was possible.
__________________

__________________
2004 W22 National, Dolphin

UltraPower ECM Program
Joe Gilbert is offline   Reply With Quote
Old 12-18-2008, 02:37 PM   #17
Senior Member
 
Bruce H's Avatar
 
Join Date: Mar 2007
Location: Kingman AZ
Posts: 200
I am the second owner of my MH and my instrument cluster was in the same shape with lines going through it. Workhorse replaced mine with the new and improved orange display at no charge. I should say I still had several months left on the original warranty. Can't say enough good things about Workhorse and Newmar, they have been great to me.
__________________
2004 Newmar/Scottsdale, W22, Toad/2000 Jeep Cherokee Classic 4X4 Auto Trans, US Gear Brake System, Blue OX Tow Bar, Garmin 1450 MT GPS. RVing Since 1989. Life Is Good!!!
Bruce H is offline   Reply With Quote
Old 12-18-2008, 06:02 PM   #18
Member
 
Winnebago Owners Club
Join Date: Mar 2003
Location: Gloucester, Virginia
Posts: 31
Blog Entries: 1
My original cluster display went "out" at 20,000 miles and was replaced by Workhorse, labor included. This last one went out at 50,000 miles and was covered by Workhorse, minus the $125.00 labor charge. I have never had a problem with any Workhorse work and would go with another Workhorse chassis in a moment. I place my recent instrument cluster inconvenience with the dealership that installed the replacement cluster. They should have picked up immediately on the problem and corrected it before I picked up the coach.
__________________
03 Winnebago Adventurer 33V, W-20 Chassis, Vortec 8.1, Allison 1000 Tranny
Blue Ox Tow Bar, 2008 HHR
Drifterpilot is offline   Reply With Quote
Old 04-22-2017, 11:06 PM   #19
Junior Member
 
hasherbob's Avatar
 
Join Date: Apr 2017
Posts: 1
I played with the trip/mode buttons before reading the appropriate threads. now everything is in kilometers - any advice on getting it back to miles?
__________________
hasherbob is offline   Reply With Quote
Old 04-23-2017, 11:24 PM   #20
Senior Member
 
gruelens's Avatar
 
Join Date: Jul 2012
Posts: 1,289
Quote:
Originally Posted by hasherbob View Post
I played with the trip/mode buttons before reading the appropriate threads. now everything is in kilometers - any advice on getting it back to miles?
Using the search window at the top of the page revealed lots of forum entries regarding kilometers to miles. All the best.
https://www.google.com/search?q=chan...earch=irv2.com
__________________

__________________
George R. - Fulltiming since January '03
2007 Newmar Mountain Aire 3991
2012 Chevy Malibu LT1
gruelens is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
instrument cluster workhorse Jimsarah Workhorse and Chevrolet Chassis Motorhome Forum 4 01-19-2009 02:27 PM
Instrument Cluster LCD Display pace89 Winnebago Industries Owner's Forum 1 10-24-2008 07:45 AM
Instrument Cluster LCD Display pace89 Workhorse and Chevrolet Chassis Motorhome Forum 1 10-23-2008 12:09 PM
Workhorse Instrument Panel Display LR Workhorse and Chevrolet Chassis Motorhome Forum 8 03-12-2008 11:03 AM
Workhorse Instrument Cluster Display Workhorse and Chevrolet Chassis Motorhome Forum 17 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.