Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-10-2008, 09:28 PM   #1
Member
 
K Man's Avatar
 
Newmar Owners Club
Workhorse Chassis Owner
Join Date: Dec 2007
Location: Ontario, Canada
Posts: 94
The LED display on our '04 Kountry Star dash- is getting lines in and becoming harder to read. I have been told this means replacing the whole cluster!! Is there not a software fix for it?
__________________

__________________
'04 Kountry Star 3778 - Gas
08 Liberty Sport
K Man is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-10-2008, 09:28 PM   #2
Member
 
K Man's Avatar
 
Newmar Owners Club
Workhorse Chassis Owner
Join Date: Dec 2007
Location: Ontario, Canada
Posts: 94
The LED display on our '04 Kountry Star dash- is getting lines in and becoming harder to read. I have been told this means replacing the whole cluster!! Is there not a software fix for it?
__________________

__________________
'04 Kountry Star 3778 - Gas
08 Liberty Sport
K Man is offline   Reply With Quote
Old 07-11-2008, 04:58 AM   #3
paz
Senior Member
 
paz's Avatar
 
Join Date: May 2005
Location: Full-timers - Home is where we park it.
Posts: 4,716
I don't mean to split hairs, but the Workhorse display is LCD (Liquid Crystal Display), not LED (Light Emitting Diode). But the difference is important because if you scroll down to the Workhorse Forum and use the "Find" button at the top of the page do a search for "LCD," you should come up with several threads discussing the problem you are having.

I believe there was a recall that may have included some 2004 units, but I don't think it was for the problem you describe. The problem you describe may require replacing the Actia instrument cluster. You could also do a search for "Actia recall" to get more details.
__________________
2015 DRV Tradition 375KPS
2015 Chevy Duramax 3500HD LTZ Dually
Full-timers...Home is where we park it.
Check out our blog: Living Our Dream
paz is offline   Reply With Quote
Old 07-11-2008, 07:01 PM   #4
Senior Member
 
al koffman's Avatar
 
Workhorse Chassis Owner
Join Date: Feb 2000
Location: Kingman Az usa
Posts: 226
This is a very common problem with the IP and it is not a software problem, it definately is a hardware (LCD) problem.I have had 4 panels replaced because of this problem.
__________________
Al

2004 Allegro 32BA W20
al koffman is offline   Reply With Quote
Old 07-11-2008, 08:00 PM   #5
Senior Member
 
Workhorse Chassis Owner
Join Date: Oct 2004
Location: California Desert
Posts: 357
Take your coach to a Workhorse service center and they will most likely be able to replace the IP under warranty, even if your chassis is not within the 3yr/36K mile limit. The IP manufacturer (Actia) has had so many problems with the unit that they are basically authorizing all replacements.
__________________
2004 Southwind 32VS
2014 C-Max toad
Workhorse chassis
wilanddij is offline   Reply With Quote
Old 07-12-2008, 07:30 AM   #6
Member
 
K Man's Avatar
 
Newmar Owners Club
Workhorse Chassis Owner
Join Date: Dec 2007
Location: Ontario, Canada
Posts: 94
Thanks - I will see what Actia has to say about this.
__________________
'04 Kountry Star 3778 - Gas
08 Liberty Sport
K Man is offline   Reply With Quote
Old 07-12-2008, 07:45 AM   #7
Senior Member
 
Korryp's Avatar
 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Feb 2008
Location: Sammamish, WA
Posts: 159
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by al koffman:
This is a very common problem with the IP and it is not a software problem, it definately is a hardware (LCD) problem.I have had 4 panels replaced because of this problem. </div></BLOCKQUOTE>

I had mine replaced and Actia denied all responsibility. Workhouse paid for the LCD and charged my extended warranty for the labor.

Korry
__________________
'07 Fleetwood Bounder Diesel 38N
Brazel's added: MP-8, Aero Muffler, Koni FSD Shocks, Bell Crank and Comfort Ride Control Valves. '08 Ford Escape Hybrid, Brakemaster 9100
Korryp is offline   Reply With Quote
Old 07-12-2008, 12:26 PM   #8
Senior Member
 
Bruce H's Avatar
 
Join Date: Mar 2007
Location: Kingman AZ
Posts: 200
My info display did the same thing on my 2004 Scottsdale and I took it to an authorized Workhorse service center. It was out of warranty about 4 or 5 months, however because they had so many failures Workhorse replaced it at no charge to me. It is also much easier to read as the new one has an orange background instead of the gray back ground. No harm in trying to get workhorse to cover it.
__________________

__________________
2004 Newmar/Scottsdale, W22, Toad/2000 Jeep Cherokee Classic 4X4 Auto Trans, US Gear Brake System, Blue OX Tow Bar, Garmin 1450 MT GPS. RVing Since 1989. Life Is Good!!!
Bruce H is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Workhorse Instrument Cluster Display Drifterpilot MH-General Discussions & Problems 19 04-23-2017 11:24 PM
LED display K Man Workhorse and Chevrolet Chassis Motorhome Forum 9 07-18-2008 01:40 AM
Freightliner dash display goes to inverse display -- how to change? rv rick Freightliner Motorhome Chassis Forum 7 05-12-2008 10:46 AM
Workhorse Instrument Panel Display LR Workhorse and Chevrolet Chassis Motorhome Forum 8 03-12-2008 11:03 AM
Workhorse Instrument Cluster Display Workhorse and Chevrolet Chassis Motorhome Forum 17 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.