Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-08-2008, 05:27 PM   #1
Junior Member
 
Join Date: Dec 2008
Posts: 4
the charge cycle on the invertor never shuts off. in the setup phase we use 11.5 <10 and 5 as the parameters. it will charge up to 14 and continue-it never gets to the float stage. this occured when we got out of storage and plugged into shore power, there was a fault on the remote panel. we went thru the setup phase and charge-the 4 6 volts battaries cooked until the lp detector came on. checked the battaries and replaced-still they charge cycle never stops. and suggestions?
__________________

__________________
cuuckey is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-08-2008, 05:27 PM   #2
Junior Member
 
Join Date: Dec 2008
Posts: 4
the charge cycle on the invertor never shuts off. in the setup phase we use 11.5 &lt;10 and 5 as the parameters. it will charge up to 14 and continue-it never gets to the float stage. this occured when we got out of storage and plugged into shore power, there was a fault on the remote panel. we went thru the setup phase and charge-the 4 6 volts battaries cooked until the lp detector came on. checked the battaries and replaced-still they charge cycle never stops. and suggestions?
__________________

__________________
cuuckey is offline   Reply With Quote
Old 12-08-2008, 11:47 PM   #3
Junior Member
 
Join Date: Dec 2008
Location: San Francisco bay area
Posts: 2
Disconnect your Freedom 458 right away and get it repaired.
I wanted to ask more questions like how long did the batteries charge; but if you cooked a set of batteries and it is trying to do the same to the new batteries, I'd say, "Disconnect right away!

Sincerely,
Dave
__________________
davetheengineer is offline   Reply With Quote
Old 12-09-2008, 12:05 AM   #4
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
cuuckey, welcome to iRV2.com. We are glad to have you join us. I know that you have replaced the batteries but I have also ran into the fact that a new battery could have a weak or bad cell. I would make certain the battery bank is good first, then address the inverter/charger if needed. How much do you know about batteries? Do you have a hydrometer and know how to use it? Here are some links of interest:
http://www.usbattery.com/care.htm
http://www.dcbattery.com/faq.html#1
http://www.windsun.com/Batteri...m#Battery%20Charging
http://www.rvsolarelectric.com/sources.htm
http://www.batteryfaq.org

Good luck and keep us posted as to what you find.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 12-09-2008, 12:08 AM   #5
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
davetheengineer, we are also glad to have you join us here and look forward to reading of your adventures and experiences as well as any help you can provide along the way. I am sure you will find plenty of us that could use help now and then. Take care and enjoy the website and forums.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xantrex auto gen start problem Techie RV Systems & Appliances 3 09-15-2008 07:54 AM
Xantrex problem - outlets dead when connected to 120v Lindenberg Alpine Coach Owner's Forum 5 08-14-2008 08:47 PM
Xantrex Freedom 458 Inverter/Charger problem Duwain Pingenot Alpine Coach Owner's Forum 11 06-24-2008 10:29 PM
Xantrex 458 dnebout MH-General Discussions & Problems 6 12-07-2007 02:16 PM
Freedom 458 Series Inverter/Charger Sangone Winnebago Industries Owner's Forum 6 03-19-2005 10:50 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.