Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-07-2014, 09:59 PM   #1
Senior Member
 
rjsupersonic's Avatar
 
Join Date: May 2013
Posts: 487
Xantrex inverter/charger help

I have a Xantrex freedom 458 inverter/charger my coach is a 2007 National Seabreeze. We had a bit of a storm in Tennesse tonight and I lost the power on the tv and front electrical 110 volt plug. Everything else works 12 volt /110 volt. The led is flashing red on the Xantrex manual says to reset it but how??? any help is appreciated. Thanks
__________________

__________________
rjsupersonic is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-08-2014, 02:19 AM   #2
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,792
On the inverter there are reset buttons to push and there maybe two.
In QT's # 3 there is a section with info for all types of inverter/converters.
Some tv outlets up front have a small inverter that has a GFI outlet on it and the GFI has to be reset for inverter to work.
__________________

__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 06-08-2014, 05:26 AM   #3
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 22,825
As noted on some inverters there is a RESET button for a circuit breaker, sometimes 2 and often the inverter is mounted so as to make them hard to see (Like behind the thing).

On Xantrex (And many others) there is a 2nd reset procedure This is #1 on the "5 ways to re-boot a computer" (I will only do 1 and 5) 1 is the cold boot, when you turn it on in the AM (5 Is the steel toe boot, so you don't hurt your foot).

To "Cold boot" the inverter. REMOVE ALL POWER, both 12 and 120 volt, actually lift the battery lead.

Count, slowly, to 5, or have a cup of coffee (Brewed before you removed all power) then restore, does not mattery if you hook up 12 or 120 first but what I'd do is WITH THE INVERTER TURNED OFF at the inverter itself I'd hook up 12, then 120 then turn on the inverter.

On edit: Change What I "would do" to "What I Did"
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 06-08-2014, 08:17 AM   #4
Senior Member
 
Dave78Chief's Avatar
 
Join Date: Jun 2009
Posts: 1,513
Xantrex manual says to cycle the INVERT ON/OFF switch to manually reset. That will only work if the problem that caused the Fault indication has been cleared.

Dave
__________________
Dave in Virginia
1978 Winnebago Chieftain
Dodge M400 - 440-3
Classic Winnebago Site: http://www.classicwinnebagos.com/forum/index.php
Dave78Chief is offline   Reply With Quote
Old 06-08-2014, 09:35 AM   #5
Senior Member
 
rjsupersonic's Avatar
 
Join Date: May 2013
Posts: 487
Still not working just 2 flashing red lights....but the batteries seem to maintain their charge. Will call Xantrex as soon as they open?
__________________
rjsupersonic is offline   Reply With Quote
Old 06-08-2014, 10:07 AM   #6
Senior Member
 
Dave78Chief's Avatar
 
Join Date: Jun 2009
Posts: 1,513
Quote:
We had a bit of a storm in Tennesse tonight and I lost the power on the tv and front electrical 110 volt plug.
Quote:
just 2 flashing red lights
Indicates: Back-feed shutdown. Incorrect AC wiring.
Correct AC input wiring before use. Manually restart the system.

If both are flashing I suspect you have wet AC output connections at a receptacle from the storm.

Dave
__________________
Dave in Virginia
1978 Winnebago Chieftain
Dodge M400 - 440-3
Classic Winnebago Site: http://www.classicwinnebagos.com/forum/index.php
Dave78Chief is offline   Reply With Quote
Old 06-08-2014, 10:29 AM   #7
Senior Member
 
rjsupersonic's Avatar
 
Join Date: May 2013
Posts: 487
Thanks i will check, I may have missed an outlet but have found not wet ac outlets. The batteries have maintained at 12.6 volts for the last 20 hrs. will the engine on the coach still charge the batteries as we travel?( Engine and chassis batteries)? I have disconnected from shore power and used the generator no issues other than the flashing inverter lights and I can hear the Xantrex fan running non-stop. The only dead circuit is for the TV and front passenger outlet.I'm going to open the outlet box and check for water . This stuff always happens on a weekend when business are closed.
__________________
rjsupersonic is offline   Reply With Quote
Old 06-08-2014, 02:40 PM   #8
Member
 
aden's Avatar
 
Join Date: Nov 2011
Posts: 60
Check any ground fault plugs to see if they are tripped.
__________________
aden is offline   Reply With Quote
Old 06-08-2014, 03:20 PM   #9
Senior Member
 
rjsupersonic's Avatar
 
Join Date: May 2013
Posts: 487
Thanks, I checked all the gfi's nothing tripped.
__________________
rjsupersonic is offline   Reply With Quote
Old 06-09-2014, 07:51 AM   #10
Senior Member
 
Freightliner Owners Club
Join Date: Apr 2004
Location: Apache Junction, Az
Posts: 703
By the way, your batteries are reading 12.6, the inverter/charger is NOT working. It should be in the 13.4 Volt range.

You should have 2 circuit breaker panels. 1 panel will have a breaker label Inverter/Charger. Flip that one off. That should kill all AC power to the Inverter/Charger. Next goto the inverter/charger panel and turn off ALL the breakers in that one.

Next disconnect the Neg lead from the Inverter/Charger to the battery. Wait, coffee.
Re-connect battery cable.
Next turn on the inverter/charger breaker in circuit breaker box 1.
Look at your inverter or monitor panel.
Next turn on 1 by 1 of the breakers in the inverter/charger breaker box. Make sure you inspect the panel after each breaker is turned on.
__________________
Dale&Susan, 08 Alfa Gold, DaGirlsRv Blog
2015 F-150XLT_1600W Solar_880 AmpHr
Magnum_MS2812
gatorcq is offline   Reply With Quote
Old 06-09-2014, 12:27 PM   #11
Senior Member
 
rjsupersonic's Avatar
 
Join Date: May 2013
Posts: 487
Solved

Thanks for all the help. I called Xantrex this morning this is what they told me to do..... Disconnect from shore power, disconnect 12 volt power. Disconnect either the positive or negative from the inverter...wait a good hour. reconnect inverter terminal then turn on 12 volt system. make sure the DC power at the inverter is the same as at the batteries. then reconnect shore power. This cleared up the system which is now charging the batteries. I am relieved, was not looking forward to spending over 1k for a new inverter. I am posting this in case others may need the solution. Thanks again for all the help great forum!!

PS Xantrex has a 30 month warranty, turns out I was in month 29
__________________

__________________
rjsupersonic is offline   Reply With Quote
Reply

Tags
inverter, xantrex



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xantrex HF1800 Inverter Issue topdownman MH-General Discussions & Problems 1 05-28-2014 04:07 AM
Xantrex freedom 458 conveter/inverter adonh Class A Motorhome Discussions 13 05-25-2014 08:36 PM
Xantrex Freedom 458 adonh Class A Motorhome Discussions 7 02-01-2014 06:16 PM
Xantrex inverter/charger shows full charge at 12.2V michelb Class A Motorhome Discussions 3 07-16-2013 07:04 PM
Xantrex AGS lights on Remote and Controller deandec Class A Motorhome Discussions 1 06-12-2013 10:40 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.