Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-31-2013, 05:47 PM   #1
Member
 
Join Date: Jul 2012
Location: Shelbyville, KY
Posts: 77
10 Wrangler, Cooltech, Ready Brute problems

Sunday I did my first test run towing the 10 wrangler behind our 04 minnie winnie. The setup is readybrute/cooltech. Everything worked fine, did a bunch of testing and fine tuning at the high school parking lot, then a 10 mile or so run at 55.

Today however the Wrangler freaked. First it was a bell and the esp,bas and traction control lights. Then the parking break and abs lights and bell about once a minute. When the bell dings the speedo go to zero. I turned around and headed for the dealer, on the way the check engine light came on (amber) and the jeep died once at a stop light. I got it restarted but i think i lost power a couple of times, wipers stops, all warning lights came on etc ...

The dealer said all the codes pointed to the brakes being applied at an "inappropriate" time and towing it with the key on caused the problem. But i didn't have the key on. He then moved onto the cooltech caused the problem. And i should disconnect the battery.

My scangauge didn't see any codes.

They cleared all the codes and so far it has not come back.

Any help would be great, hoping I did not kill the computer. And in turn my marriage.
__________________

__________________
Jim Apple
wb1dog
japple is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-31-2013, 05:56 PM   #2
Senior Member
 
adonh's Avatar
 
Join Date: Apr 2013
Location: Missouri City, TX
Posts: 1,306
What is cooltech?
__________________

__________________
Don
2003 Forest River Cardinal Platinum 37' 5th Wheel
1976 31' Airstream
adonh is offline   Reply With Quote
Old 10-31-2013, 06:07 PM   #3
Senior Member
 
PDR John's Avatar
 
Join Date: May 2012
Posts: 3,627
Cooltech: Cool Tech LLC. JK Tow Harness Kit



I thought on the 10s you had to pull a fuse. Might want to double check.
__________________
2013 DSDP 4347, all electric, 450 H.P. ISL
Air & hydraulic leveling
14 Jeep Grand Cherokee Overland toad
[SIGPIC][/SIGPIC]
PDR John is offline   Reply With Quote
Old 10-31-2013, 08:17 PM   #4
Senior Member
 
Roger G's Avatar
 
Join Date: Mar 2011
Location: Amory, Ms
Posts: 698
I have the Cooltech harness on a 12 and initially had a ton of problems, nothing like yours but problems still. Cooltech customer service is the worst I have ever dealt with. My problem turned out to be a loose ground in the umbilical cord. It would ohm through but would lose ground under load. Cooltech finally told me that my Jeep wiring must be wrong because there was no way there was a problem with their harness. The next jeep will have a Mopar harness on it.
__________________
Roger And Kim Goodwin
bout them DAWGS!!
Roger G is offline   Reply With Quote
Old 10-31-2013, 08:26 PM   #5
Senior Member
 
FlyingDiver's Avatar
 
Newmar Owners Club
Join Date: May 2007
Location: Somewhere....
Posts: 3,820
I don't trust those wiring systems that connect to the vehicle lights. I always go the route of installing extra bulbs. It's especially easy on some Jeep models because the tail light enclosures already have a spot for an extra bulb. My installer told me it's because they use an extra one for the European models.
__________________
2008 King Aire 4562, Spartan K3(GT) w/ Cummins ISX 600
2014 Jeep Grand Cherokee Overland 5.7L V8 Hemi w/ Blue Ox Aventa LX Tow Bar and baseplate, SMI Air Force One brake
FlyingDiver is offline   Reply With Quote
Old 11-04-2013, 10:10 AM   #6
Member
 
Join Date: Jul 2012
Location: Shelbyville, KY
Posts: 77
Thanks everyone.
__________________
Jim Apple
wb1dog
japple is offline   Reply With Quote
Old 11-04-2013, 03:33 PM   #7
Senior Member
 
Bryan H's Avatar
 
Join Date: Jun 2012
Posts: 143
I think the '11 wrangler I owned previously said to disconnect the battery. Might check your owners manual.

I also had ReadyBrute and Cooltech. Had some issues with Cooltech (search for posts by me if that is of interest to you). Current toad is wired with separate bulbs, and that is now my preference.
__________________
2015 Thor Outlaw 29H Class C Toyhauler
2015 Jeep Wrangler JKU Toad
Bryan H is offline   Reply With Quote
Old 11-04-2013, 03:47 PM   #8
Senior Member
 
FlyingDiver's Avatar
 
Newmar Owners Club
Join Date: May 2007
Location: Somewhere....
Posts: 3,820
Quote:
Originally Posted by Bryan H View Post
I think the '11 wrangler I owned previously said to disconnect the battery. Might check your owners manual.
I don't think the Jeep manual says anything about the battery. I certainly never disconnected it on my '10 Wrangler or '12 Liberty.

joe
__________________
2008 King Aire 4562, Spartan K3(GT) w/ Cummins ISX 600
2014 Jeep Grand Cherokee Overland 5.7L V8 Hemi w/ Blue Ox Aventa LX Tow Bar and baseplate, SMI Air Force One brake
FlyingDiver is offline   Reply With Quote
Old 11-04-2013, 08:25 PM   #9
Senior Member
 
Join Date: Jun 2011
Posts: 283
I have Cool Tech on my 12 wrangler Sport for over a year and about 7,000 tow miles behind my motor home with no problems at all.
__________________
Mody n Domy
full timing it
Mody n Domy is offline   Reply With Quote
Old 11-05-2013, 09:13 AM   #10
Senior Member
 
Bryan H's Avatar
 
Join Date: Jun 2012
Posts: 143
Quote:
Originally Posted by Mody n Domy View Post
I have Cool Tech on my 12 wrangler Sport for over a year and about 7,000 tow miles behind my motor home with no problems at all.
What happens when you have a turn signal on and the jeep's brakes are applied by your braking system? In my case, the brake lights would override the turn signal, and the blinking would stop. As soon as I came to a stop and the readybrute released the brake, the signal would flash again. That was my only issue and the reason I now prefer a separate bulb system.
__________________
2015 Thor Outlaw 29H Class C Toyhauler
2015 Jeep Wrangler JKU Toad
Bryan H is offline   Reply With Quote
Old 11-08-2013, 02:20 PM   #11
Senior Member
 
Join Date: Jun 2011
Posts: 283
Byran I have the Blue Ox Patriot breaking system and have never had this problem.
__________________
Mody n Domy
full timing it
Mody n Domy is offline   Reply With Quote
Old 03-12-2014, 04:17 PM   #12
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2010
Posts: 124
Quote:
Originally Posted by FlyingDiver View Post
I don't trust those wiring systems that connect to the vehicle lights. I always go the route of installing extra bulbs. It's especially easy on some Jeep models because the tail light enclosures already have a spot for an extra bulb. My installer told me it's because they use an extra one for the European models.
I don't trust that either. Easy to install an additional light in the taillight assembly and use a wire harness from blue ox.
__________________
Chuck n Terri
2017 Heartland Bighorn 3875FB
2016 Chevy 3500 Duramax
Lostdog is offline   Reply With Quote
Old 03-12-2014, 04:54 PM   #13
Senior Member
 
JFNM's Avatar
 
Newmar Owners Club
Solo Rvers Club
Join Date: May 2013
Location: Mountain West
Posts: 1,060
Quote:
Originally Posted by japple View Post
Sunday I did my first test run towing the 10 wrangler behind our 04 minnie winnie. The setup is readybrute/cooltech.
I have a very similar setup - '10 Wrangler, Blue Ox base plate, ReadyBrute bar, Cooltech harness. I've been towing with the battery disconnected and no problems. I made a 250 mile drive last week with the battery connected after observing that the steering wheel does NOT lock when the key is in the off position. No problems following this trip either. None of that is likely to help you but possibly another data point...
__________________
JD & Buddy (the ferocious feline) - Full timer out west
2005 Newmar Dutch Star 4023 | 2010 Wrangler (daJeep) | 650 Watts Solar
My Adventures
JFNM is offline   Reply With Quote
Old 06-17-2014, 02:24 PM   #14
Member
 
Join Date: Jul 2012
Location: Shelbyville, KY
Posts: 77
Now I have the no turn signals if the brakes are on problem. Ugh even with the jeep battery disconnected.
__________________

__________________
Jim Apple
wb1dog
japple is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.