Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-29-2008, 03:49 PM   #1
Junior Member
 
Join Date: Feb 2008
Location: Escondido, CA
Posts: 2
I have a 4 door Wrangler (Sahara). I have towed it twice and have encountered problems.
I have turned the key to on position (two clicks) instead of one. I think when I did that I enabled the Electornic Stability, Traction control, and electronic roll mitigation to activate. I am towing with a Class C Motorhome, with a banks exhaust system, and transcommand. Everything is fine when I am on the freeway, on hills, uphill or downhill, but when I get on a curvy road it feels like the electronic stuff is causing the brakes to engage. I am going to try this weekend to tow with the key on the first click to see if this problem goes away. Has anyone else encountered this problem??
__________________

__________________
oldbzrd is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-29-2008, 03:49 PM   #2
Junior Member
 
Join Date: Feb 2008
Location: Escondido, CA
Posts: 2
I have a 4 door Wrangler (Sahara). I have towed it twice and have encountered problems.
I have turned the key to on position (two clicks) instead of one. I think when I did that I enabled the Electornic Stability, Traction control, and electronic roll mitigation to activate. I am towing with a Class C Motorhome, with a banks exhaust system, and transcommand. Everything is fine when I am on the freeway, on hills, uphill or downhill, but when I get on a curvy road it feels like the electronic stuff is causing the brakes to engage. I am going to try this weekend to tow with the key on the first click to see if this problem goes away. Has anyone else encountered this problem??
__________________
oldbzrd is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007-2009 Jeep Wrangler Flat Towing CoolTech Toads and Motorhome Related Towing 47 05-05-2013 09:36 PM
2007+ Wrangler Cool Tech Harness/IOD Testing pattonsr Toads and Motorhome Related Towing 3 11-16-2007 12:49 PM
Installing door awning on 2007 Tropical? nodine National RV Owner's Forum 7 07-22-2007 01:58 PM
Wind noise at front door in 2007 coach!! TGF Alpine Coach Owner's Forum 12 06-29-2007 01:10 PM
2007 Wrangler base plate BillArf Toads and Motorhome Related Towing 21 12-30-2006 06:16 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.