Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-10-2013, 09:02 PM   #1
Senior Member
 
Curtisgeiger's Avatar


 
Entegra Owners Club
Join Date: Jul 2013
Location: Fort Bragg, NC
Posts: 865
2011 GMC Yukon XL Denali (AWD)

GMC owners manual says "towing my vehicle on a fours will damage the drivetrain components."

I read that a Remco lube pump on my transmission is required to avoid the damage described above.

Besides the lube pump, tow package and brake buddy, is that all I need to ensure my Yukon does not get damaged?

Does the Remco modification in anyway void my GMC factory warranty?

Thanks,

Curt
__________________

__________________
Curt Geiger
2014 Entegra Aspire 44U
North Carolina
Curtisgeiger is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-10-2013, 11:15 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970
Is it only the transmission, that's the problem , I thought the main issue , was the AWD transfer case.
Time for me to do some reading I guess.
Ok , Remco web site says a lube pump is what you need.
Remco offers a warranty for certain vehicles , whether your factory warranty is effected is up to GM.
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 08-11-2013, 05:12 PM   #3
Senior Member
 
Curtisgeiger's Avatar


 
Entegra Owners Club
Join Date: Jul 2013
Location: Fort Bragg, NC
Posts: 865
Hopefully someone has some experience with a Remco transmission lube pump on an SUV like mine.

Standing by...
__________________
Curt Geiger
2014 Entegra Aspire 44U
North Carolina
Curtisgeiger is offline   Reply With Quote
Old 08-11-2013, 11:07 PM   #4
Senior Member
 
Heater's Avatar
 
Join Date: Aug 2011
Posts: 162
I have owned 2 Denali's. I love them. I know exactly why you want to use it as a toad. I bought an LTZ Tahoe to pull after I exhausted my efforts on trying to come up with a good way to pull my Denali. I now pull a Z71 silverado instead of the Tahoe. I wanted to be able to bring the golf cart along also. My suggestion would be to look into buying a fully loaded LTZ Tahoe. They are almost identical just a little less bling and 4wd in lieu of AWD. If REMCO will stand behind their product I would go that route maybe. I'm almost positive that 2 years ago there was not an option to tow a Denali.
__________________
Heater is offline   Reply With Quote
Old 08-12-2013, 05:06 AM   #5
Senior Member
 
Curtisgeiger's Avatar


 
Entegra Owners Club
Join Date: Jul 2013
Location: Fort Bragg, NC
Posts: 865
Sounds like I need to put the Yukon up on a trailer...
__________________
Curt Geiger
2014 Entegra Aspire 44U
North Carolina
Curtisgeiger is offline   Reply With Quote
Old 08-12-2013, 12:59 PM   #6
Senior Member
 
Heater's Avatar
 
Join Date: Aug 2011
Posts: 162
If it is an 08 or newer I would buy a lube pump and tow it. If I still had mine that is exactly what I would do.
__________________
Heater is offline   Reply With Quote
Old 08-12-2013, 01:10 PM   #7
Senior Member
 
jeryan59's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Apr 2012
Posts: 667
I had a 2004 Denali with a lube pump. My Denali caught on fire towing 4 wheels down with a Remco lube pump, never determined what started the fire which resulted in burning up our previous motorhome as well. I AM NOT saying the Remco lube pump had anything to do with it, insurance company hired fire investigator and they couldn't determine cause of fire either. I personally believe it had something to do with fuel, but I will never know for sure?

I have a 2008 Escalade and Remco told me they didn't have a lube pump for this AWD vehicle nor for a GMC Denali. Hence I purchased an enclosed trailer.
__________________

__________________
Johnny Rotten
2009 American Eagle 42'
Trailering HD Road Glide and Saab 9.3 or Cadillac Escalade ESV
jeryan59 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.