Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-11-2015, 06:34 AM   #1
Member
 
jjwalkers26's Avatar
 
Join Date: Mar 2011
Location: Monterey, TN
Posts: 74
2015 Ford Edge Problem/Wiring

I just bought a 2015 Ford Edge to flat tow. I bought the recommended baseplate
and wiring harness from Blueox. The baseplate was installed on Friday and they started on the wiring on Monday 7-10-2015. Because of a question about the wiring install, I called blueox. As soon as I told them the veh and wiring I was installing, they said don't install the wiring kit BX8848 as we found out it doesn't work in that car. I asked for the replacement and they said at this time there is none. They removed this wiring kit on Friday for use in this Veh. Great, I am out
2 hours of labor and maybe I won't be able to return the wiring harness as part of it is already installed in the car. I was told to use the light kit you attach to the outside of the veh. I won't do that as I don't want scratches. I will find out what the problem is and get Blueox to make good on my expense so far.

Thought I would just pass on what I have learned so others don't find themselves
with the same problem.
__________________

__________________
2014 Tiffin Allegro 33AA RED
2015 Ford Edge Titanium
Blue Ox Aventa II Towbar/Invisibrake
jjwalkers26 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-13-2015, 06:49 AM   #2
Member
 
jjwalkers26's Avatar
 
Join Date: Mar 2011
Location: Monterey, TN
Posts: 74
Quote:
Originally Posted by jjwalkers26 View Post
I just bought a 2015 Ford Edge to flat tow. I bought the recommended baseplate
and wiring harness from Blueox. The baseplate was installed on Friday and they started on the wiring on Monday 7-10-2015. Because of a question about the wiring install, I called blueox. As soon as I told them the veh and wiring I was installing, they said don't install the wiring kit BX8848 as we found out it doesn't work in that car. I asked for the replacement and they said at this time there is none. They removed this wiring kit on Friday for use in this Veh. Great, I am out
2 hours of labor and maybe I won't be able to return the wiring harness as part of it is already installed in the car. I was told to use the light kit you attach to the outside of the veh. I won't do that as I don't want scratches. I will find out what the problem is and get Blueox to make good on my expense so far.

Thought I would just pass on what I have learned so others don't find themselves
with the same problem.
I have now learned it's not the harness but problems with some installers not being able to tap into vehicles wiring harness.
__________________

__________________
2014 Tiffin Allegro 33AA RED
2015 Ford Edge Titanium
Blue Ox Aventa II Towbar/Invisibrake
jjwalkers26 is offline   Reply With Quote
Old 08-13-2015, 06:57 AM   #3
YC1
Senior Member
 
YC1's Avatar


 
Holiday Rambler Owners Club
Join Date: Jun 2011
Posts: 5,400
Yep. Are you using a toad brake? I have the Invisibrake and installed diodes in the wires right behind the light housings. A bit of a tight fit but they work.

Wiring can be very time consuming.
__________________
Myron & Deborah
08 HR Endeavor 40 SKQ
2012 Ford Edge Limited FWD 3.5L
Aluminator tow bar, Demco base plate
YC1 is offline   Reply With Quote
Old 08-14-2015, 04:49 AM   #4
Member
 
jjwalkers26's Avatar
 
Join Date: Mar 2011
Location: Monterey, TN
Posts: 74
Quote:
Originally Posted by YC1 View Post
Yep. Are you using a toad brake? I have the Invisibrake and installed diodes in the wires right behind the light housings. A bit of a tight fit but they work.

Wiring can be very time consuming.
I haven't even started to think about my invisibrake install. I want them to wire my Ford Edge first. There is a differance I think between the 12 and 15 edge.
I hope they figure it out soon.
__________________
2014 Tiffin Allegro 33AA RED
2015 Ford Edge Titanium
Blue Ox Aventa II Towbar/Invisibrake
jjwalkers26 is offline   Reply With Quote
Old 08-14-2015, 07:42 AM   #5
YC1
Senior Member
 
YC1's Avatar


 
Holiday Rambler Owners Club
Join Date: Jun 2011
Posts: 5,400
To wire the Edge for lights I bought the “universal wiring kit “ from Roadmaster which includes four heavy duty diodes, plenty of cable,.

The part number is 154. No sockets were included to connect at front of engine area. Purchase that separately.

I highly recommend adding a charge line as well. The Invisibrake charge line just will not keep up with the Edge.
Attached Files
File Type: pdf Amber light wiring on Edge.pdf (1.26 MB, 47 views)
__________________
Myron & Deborah
08 HR Endeavor 40 SKQ
2012 Ford Edge Limited FWD 3.5L
Aluminator tow bar, Demco base plate
YC1 is offline   Reply With Quote
Old 08-26-2015, 06:59 AM   #6
Member
 
jjwalkers26's Avatar
 
Join Date: Mar 2011
Location: Monterey, TN
Posts: 74
Well, I finally found a tech that knows what he was doing. Blueox really screwed me up
by telling my other tech to remove the wiring harnass as it wouldn't work in that veh. Later he said he didn't know why. It was already installed then removed. That blueox employee didn't know what he was talking about and cost me $200.00 in the time it took the tech to install then remove what he had done. Blueox finally said there was nothing wrong with the
wiring harnass. It cost me $458.00 to have it installed by another company as they took
3 1/2 hours to reinstall at $120.00 an hour. It now works fine.
__________________
2014 Tiffin Allegro 33AA RED
2015 Ford Edge Titanium
Blue Ox Aventa II Towbar/Invisibrake
jjwalkers26 is offline   Reply With Quote
Old 08-31-2015, 08:38 AM   #7
Junior Member
 
Join Date: Mar 2015
Posts: 6
Hello, Pete46 here. I ran into a similar problem with my 2013 Lincoln MKX. Said that because of multiplex wiring in the car I would have to use a light bar. I plan to mount the light bar to my rear hitch on the car. I agree with you on scratching.

Quote:
Originally Posted by jjwalkers26 View Post
I just bought a 2015 Ford Edge to flat tow. I bought the recommended baseplate
and wiring harness from Blueox. The baseplate was installed on Friday and they started on the wiring on Monday 7-10-2015. Because of a question about the wiring install, I called blueox. As soon as I told them the veh and wiring I was installing, they said don't install the wiring kit BX8848 as we found out it doesn't work in that car. I asked for the replacement and they said at this time there is none. They removed this wiring kit on Friday for use in this Veh. Great, I am out
2 hours of labor and maybe I won't be able to return the wiring harness as part of it is already installed in the car. I was told to use the light kit you attach to the outside of the veh. I won't do that as I don't want scratches. I will find out what the problem is and get Blueox to make good on my expense so far.

Thought I would just pass on what I have learned so others don't find themselves
with the same problem.
__________________
Pete46 is offline   Reply With Quote
Old 09-02-2015, 07:32 PM   #8
Junior Member
 
Join Date: Sep 2015
Posts: 7
How was the problem resolved. I have encountered the same problem.
__________________
skippy 95 is offline   Reply With Quote
Old 09-03-2015, 05:57 AM   #9
Member
 
jjwalkers26's Avatar
 
Join Date: Mar 2011
Location: Monterey, TN
Posts: 74
Quote:
Originally Posted by skippy 95 View Post
How was the problem resolved. I have encountered the same problem.
Skippy, there was never a problem with the blueox wiring harness. A good tech installed it without a problem. It started out with one tech having a problem because he didn't check and select the right wire to tap into. Combine that with a blueox employee saying he was told the harness we were told to use wouldn't work in my veh which turned out to be false led to confusion. All is well now.
__________________
2014 Tiffin Allegro 33AA RED
2015 Ford Edge Titanium
Blue Ox Aventa II Towbar/Invisibrake
jjwalkers26 is offline   Reply With Quote
Old 10-08-2015, 01:58 PM   #10
Senior Member
 
Dakrism's Avatar


 
Monaco Owners Club
Join Date: Sep 2012
Location: Cicero In
Posts: 201
I have a 2015 Ford Edge in the shop today and they have called me to tell me I will have NO TURN SIGNALS I will have brake lights but nothing else.
The tech said according to Blue Ox and Roadmaster that no one has solved the 2015 Edge wiring puzzle and they are still working on it.

Are you saying they got yours to work?? I sure am interested in learning more of how they solved the problem. Can you shed any more light on the situation??

Thanks,
__________________
Dan & Kris Murphy

2009 Beaver Contessa
2015 Ford Edge SEL
Dakrism is offline   Reply With Quote
Old 10-08-2015, 02:50 PM   #11
Senior Member
 
Winepress's Avatar
 
Join Date: Jul 2012
Posts: 520
An alternative may be to install separate light bulbs in the rear light assembly, if there is room. I did this on my old Trailblazer and bypassed the factory wiring, no diodes necessary. Just a thought.


Try and live up to your dogs opinion of you.
__________________
Try to live up to your dogs opinion of you.
Winepress is offline   Reply With Quote
Old 10-21-2015, 06:35 AM   #12
Member
 
jjwalkers26's Avatar
 
Join Date: Mar 2011
Location: Monterey, TN
Posts: 74
Dan

In my case I went to Buddie Gregg's in Knoxville,TN and the tech was able to figure out the wiring and everything works fine now.

the lights on a 2015 ford edge are sealed and besides, there is no room for you to drill in the housing for separate lights.
__________________
2014 Tiffin Allegro 33AA RED
2015 Ford Edge Titanium
Blue Ox Aventa II Towbar/Invisibrake
jjwalkers26 is offline   Reply With Quote
Old 11-25-2015, 09:14 AM   #13
Senior Member
 
Algoma's Avatar


 
Join Date: Nov 2007
Location: Charleston, WV
Posts: 2,604
Slightly off topic, but I am looking at buying the 2015 Ford Edge and have a question regarding disconnecting the 12v battery. I have an Evenbrake which requires 12v, would I have to run 12v from the motorhome? Also do you lose all your memory settings if the 12v is disconnected?
__________________
John and Mary Knight
2015 Newmar Ventana 4311 - wheelchair accessible
2015 Cadillac SRX Luxury AWD
Algoma is offline   Reply With Quote
Old 11-25-2015, 07:02 PM   #14
YC1
Senior Member
 
YC1's Avatar


 
Holiday Rambler Owners Club
Join Date: Jun 2011
Posts: 5,400
Quote:
Originally Posted by Algoma View Post
Slightly off topic, but I am looking at buying the 2015 Ford Edge and have a question regarding disconnecting the 12v battery. I have an Evenbrake which requires 12v, would I have to run 12v from the motorhome? Also do you lose all your memory settings if the 12v is disconnected?

With any Edge I would add a charge line. Removing the battery usually removes the memories and the vehicle has to relearn many parameters.
__________________

__________________
Myron & Deborah
08 HR Endeavor 40 SKQ
2012 Ford Edge Limited FWD 3.5L
Aluminator tow bar, Demco base plate
YC1 is offline   Reply With Quote
Reply

Tags
ford, wiring



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2015 Ford 5 Speed Trans... LVRVLUVR Class C Motorhome Discussions 9 06-28-2015 09:42 AM
Ford Edge Owners Gadget Man Toads and Motorhome Related Towing 2 05-08-2015 08:57 PM
2015 Baystar and Ted Britt Ford Chantilly Va. RattVader Newmar Owner's Forum 1 04-03-2015 08:03 AM
2015 Ford F250 5th wheel prep package ($370) question. Captainkoop Trailer Towing and Tow Vehicles Discussion 5 06-10-2014 07:25 PM
Rapid interior heater 2015 f250 Ford Diesel Captainkoop Trailer Towing and Tow Vehicles Discussion 3 06-10-2014 03:21 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.