Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-27-2016, 10:00 PM   #1
Senior Member
 
JohnBoyToo's Avatar


 
Monaco Owners Club
Join Date: May 2012
Location: DFW, Tex-US
Posts: 4,844
Check your power plugs !!!

Plugged our brake buddy in today and no power !!!
tried another outlet and still none...
got the cellphone charger out and power,
so started looking at brake buddy and oops...

the screw on connector that held the pin in had ejected it !!!
I guess it just unscrewed over time and many uses - so check yours...
Attached Thumbnails
Click image for larger version

Name:	2016-01-27 038.jpg
Views:	65
Size:	250.6 KB
ID:	117575  
__________________

__________________
'11 Monaco Diplomat 43DFT RR10R pushed by a '14 Jeep Wrangler JKU. History.. 5'ers: 13 Redwood 38gk, 11 MVP Destiny, Open Range TT, popups, vans, tents...
JohnBoyToo is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-31-2016, 02:55 PM   #2
Senior Member
 
Fiesta48's Avatar
 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Nov 2010
Location: Texas
Posts: 1,596
Had exactly same problem. Had another plug I used parts from. Compressor did not come on.
__________________
Fiesta48 is online now   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Disconnect BD1 only Operates when coach plugged into shore power kcolivier Newmar Owner's Forum 5 10-13-2015 11:18 PM
2004 Southwind Converter Blowing Shore Power Fuse Tom Lopez Fleetwood Products Owner's Forum 9 05-19-2015 01:34 PM
Power trouble...2007 Southwind dobie1kanobe RV Systems & Appliances 1 01-18-2015 06:39 AM
Hybrid Solar / Shore Power Solution Wanted SteveUpp Going Green 20 09-23-2014 07:32 AM
Automatic Power Switch Problem Zertman RV Systems & Appliances 12 07-07-2014 04:52 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.