Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 01-07-2013, 11:54 PM   #1
Junior Member
Join Date: Mar 2011
Posts: 14
Cooltech JK Tow Harness Kit Problems

I installed a cooltech harness on my 2007 JK and I am having a pretty major issue I can't seem to get resolved with cooltech customer service.

After following the install directions carefully, ensuring each prong on jeep plug matched function/power signal coming from MH (using cooltech supplied umbilical), and with the jeep battery disconnected, the dash lights up and relays click when I connect jeep to MH. I have inspected all plugs inspected for any damage to wire shielding and all is good. I did notice however that all prongs on jeep plug have connectivity to ground, both with the battery connected and disconnected, should this be the case? Also the running lights on the jeep appear to be dimmer when powered by MH vs powered by jeep battery. The only solution that works is to pull the IOD fuse along with several other relays until no more clicking.

MH is a 2005 southwind, and I have also attached install intructions and pic of my jeep plug config to match MH output

Cool Tech JK Harness Install Instructions

Any ideas on what my be causing my issue would be greatly appreciated.

GoBigGuy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-08-2013, 12:40 AM   #2
Senior Member
TheJeep's Avatar
Monaco Owners Club
Join Date: Sep 2012
Posts: 237
I had that system on my 07 Rubicon (I miss the Jeep). I also noticed the the lights were slightly dimmer than the normal Jeep running light but it was just a hair dimmer. It was not enough for me to say it was a problem. I did not disconnect my battery and never had a problem with that. I know the owners manual said to but that was my Jeep and what I choose to do. As far as the relays do you have the key in the accessory or run position. In the run position it would cause that. Hope this helps.

2006 Monaco Dynasty Diamond IV
TheJeep is offline   Reply With Quote
Old 01-08-2013, 05:50 PM   #3
Junior Member
Join Date: Mar 2011
Posts: 14
Key has been I run position, thought it had to be to unlock steering, will turn it back a click to accessory, of that works you are a genius! Will report back next time jeep a MH are linked. Thank you!
GoBigGuy is offline   Reply With Quote
Old 01-08-2013, 08:15 PM   #4
Senior Member
hogdriver's Avatar

Entegra Owners Club
Join Date: Jan 2012
Location: Space Coast, FL
Posts: 2,552
CoolTech Issues

I had some similar issues with the CoolTech kit on my 2012. I'd get a great turn signal on one side of the Jeep then the other was weak. My running lights were dimmer also. Finally I ran a new ground wire to the harness from the RV harness and all works. For some reason the ground I was using at the back of the Jeep was poor. My Jeep does not require the key for towing and I do not pull a fuse. I've towed it over 5000 mi so far.
Dave & Debbie
2014 Anthem 44B
2012 Jeep Rubicon toad
hogdriver is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:43 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.