Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 11-26-2011, 07:43 AM   #15
Senior Member
num1dgh's Avatar
Country Coach Owners Club
Join Date: Apr 2011
Location: California
Posts: 489
The only time the battery on our toad (2010 Ford Edge) dies is when we tow it too long without starting it. If we must drive longer than 5 hours or so when we stop, we'll go run the Ford for a bit. I must say, though, that we towed a 2007 CRV for way too long (a few times over 10 hours a trip), never started it up, and never lost charge on the battery!

John & Cathy Lamb
45' Marathon XLII
num1dgh is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-26-2011, 08:09 AM   #16
Senior Member
sgtjoe's Avatar
National RV Owners Club
Join Date: May 2008
Posts: 1,727
Getting ready to head South for the Winter and this will be the first trip with our 2011 CRV with the navigation system. The manual says to pull the 7.5 amp radio fuse for long periods of towing. So will this also shut down the navi system? What about just disconnecting the battery ground? That looks easier then trying to get that fuse out.

Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead coach battery.......any ideas? prescue Winnebago Industries Owner's Forum 1 07-30-2011 06:41 PM
Chassie battery dead luceil Winnebago Industries Owner's Forum 9 05-07-2008 03:18 PM
Dead Chassie Battery Blue Ribbon MH-General Discussions & Problems 5 02-01-2007 01:34 AM
Resurrect - Dead Cordless Battery oemtech iRV2.com General Discussion 5 09-17-2005 06:09 PM
Dead chassis battery after 2 days Fla2RI Workhorse and Chevrolet Chassis Motorhome Forum 14 06-27-2005 07:14 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:01 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.