Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-13-2008, 07:06 AM   #1
Member
 
leemax's Avatar
 
Join Date: May 2006
Location: selah wa.
Posts: 40
have towed my chevy. around alot in past. But now when i tried to hook it up i drained the chassis battery. Replaced with new batt. and when i checked out the towbar for travel i noticed that when i moved the safety cable i got sparks. and the cable got very hot. The only thing ive had done sense i last towed was had my backup monitor replaced. Its almost like maybe the GND. is bad? Any ideas please. Thanks in advance LEE
__________________

__________________
Lee & Maxine and dogs coco & mollie. toad. 05 chevy HHR. Two Honda ATV.s Deuce Hauler trailer. To take it all with me. Fun and Games

two atv.s & Deuce Hauler trailer so i can take it all with me
leemax is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-13-2008, 07:06 AM   #2
Member
 
leemax's Avatar
 
Join Date: May 2006
Location: selah wa.
Posts: 40
have towed my chevy. around alot in past. But now when i tried to hook it up i drained the chassis battery. Replaced with new batt. and when i checked out the towbar for travel i noticed that when i moved the safety cable i got sparks. and the cable got very hot. The only thing ive had done sense i last towed was had my backup monitor replaced. Its almost like maybe the GND. is bad? Any ideas please. Thanks in advance LEE
__________________

__________________
Lee & Maxine and dogs coco & mollie. toad. 05 chevy HHR. Two Honda ATV.s Deuce Hauler trailer. To take it all with me. Fun and Games

two atv.s & Deuce Hauler trailer so i can take it all with me
leemax is offline   Reply With Quote
Old 10-13-2008, 08:50 AM   #3
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,060
Noticeable sparks and a drained chassis battery (coach chassis or car?) sounds more like a short to me. Check the ground wire to the trailer by all means, but you don't usually get big sparks and heat if the trailer is grounding through the safety chain. hat suggests that a LOT of current is flowing through it. Maybe you would have that symptom if all the trailer lights were on (tail, markers, brakes, etc) but you don't usually see that just when hooking up.
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 10-13-2008, 11:10 AM   #4
Member
 
leemax's Avatar
 
Join Date: May 2006
Location: selah wa.
Posts: 40
got it fixed. Thanks Anyway. Lee
__________________
Lee & Maxine and dogs coco & mollie. toad. 05 chevy HHR. Two Honda ATV.s Deuce Hauler trailer. To take it all with me. Fun and Games

two atv.s & Deuce Hauler trailer so i can take it all with me
leemax is offline   Reply With Quote
Old 10-13-2008, 12:19 PM   #5
Moderator Emeritus
 
RustyJC's Avatar


 
Texas Boomers Club
Join Date: Jul 2000
Location: Cypress, Texas USA
Posts: 8,854
Just a suggestion - it might be helpful to someone who could have this problem in the future if you'd tell us what you found and how you fixed it.

Thanks,

Rusty
__________________
2016 Ram Longhorn 3500 Dually 4x4 CCLB, 385/900 Cummins, Aisin AS69RC, 4.10
2014.5 DRV Mobile Suites 38RSSA #6972
Come join us on a TEXAS BOOMERS rally!
RustyJC is offline   Reply With Quote
Old 10-13-2008, 07:53 PM   #6
Senior Member
 
sfischer's Avatar
 
Tiffin Owners Club
Join Date: Nov 2006
Location: Fulltimers-could be anywhere
Posts: 171
Glad you got it fixed. What was the correction?
__________________

__________________
Steve and Karen Fischer
2010 Tiffin Phaeton 40QTH on Powerglide chassis
http://www.gonebyrv.blogspot.com
sfischer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dingy Running Lights Gadget Man Toads and Motorhome Related Towing 9 03-18-2011 08:04 PM
Dingy on trailer? Pueblo Dave Winnebago Industries Owner's Forum 18 03-08-2008 04:04 PM
Dingy Pickup novatz Toads and Motorhome Related Towing 6 06-03-2007 05:23 PM
PT Crusier Dingy Tom Williams Toads and Motorhome Related Towing 2 02-25-2005 11:41 AM
Dingy on trailer? Toads and Motorhome Related Towing 18 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.