Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 10-03-2015, 10:56 PM   #1
Junior Member
PartyBoyWA's Avatar
Triple E Owners Club
Join Date: Aug 2009
Posts: 19
Excalibar question

Hello Friends,

I obtained an Excali bar tow bar with my RV when I bought it some years ago. I am just now getting to towing my Honda. Today when I backed up the Honda to fully extend the tow bar, I did so per the instructions. But I never got the green stripe on the thicker end of the tow bar that the instructions say you are supposed to get when the tow bar is properly extended. Took a small loop around the block (very slowly). Very jerky. Something is not right. I reattempted backing up the Honda adding as much reverse as I felt comfortable with and still can't seem to get the tow bar to extend as it seems it should.

Things to know:

1-I read the full instructions.
2-MH is a 24' Class C, 2004 E-450
3-The tow bar is a first generation Excali bar, by Demco (not the II model).

Would appreciate any wisdom, especially from those who have this same model tow bar.

Moving from SoCal to Anchorage in 2 weeks. (That's a post of it's own.) Need to get this right soon.

Thanks for the help!

PartyBoyWA is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-03-2015, 11:01 PM   #2
Senior Member
Rockwood27's Avatar
Winnebago Owners Club
Nor'easters Club
Workhorse Chassis Owner
Join Date: Jun 2012
Location: Freedom, NH
Posts: 745
Can't help you with your question, but you may get a better response if you post this in the toads subforum under the motorhome forum.

Fran, Mary & Zoey (silver Cocker)
2006 Itasca Sunrise 35A, 2005 W-22, Allison 1000 5 speed
'13 Ford Focus ST or '10 Prius on Master Tow Dolly 80THD-SB or '00 Jeep Cherokee 4-down
Rockwood27 is online now   Reply With Quote
Old 10-04-2015, 07:13 AM   #3
Senior Member
Join Date: Mar 2009
Location: Crossville, Tennessee
Posts: 229
Download the manual from Demco. The locking ends need to be disassembled, cleaned, and lubed. Dirt gets in there and is a common problem with the 1st gen Excalibars. If you can't find the manual just pm me with your email and I'll send you a copy.
2004 Hurricane 32R F53, 2010 Ranger, 2016 Harley Switchback, 1 wife and 4 cats
jrd48 is offline   Reply With Quote
Old 10-05-2015, 11:09 PM   #4
Junior Member
PartyBoyWA's Avatar
Triple E Owners Club
Join Date: Aug 2009
Posts: 19
Rockwood27-Thanks for the move. Must have been my goof.

jrd48-Hadn't thought about that. It's the first time it's been used since I bought it in 2009. Don't know how much the previous owner used it. But the RV had only 3k miles. So it could not have been too much. Dirt makes sense. I'll get it cleaned out.

Thanks to all!
PartyBoyWA is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Another hitch question gap23 Trailer Towing and Tow Vehicles Discussion 6 08-10-2015 09:22 PM
Battery and Power Question rrthor Alpine Coach Owner's Forum 31 07-12-2015 07:05 AM
Slideout Question -Grumpy- Winnebago Industries Owner's Forum 5 07-01-2015 03:44 PM
A/C & Gas Heater Maint Question Bilgerat Fleetwood Products Owner's Forum 0 03-11-2015 06:46 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:18 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.