Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-09-2011, 07:53 PM   #1
Junior Member
 
Join Date: Nov 2011
Posts: 14
Flat towing using Remco transmission pump on Toad

Has anyone had any experience with a Remco transmission pump on any of there vehicles that are being flat towed?
__________________

__________________
tom-brenda is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-09-2011, 07:59 PM   #2
Senior Member
 
336muffin's Avatar
 
Join Date: Apr 2011
Posts: 2,569
I have friends that do with no problems. I like the drive shaft disconnect myself.
__________________

__________________
336muffin is offline   Reply With Quote
Old 11-09-2011, 09:47 PM   #3
Senior Member
 
Pigman1's Avatar
 
Join Date: Sep 2011
Posts: 1,937
Used one for a few years on a Hyundai. Failed once, but they replaced it without a question. If I had to do it again, I wouldn't hesitate to use one. I haven't dealt with the company since their breakup.
__________________
Pigman
2013 Tiffin Allegro Bus 43QGP
2011 Chevy Silverado 1500 Toad
Pigman1 is offline   Reply With Quote
Old 11-09-2011, 09:58 PM   #4
Member
 
Join Date: Jun 2009
Location: Madison, Ga
Posts: 69
I bought one in 2001. Used it on my 1997 chrysler T&C for 2 years. It went bad and was replaced free. Used the replacement for 6 yrs and it startedto leak after 50,000 + miles so I bought a new one this summer. The new one has a much bigger motor and works great. Wouldn' hesatate to do it again. The company was great to deal with and service was fast.
Busyguy
__________________
busyguy is offline   Reply With Quote
Old 11-10-2011, 09:14 AM   #5
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 22,787
Like the first responder.. I know many who tow that way.. Personally.. I prefer passive systems like the axle lock or drive shaft disconnect (Front/Rear wheel drive respectively) to active systems that can (in theory) fail like the lube pump.. But that's me. I have heard of only one lube pump failure in the several years I've been on line in RV forums. I have heard of several issues with Drive Shaft Disconnects... But the only failures were on the remote operation cable (Easily replaced and a stock item in many Auto parts stores)
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 11-10-2011, 01:00 PM   #6
Junior Member
 
Join Date: Nov 2011
Posts: 14
I am wanting to use a Remco pump on a 2012 Ford Escape that we bought and found out after the fact that it couldn't be successfully flat towed. With that being said, we are looking for some positive responses to this application. However, if anyone has any negatives experiances, please respond as we need to know.
__________________
tom-brenda is offline   Reply With Quote
Old 11-10-2011, 01:12 PM   #7
Senior Member
 
Join Date: Jul 2011
Location: Hawkeye State
Posts: 143
tom-brenda
What causes you to think a 2012 Escape "can't" be flat towed? Seems I read a couple of posts about Ford modifying the instructions for flat towing but hadn''t heard that it "can't' be done. I believe the tech bulletin from Ford even mentions Remco as an option to the "stop every five hours ..... shift gears....." remedy. Oh yea and you need to adjust the transmission fluid - to the low side. its all in the tech bulletin for Escapes and Fusion.
__________________
2011 Jayco 31SS V10
2006 Ranger Reata 1850
2014 Jeep Grand Cherokee 4-down
Gma-n-Gpa is offline   Reply With Quote
Old 11-10-2011, 01:13 PM   #8
Senior Member
 
Our Time's Avatar


 
Monaco Owners Club
Join Date: Aug 2006
Location: Ft Myers Fl / Omaha Ne
Posts: 617
Been towing with a lube pump for 6 years, over 50,000 miles. No problems other than a corroded wire. Remco tech support was great when I had a wiring problem.
__________________
Chuck & Mary
2008 Monaco Diplomat 40 SKQ
2008 Enclave Toad
Our Time is offline   Reply With Quote
Old 11-10-2011, 06:42 PM   #9
Senior Member
 
Pusherman's Avatar
 
Join Date: Oct 2006
Location: Rochester NY
Posts: 2,544
Quote:
Originally Posted by Gma-n-Gpa View Post
tom-brenda
What causes you to think a 2012 Escape "can't" be flat towed? Seems I read a couple of posts about Ford modifying the instructions for flat towing but hadn''t heard that it "can't' be done. I believe the tech bulletin from Ford even mentions Remco as an option to the "stop every five hours ..... shift gears....." remedy. Oh yea and you need to adjust the transmission fluid - to the low side. its all in the tech bulletin for Escapes and Fusion.
My understanding as well.
__________________
Don
'07 Winnebago Journey 34H - CAT C7, Koni's, MCU's, SS Bell Crank, Safe-T-Plus
'07 HHR Toad, SMI AFO, Blue OX
Pusherman is offline   Reply With Quote
Old 11-10-2011, 08:40 PM   #10
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970
1 year, 8000 miles, 2000 Caravan, A604 4spd , all Remco systems working fine. No trans issues.
Safe travels.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 11-10-2011, 08:55 PM   #11
Senior Member
 
Mr_D's Avatar
 
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 28,375
Have a friend that used on in a Caravan, the pump failed, the failure alarm didn't work and it destroyed the trans as a result. Remco took no responsibility for any of the damage.
Another two friends in the same club had drivershaft disconnects, both had transmissions go out while towing. In both cases they arrived at their destination and the trans was gone. No idea what happened.
__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '14 CR-V
Mr_D is offline   Reply With Quote
Old 11-11-2011, 09:37 AM   #12
Junior Member
 
Join Date: Nov 2011
Posts: 14
We know of several 2012 Ford Escape cases that followed all technical service bullitens and have had transmission failures. It is cost prohibative to trade this year, that is why we are concidering a Remco pump.
__________________
tom-brenda is offline   Reply With Quote
Old 11-11-2011, 01:52 PM   #13
Junior Member
 
Join Date: Nov 2011
Posts: 14
Quote:
Originally Posted by Our Time View Post
Been towing with a lube pump for 6 years, over 50,000 miles. No problems other than a corroded wire. Remco tech support was great when I had a wiring problem.
what are you towing
__________________
tom-brenda is offline   Reply With Quote
Old 11-11-2011, 01:55 PM   #14
Junior Member
 
Join Date: Nov 2011
Posts: 14
Chuck and Mary

What vehicle are you towing with Remco pump?
__________________

__________________
tom-brenda is offline   Reply With Quote
Reply

Tags
toad, towing



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flat towing a Buick LaCrosse wlf00 Toads and Motorhome Related Towing 13 02-22-2012 08:34 AM
Flat Towing - 2011 Hyundai Elantra Manual Transmission? rschroer Toads and Motorhome Related Towing 1 07-06-2011 03:25 PM
Transmission Lube Pump or Drive Shaft Disconnect? K5EAG Toads and Motorhome Related Towing 2 10-13-2010 11:02 AM
flat towing 09/10 King Ranch moisheh Toads and Motorhome Related Towing 5 07-06-2010 08:44 PM
Remco Lube pump zetron Toads and Motorhome Related Towing 3 05-16-2005 06:02 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.