Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-28-2012, 08:57 PM   #1
Junior Member
 
Join Date: May 2012
Posts: 3
Ford escape

So has anyone installed the remco pump on their ford escape? If so how does it work?
__________________

__________________
Big S is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-28-2012, 09:41 PM   #2
Member
 
jroan's Avatar
 
Tiffin Owners Club
Join Date: Jan 2012
Location: Pearl Mississippi
Posts: 90
Ford Escape

I am still in the shock mode. Just found out Ford has issued a supplement to the owners guide that the Escape and Fusion Stating they cannot be flat towed.
I just purchased 2012 Escape November 2011- as the 2011 Ford Fiesta I was towing went thru two transmission and one engine before 6000 miles. Ford did give me back my money - if I purchased a new Ford replacement. Which I did - and now this,
From what I have determined if I install a REMCO Pump it might void my warranty can not get a answer from Ford on this.

Jroan
__________________

__________________
Jerry & Anna
Retired Navy - 55 yrs Aircraft Mechanic/Pilot
2007 40 Ft Tiffin Phaeton, 2016 Ford Explorer
jroan is offline   Reply With Quote
Old 06-10-2012, 10:17 PM   #3
Member
 
smith45's Avatar
 
Join Date: May 2012
Location: Bandera Texas For the most part
Posts: 55
Remco Lube Pump

I , along with Ford, installed a Remco Lube Pump an my "09 Escape. I works fine, no problems. After the third burnt transmission Ford paid $500 toward the cost of the pump. They may try to scare you about warranty but it will not void the warranty unless Ford can prove the lube pump CAUSED the problem.

Chuck
__________________
smith45 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.