Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-09-2012, 11:21 AM   #1
Junior Member
 
Join Date: Apr 2011
Posts: 3
GMC Envoy tow car

I have a 2002 GMC Envoy with 170,000 which I purchased new and tow behind my motorhome with a Roadmaster tow bar & "Invisibrake" system. I tow with 4 wheels on the ground and follow the manual's instructions. The issue I am having is a burning smell coming from the engine area after I start dring the car after it has been towed. There is no smell while towing or after towing, only the first time I drive the car after towing it. The smell goes away after a few hours of driving. I have been to the dealership and a transmission shop with no answers. The transmission has been serviced and oils look fine. Any thoughts on this would be appreciated as we are new to the rv world.
__________________

__________________
teameaton is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-09-2012, 11:36 AM   #2
Senior Member
 
mllk3rd's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Jul 2011
Location: Pismo Beach, CA.
Posts: 323
Quote:
Originally Posted by teameaton View Post
I have a 2002 GMC Envoy with 170,000 which I purchased new and tow behind my motorhome with a Roadmaster tow bar & "Invisibrake" system. I tow with 4 wheels on the ground and follow the manual's instructions. The issue I am having is a burning smell coming from the engine area after I start dring the car after it has been towed. There is no smell while towing or after towing, only the first time I drive the car after towing it. The smell goes away after a few hours of driving. I have been to the dealership and a transmission shop with no answers. The transmission has been serviced and oils look fine. Any thoughts on this would be appreciated as we are new to the rv world.
I tow an 05 Envoy and have never had a this happen. Is this a new problem or has it always done this after towing? Is some type of fluid getting onto the exhaust system?
__________________

__________________
Mike, Lora and Bebe
05 Safari Simba 37 PCT, WorkHorse W22, Koni FSD, CrossFire, Rear Trak-Bar, SG2
Ready Brute w/ Ready Brake, Safe-T-Plus, 05 GMC Envoy
mllk3rd is offline   Reply With Quote
Old 08-09-2012, 11:42 AM   #3
Senior Member
 
djbmsu's Avatar
 
Join Date: Nov 2011
Location: Charlotte Harbor, FL
Posts: 1,806
You don't really identify the burning smell. Oil smells differently than Brakes, and brakes smell differently than electrical.
__________________
Don and Nancy
[2014 40QBH Phaeton, 2015 Buick Enclave, 2yr old sisters Sara n Kaycee, Havanese, Two Segways
djbmsu is offline   Reply With Quote
Old 08-09-2012, 11:48 AM   #4
Community Administrator
 
Route 66's Avatar


 
Newmar Owners Club
Retired Fire Service RVer's
Spartan Chassis
Join Date: May 2000
Location: Newark, DE
Posts: 25,623
Smells like burnt rubber?

Some toads do smell like that and my Yukon would do it sometimes.

It's not been determined what causes it and it has not caused a problem.
__________________
Adios, Dirk - '84 Real Lite Truck Camper, '86 Wilderness Cimarron TT, previously 4 years as a fulltimer in a '07 DSDP

Route 66 is offline   Reply With Quote
Old 08-09-2012, 12:02 PM   #5
Senior Member
 
Not a Clue's Avatar
 
Fleetwood Owners Club
Join Date: Sep 2007
Location: Orange County, Ca
Posts: 359
This will happen sometimes with ours and it was determined that sometimes while towing road grime will build up on the muffler/manifold and when you first drive the car it smells as it burns off.
__________________
Linda, Robin & Buddee(Cavalier)
09 Fleetwood Fiesta 29', 08 Vue Demco/UBS
http://thetravelsoflindarobin.blogspot.com/
Not a Clue is offline   Reply With Quote
Old 08-09-2012, 12:45 PM   #6
Member
 
Springer45's Avatar
 
Join Date: Jun 2012
Location: Boulder CIty NV
Posts: 81
Is this smell only after towing or is it on any cold start?
__________________

__________________
Springer45 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.