Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 05-12-2014, 07:15 PM   #1
Senior Member
ejm4's Avatar
Mid Atlantic Campers
Forest River Owners Club
Freightliner Owners Club
Join Date: Jun 2010
Location: Mechanicsburg, PA
Posts: 514
Invisibrake | Troubleshooting Help Needed

I am using the invisibrake on my 2013 F-150. I have used the setup all last year with no issues.

I brought the coach out of storage today and hooked up. I applied the brake in the coach and the light came on indicating the Invisibrake was working.

The second and rest of the brake applications resulted in no light coming on in the dash. Arrived home and checked all the connections - all o.k.

I pulled the emergency disconnect and the unit activated and applied the brake as if the truck broke away from the coach.

Any ideas? Possible bad light cord from the coach to the toad?

2013 Berkshire 390BH 360
My Albums
ejm4 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-14-2014, 03:20 PM   #2
Join Date: May 2012
Posts: 50
Is the Invisibrake (IB) actually activating when you press the RV brake pedal and the RV dash monitor light is just not working? That monitor light is wired to the toad’s cold side brake light switch and should light when IB pulls the toad brake pedal. If that wire disconnects it wouldn’t keep IB from working, you just won’t know that it is.
view2a.thril is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Roadmaster Invisibrake problems TexasEd Toads and Motorhome Related Towing 138 08-12-2016 02:28 AM
How reliable and safe is Invisibrake when not in use? macnut Toads and Motorhome Related Towing 10 03-14-2014 07:30 PM
Invisibrake Install Mike_Harriet Toads and Motorhome Related Towing 2 03-04-2014 06:42 PM
Towing 2012 Equinox, Need install information for Invisibrake Richardk Toads and Motorhome Related Towing 5 02-22-2014 10:02 PM
Smart Tire Error Codes & Troubleshooting EngineerMike Alpine Coach Owner's Forum 0 06-16-2013 12:25 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:02 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.