Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-23-2014, 03:10 PM   #1
Junior Member
 
Join Date: Jul 2014
Posts: 1
Jeep CK neutral switch

Having issue with my 2008 jeep Cherokee Laredo not coming out of neutral after towing. I have read about the flash option but I can't drive it around the block since it is in neutral. Any ideas how to get it in to drive so I don't have to tow it to be fixed.
__________________

__________________
rmordecki is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-23-2014, 04:54 PM   #2
Senior Member
 
onechaddude's Avatar
 
Join Date: Jul 2011
Posts: 1,540
Sorry I can't help you. I had similar problem but I couldn't get my 07 into neutral to start a trip. A quick trip over to local dealership and they solved the problem in about 15 minutes on a Friday afternoon. Since its in neutral can't you just tow it there? If your dealer doesn't know how to solve the problem let me know. My dealer said a specific procedure was required for it to work. Good luck.

Chad
__________________

__________________
onechaddude is offline   Reply With Quote
Old 07-24-2014, 06:34 PM   #3
Senior Member
 
jeepfreak's Avatar
 
Join Date: Mar 2003
Location: Home is where we park it
Posts: 417
Had that happen to my 07 commander after having in for the n23 recall 3 times. What I did was disconnect the + battery cable for a minute then put back on and go thru the procedure. It worked and the next week I traded it in for a 2014 Jeep Unlimited Rubicon as I could not trust it to work after the awful recall.
__________________
2007 Allegro 34wa .WH w20 8.1 6speed. Bow tie powered 79 CJ7 or a 2014 Jeep Unlimited Rubicon Toad.
jeepfreak is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Towing Jeep Wranger n5pht Toads and Motorhome Related Towing 21 08-10-2014 04:44 PM
50amp / 30amp switch box Gary111 National RV Owner's Forum 3 06-06-2014 11:30 AM
Anybody add a second generator starting switch? Bob86ZZ4 RV Systems & Appliances 23 06-04-2014 08:58 AM
12 volt on/off switch by the door caninecop Tiffin Motorhomes Owners Forum 4 02-24-2014 09:02 AM
Suburban limit switch? Ron Burgundy RV Systems & Appliances 5 02-15-2014 04:51 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.