Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-13-2014, 05:44 AM   #1
Junior Member
 
Join Date: Jan 2014
Posts: 8
Mopar harness not working

I just installed the Mopar harness, (2014 unlimited) and it is not working. None of the lights are working. I can here a relay clicking in the mopar harness, but that is all. I did check the ground wire on the harness and that has continuity all the way back to the battery.. Do I need to disconnect the battery in the jeep? I thought it would just be plug and play
__________________

__________________
Ronvp is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-13-2014, 06:16 AM   #2
Junior Member
 
Join Date: Jan 2014
Posts: 8
Only thing I can find on the forum is that I need to have the 12v Aux wire hooked up. I will check to see if I have power on that coming from the MH
__________________

__________________
Ronvp is offline   Reply With Quote
Old 07-13-2014, 09:53 AM   #3
Senior Member
 
jeepfreak's Avatar
 
Join Date: Mar 2003
Location: Home is where we park it
Posts: 417
I just purchased a new unlimited Rubicon and got the harness and installation in the deal. At least if mine doesn't work it's on them. Supposed to pick it up next Tuesday.
Does the steering lock on these ? It does say to turn the key to acc. Does that draw down the battery?
__________________
2007 Allegro 34wa .WH w20 8.1 6speed. Bow tie powered 79 CJ7 or a 2014 Jeep Unlimited Rubicon Toad.
jeepfreak is offline   Reply With Quote
Old 07-13-2014, 10:15 AM   #4
Senior Member
 
Peterrrr's Avatar
 
Thor Owners Club
Freightliner Owners Club
Join Date: Jun 2010
Location: Ottawa Ont
Posts: 224
The large 690 page printed owners guide that you have to request from Chrysler, does not require you to disconnect the battery or leave the key in the ignition. The CD and the smaller owners guide which comes with the vehicle has, "the battery disconnect procedure and key in". Not sure of what the latest online manual states.
__________________
Peterrrr is offline   Reply With Quote
Old 07-13-2014, 11:44 AM   #5
Senior Member
 
Peterrrr's Avatar
 
Thor Owners Club
Freightliner Owners Club
Join Date: Jun 2010
Location: Ottawa Ont
Posts: 224
RONVP. You might want to read this thread. Sound familiar to your problem. Installing Mopar harness on 2014 Jeep Wrangler
__________________
Peterrrr is offline   Reply With Quote
Old 07-13-2014, 05:32 PM   #6
Junior Member
 
Join Date: Jan 2014
Posts: 8
All working perfectly now. I was testing it on my Navigator, and after measuring with a multi meter, the 12v Aux (Black wire)is connected, but somehow not getting power. I connected it to my RV and it is working perfectly.

Without this forum, I could have been searching forever! Thanks
__________________
Ronvp is offline   Reply With Quote
Old 07-20-2014, 05:53 PM   #7
Junior Member
 
Join Date: Feb 2014
Location: Seattle, Wa
Posts: 18
I'm heard that in some RVs the key needs to be on for that line to have 12V. I should be receiving my Mopar harness for 2014 Rubicon Unlimited this week. I'm pulling with a 2013 Georgetown 351DS.

I also bought the cool tech harness but returned it before I even opened it. I prepare the relay approach with the Mopar harness.

Cheers!
__________________
s2kdrifter is offline   Reply With Quote
Old 07-20-2014, 07:26 PM   #8
Senior Member
 
jeepfreak's Avatar
 
Join Date: Mar 2003
Location: Home is where we park it
Posts: 417
I picked up our new Rubicon Tuesday and I got them to throw in the harness along with the install, put it behind the MH and plugged it in even though I haven't done the base plate yet , and as long as the coach is running everything works.
__________________
2007 Allegro 34wa .WH w20 8.1 6speed. Bow tie powered 79 CJ7 or a 2014 Jeep Unlimited Rubicon Toad.
jeepfreak is offline   Reply With Quote
Old 07-20-2014, 07:30 PM   #9
Senior Member
 
jeepfreak's Avatar
 
Join Date: Mar 2003
Location: Home is where we park it
Posts: 417
By the way I took my 2014 Unlimited Rubicon to the scale and with a half a tank of fuel and no base plate yet and it weighed in at 4534lbs
__________________
2007 Allegro 34wa .WH w20 8.1 6speed. Bow tie powered 79 CJ7 or a 2014 Jeep Unlimited Rubicon Toad.
jeepfreak is offline   Reply With Quote
Old 07-29-2014, 08:42 PM   #10
Junior Member
 
Join Date: Feb 2014
Location: Seattle, Wa
Posts: 18
Ron how did you feed the grommet through the 1 1/8" hole?
__________________
s2kdrifter is offline   Reply With Quote
Old 07-30-2014, 06:09 AM   #11
Junior Member
 
Join Date: Jan 2014
Posts: 8
I used some silicone oil to lubricate the grommet.. It still took lots of work. I think is easier to make the hole a little larger.
__________________
Ronvp is offline   Reply With Quote
Old 07-31-2014, 07:57 PM   #12
One of the Hoots
 
FLSteve's Avatar


 
Newmar Owners Club
Freightliner Owners Club
Join Date: Mar 2011
Location: Fort Myers, FL
Posts: 798
Go with a 1-3/8" hole ... the perfect size.

Mopar Wiring harness


Steve
__________________

__________________
Steve & Lisa
2015 Mountain Aire 4553
2014 Jeep Wrangler Rubicon & 2012 Jeep Grand Cherokee
FLSteve is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mopar Wiring harness Gladie Toads and Motorhome Related Towing 86 08-24-2016 11:08 AM
Installing Mopar harness on 2014 Jeep Wrangler corvettec3 Toads and Motorhome Related Towing 16 07-31-2014 07:54 PM
Brake lights not working help maxwell18 Class A Motorhome Discussions 10 05-06-2014 06:07 PM
Installing Mopar harness on 2014 Jeep Wrangler corvettec3 Toads and Motorhome Related Towing 2 04-26-2014 09:55 AM
Heat tape not working!! Cari Z Full-Timers 17 02-12-2014 07:56 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.