Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 03-22-2015, 09:54 PM   #1
Junior Member
Join Date: Mar 2015
Posts: 1
Problems with Lights

Just added a tow-dolly to our 32 foot 2006 Fiesta. All worked fine last week. Now the taillights and the upper marker lights halfway back don't work on the RV. Turn signals and brake lights work fine. Tested fuses under hood and dash and all are good.

MaBarker is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-26-2015, 02:52 PM   #2
Senior Member
Ray,IN's Avatar
Join Date: Aug 2001
Location: North America somewhere
Posts: 12,300
Over 80% of 12V problems are related to a poor ground, this sounds like one of them.

2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA 1SG, retired;PPA,Good Sam Life member."We the people are the rightful masters of both the Congress and the Courts - not to overthrow the Constitution but to overthrow men who pervert theConstitution. "Abraham Lincoln"
Ray,IN is offline   Reply With Quote
Old 03-28-2015, 03:12 PM   #3
pjkellrvers's Avatar
Nor'easters Club
Join Date: Sep 2008
Location: North Port,Fl,
Posts: 88
Smile lights

I have an 05 32 fiesta and i must have ran over a tire shark (tire part on the road) and it cut the wires under the coach and blew a fuse. There is a third fuse box that i didnt know about which was under the hood central upper area which had the fuse/relay which solved my problem. Dont know what to suggest but double check ALL the fuses Under the dash drivers side and the two under the hood. Good luck....paul
pjkellrvers is offline   Reply With Quote
Old 03-28-2015, 04:36 PM   #4
Senior Member
Tiffin Owners Club
Freightliner Owners Club
Join Date: Aug 2014
Posts: 1,670
Your tail lights and Brake/Turn are probably in the same housing, so the fact that the Brake lights work indicates the ground is good to those assemblies.
It is likely that the marker lights are tied into a single wire run
coming from the front of the coach, the wire runs to the rear. Somewhere between the front and the middle, the connection is broken.

Are the marker lights on both sides not working??

I doubt that you have two marker light fuses.
Something to try.
Disconnect the chassis batteries if you like, or just be sure the headlight switch is OFF.
Remove one of the non-working marker light lens.
Remove the bulb.
Determine which socket contact is ground...although this is not critical.
Using a 12v lantern battery, connect the +12 & ground from the lantern battery to the socket contacts.
I suspect your non-working lights will light....and the good ones will not light up because of the broken wire (or bad connection).
2014 40QBH Phaeton DP Cummins 380HP ISL, Freightliner XC, 2014 Jeep Trailhawk TOAD
Blue Ox Aventa tow bar, SMI Air Force One -South Orange County Ca.
dpinvidic is online now   Reply With Quote

light, lights

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Aspire - Poor quality docking lights JoyalRV Entegra Owner's Forum 10 04-23-2016 09:21 PM
Fuse for roof lights ?? caheath Workhorse and Chevrolet Chassis Motorhome Forum 3 02-21-2015 08:30 PM
Toad Brake, turn and tail lights Dave1956 Toads and Motorhome Related Towing 40 06-21-2014 03:06 PM
All coach interior lights cut out but come back on pierider Monaco Owner's Forum 14 05-27-2014 05:59 AM
Vanity Lights montiem Newmar Owner's Forum 5 06-06-2013 04:36 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:46 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.