Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-17-2007, 03:56 PM   #1
Senior Member
 
Gadget Man's Avatar
 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Nov 2001
Location: Southern California
Posts: 2,090
I just had the Remco Driveshaft coupler installed on my Tacoma today. Everything seemed ok on the trip home from the mechanic, until the unit started squealing when coming to a stop and when in reverse. My mechanic said to spray some WD40 on the composite shoes that move the coupler in and out, to see if that corrected the problem. It did, but this fix surely can't last for long. Remco is closed at this hour so I can't call them until tomorrow. Anybody with this device experience the same issue?

Craig
__________________

__________________
2005 Fleetwood Providence 39J
CAT C7 350, MP-8 Programmer

My wife does all the driving - I just hold the wheel...
Gadget Man is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-17-2007, 03:56 PM   #2
Senior Member
 
Gadget Man's Avatar
 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Nov 2001
Location: Southern California
Posts: 2,090
I just had the Remco Driveshaft coupler installed on my Tacoma today. Everything seemed ok on the trip home from the mechanic, until the unit started squealing when coming to a stop and when in reverse. My mechanic said to spray some WD40 on the composite shoes that move the coupler in and out, to see if that corrected the problem. It did, but this fix surely can't last for long. Remco is closed at this hour so I can't call them until tomorrow. Anybody with this device experience the same issue?

Craig
__________________

__________________
2005 Fleetwood Providence 39J
CAT C7 350, MP-8 Programmer

My wife does all the driving - I just hold the wheel...
Gadget Man is offline   Reply With Quote
Old 09-17-2007, 08:16 PM   #3
Senior Member
 
Ford Super Duty Owner
Join Date: Feb 2002
Posts: 289
Craig if you've been under there you know the shoes slide in the coupler collar. It should be adjusted so they don't touch the collar. If it looks like it's riding on the back of the ring try pulling the cable out JUST A LITTLE to take the pressure off. and if it's in the front of the ring try pushing it back a little.
I'd use silicone(sp)instead of WD 40 less oil for dirt to stick to.
The shoes will wear down and the noise should go away if you can wait that long -. It just needs some fine tuning.
__________________
2001 Sea View 31' F53 1 slide
2012 Jeep Liberty Smi stay and play Duo brake system
Security by Bentley, KF6HCH, God Bless
John Wayne is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remco Driveshaft Couplers Gadget Man Toads and Motorhome Related Towing 15 07-09-2007 11:45 AM
Driveshaft Sully Alpine Coach Owner's Forum 6 05-31-2006 04:46 AM
Remco Driveshaft Install.. Drilling Differential LeeB Toads and Motorhome Related Towing 1 05-26-2006 07:37 PM
Experience w/ Remco driveshaft disconnect? rosegramma Toads and Motorhome Related Towing 8 11-03-2005 05:40 PM
Remco driveshaft disconnect - best prices? jelsema Toads and Motorhome Related Towing 2 09-21-2005 07:57 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.