Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-08-2007, 05:20 PM   #1
Community Moderator
 
Petro's Avatar


 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Dec 2003
Location: Weyauwega, WI US
Posts: 5,788
Is it normal for a Remco pump to be noisy? Mine is mounted on the inside fender liner of our Buick & I can feel the vibration on the fender. It appears to be pumping OK but the vibration broke the pump from its base. I used a plastic tie to fasten it to get home from our trip to CA.

Don
__________________

__________________
Don & Bev Morgan Weyauwega WI, 05 Itasca Horizon 40KD, 400 HP Cummins, Delorme GPS LT 40, Toad 07 Saturn Vue AWD, Air Force One, TST 510 TPMS, Mayor of Weyauwega 2007 - 2013, Waupaca Co Board Supervisor 2010 - 2014
Petro is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-08-2007, 05:20 PM   #2
Community Moderator
 
Petro's Avatar


 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Dec 2003
Location: Weyauwega, WI US
Posts: 5,788
Is it normal for a Remco pump to be noisy? Mine is mounted on the inside fender liner of our Buick & I can feel the vibration on the fender. It appears to be pumping OK but the vibration broke the pump from its base. I used a plastic tie to fasten it to get home from our trip to CA.

Don
__________________

__________________
Don & Bev Morgan Weyauwega WI, 05 Itasca Horizon 40KD, 400 HP Cummins, Delorme GPS LT 40, Toad 07 Saturn Vue AWD, Air Force One, TST 510 TPMS, Mayor of Weyauwega 2007 - 2013, Waupaca Co Board Supervisor 2010 - 2014
Petro is offline   Reply With Quote
Old 04-09-2007, 02:13 AM   #3
Senior Member
 
Join Date: Aug 2006
Posts: 175
I used a lub pump for three years, it always made a little noise ( you could hear it 3ft. away) you could always feel the pump working if you put your hand on the car. Like I said it did it for three years and never was a problem. I still have the pump in case I buy another car that cannot be towed 4 down without a pump.
__________________
2007 CC Allure 470
76dc is offline   Reply With Quote
Old 04-09-2007, 07:21 PM   #4
Member
 
Davestoy's Avatar
 
Join Date: Mar 2007
Location: Kennewick Wa
Posts: 69
You may want to ck the three set screws in front of the pump. Mine done the same thing. My installer took them out and and put locktite on them. The vibration went away. Yes as the previosly post said they are a little noisy.
__________________
2002 Holiday Rambler Imperial 38 ft ISL 400
M-G Brake & Crossfire System 2001 GMC sonoma Roadmaster Sterling tow bar
Davestoy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remco lube pump on '99 Dodge Caravan Don-Savannah, GA Toads and Motorhome Related Towing 15 04-01-2011 05:52 AM
Remco Lube Pump Issue ronboc Toads and Motorhome Related Towing 1 05-05-2007 04:11 PM
Who is using a Remco transmission pump? RV 4 2 Toads and Motorhome Related Towing 8 11-27-2006 05:11 PM
Remco Pump. Good on AWD? Lug_Nut Toads and Motorhome Related Towing 5 08-22-2006 03:02 PM
Remco Lube pump zetron Toads and Motorhome Related Towing 3 05-16-2005 06:02 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:20 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.