Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-02-2015, 07:32 AM   #1
Senior Member
 
Join Date: Oct 2009
Posts: 803
Remco pump problem little help please

This site's members have so much experience and knowledge it's hard to find anywhere that can compare!! Maybe one of you can assist me. Had a remco pump put on my wife's 04 330 AWD Lexus. Went on a 500 mile trip with no problem. Now the darn status box in the RV keeps sounding the buzzer. It does this when the cars electrical plug isn't plugged into the RV, and I understand if the pump stops working. The darn buzzer will go off about every 4 minutes for 10-20 seconds. Shuts off for 4-5 minuts then goes off again?? I called Remco tech. Guy said to wait until buzzer goes off and check to see if pump is running or not. Problem is every time in pull over to go check by the time I get back to toad buzzer has stopped. It won't do it sitting still. I finally asked the tech if the pump had any type of heat sensor in it as it seemed to happen less when I first started out in the morning. He said " oh yes that must be it as the pump will shut down at 185 degrees". The pump is mounted on same side as the exhaust coming diesel but I find it hard to believe that it is 185+ under the hood? Yesterday it was coming on and only 93 outside. If I leave cord plugged in and start the toad engine and drive the buzzer will only come on once in awhile?? Frustrating to say the least. Don't want to burn the transmission up but don't understand why the pump status buzzer keeps going off. Any of you guys ever seen this before or have any advise? All wires are tight and well installed. I think the pump might be bad even though I has less than 1000 miles on it.
Thanks in advance for any opinions guys. Traveling and not sure what to do.

Safe travels all
__________________

__________________
FLYING BUTCH is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-02-2015, 01:01 PM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,223
I'd think it would be very important for your pocketbook and health of the car's transmission to have an IR remote thermometer you can aim at the transmission when the buzzer goes off and give an indication of the real heat of the set up. If your diesel exhaust is blowing back under the toad and perhaps a rear radiator on the RV to boot, you could be driving temps up high enough to sound the alarm in 93 ambient temperatures.

Infrared Thermometer - Non-contact, Digital Thermometer
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 07-03-2015, 07:19 AM   #3
Senior Member
 
Join Date: Oct 2009
Posts: 803
Remco

Got the answer. Please look at my post. Brazels power chip.

Thanks everyone and safe travels
__________________
FLYING BUTCH is offline   Reply With Quote
Old 07-03-2015, 09:57 AM   #4
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,223
Quote:
Originally Posted by FLYING BUTCH View Post
Got the answer. Please look at my post. Brazels power chip.

Thanks everyone and safe travels
I don't understand how a Brazel power chip helps with the repeated Remco alarms. Please elucidate.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Penguin heat pump problem echo3 RV Systems & Appliances 4 02-27-2015 08:42 PM
Help with water pump problem please VB Bill Entegra Owner's Forum 18 02-20-2015 08:51 PM
Remco oil pump kit in a 2012 rav4 Wingrydr57 Toads and Motorhome Related Towing 11 09-22-2014 09:27 PM
Dometic 15M Penguin ACs drop into Heat Pump Sky_Boss RV Systems & Appliances 27 06-18-2014 07:55 PM
Water pump won't shut off?? SuperDad Class A Motorhome Discussions 29 02-20-2014 05:31 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.