Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-26-2014, 03:29 PM   #1
Member
 
Join Date: Sep 2013
Location: dickinson, tx
Posts: 77
Remco question

has any one ever used Remco drive shaft coupling to use on cars with automatic trans.
__________________

__________________
stew1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-26-2014, 08:30 PM   #2
Senior Member
 
Join Date: Aug 2011
Posts: 153
Installed one on my Ford Explorer 3 years ago. Still satisfied with it's performance. I think They have recently been bought out by another company. Don't know if that's good or bad.
__________________

__________________
2003 HR Imperial PKDD 40
bgholson is offline   Reply With Quote
Old 01-27-2014, 02:31 PM   #3
Junior Member
 
DennisBaker's Avatar
 
Newmar Owners Club
Join Date: Aug 2011
Location: Houston
Posts: 28
I have a Toyota 4Runner I went with a drive shaft dis-connect. I have used it for two years with no problems. Mine is a Remco.
__________________
__________________
Dennis and Beth Baker
2011 Phaeton 40 QBH,Toyota 4Runner, FMCA
DennisBaker is offline   Reply With Quote
Old 01-28-2014, 11:02 AM   #4
Member
 
BoPeg's Avatar
 
Join Date: Oct 2011
Location: Orange Va
Posts: 95
I got a remco disconnect 2 years ago for my '97 s-10 and it is working great. Have not heard anything bad about this product. B0peg
__________________
BoPeg is offline   Reply With Quote
Old 01-28-2014, 11:46 AM   #5
Member
 
Join Date: Jan 2013
Posts: 31
I have a 2002 S10 that I`ll need a driveshaft disconnect soon. can you tell me if your S10 has a large round balancer between u-joints and rear-end?
Thanks, riche156
__________________
riche156 is offline   Reply With Quote
Old 01-28-2014, 11:48 AM   #6
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 5,910
I've not used one but I have talked to two people at campgounds who had them and they were happy campers.
__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS
Arch Hoagland is offline   Reply With Quote
Old 01-28-2014, 02:55 PM   #7
Member
 
BoPeg's Avatar
 
Join Date: Oct 2011
Location: Orange Va
Posts: 95
Stew, hope you got my PM Bopeg
__________________
BoPeg is offline   Reply With Quote
Old 01-28-2014, 03:58 PM   #8
Member
 
Join Date: Jan 2013
Posts: 31
no luck at Napa web-site. I might be doing something wrong?
maybe a part number might help?
__________________
riche156 is offline   Reply With Quote
Old 01-28-2014, 04:08 PM   #9
Senior Member
 
johnsong3's Avatar
 
Tiffin Owners Club
Join Date: Mar 2011
Location: Ponte Vedra Beach, Florida
Posts: 112
We have a 2008 2-wheel drive Nissan Pathfinder. It has a total of 102,000 miles on it. We have had the drive shaft disconnect on it for the last 27,00 miles. We have pulled the Pathfinder probably 15,000 miles with the disconnect installed. It has proven to be better than I expected. Never any vibration when driving car when disconnected at speeds up to 85mph. It can be a little noisy when first engaging it but otherwise is great. Use an Air Force 1 braking system. Went with this instead of buying new car since this is my 6th Pathfinder. All high mileage.
__________________
johnsong3 is offline   Reply With Quote
Old 01-28-2014, 04:16 PM   #10
Senior Member
 
johnsong3's Avatar
 
Tiffin Owners Club
Join Date: Mar 2011
Location: Ponte Vedra Beach, Florida
Posts: 112
One clarification after reading my post. It does not vibrate above 85mph either. I just never find the need to go that fast very often.
__________________
johnsong3 is offline   Reply With Quote
Old 01-28-2014, 05:09 PM   #11
Member
 
BoPeg's Avatar
 
Join Date: Oct 2011
Location: Orange Va
Posts: 95
riche 156 Try this phone number 1-855-447-3626 or www.remcods.com Bopeg
__________________
BoPeg is offline   Reply With Quote
Old 01-30-2014, 05:41 PM   #12
Member
 
Join Date: Jan 2013
Posts: 31
Quote:
Originally Posted by BoPeg View Post
riche 156 Try this phone number 1-855-447-3626 or www.remcods.com Bopeg
Thanks Bopeg, called above phone number and talked to Bill. went to website got a forum and filled in info. I`ll fax it this Friday.
Thanks
__________________
riche156 is offline   Reply With Quote
Old 01-31-2014, 08:37 AM   #13
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 22,821
OF all the Remco products this is the one that generates the most trouble reports here and on other forums.. But that said.. If I had a RWD car, it would still be my first choice. Just as the Axle lock is my first choice for a FWD car.. Alas, the car I have the LP-1 was the only choice.

(Can't get behind the wheel to operate the Axle lock you see).
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 01-31-2014, 08:42 AM   #14
Member
 
BoPeg's Avatar
 
Join Date: Oct 2011
Location: Orange Va
Posts: 95
Richie 156 that's good news, the only draw back I had was the 5 to 6 week delivery
__________________

__________________
BoPeg is offline   Reply With Quote
Reply

Tags
towing



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tankless water heater question????? dms Tiffin Motorhomes Owners Forum 18 03-02-2014 04:54 PM
Question for the Forum Extremerving iRV2.com General Discussion 11 01-15-2014 07:31 AM
Newbie Question About Power Inverters and Electrical exploring RV Systems & Appliances 11 01-05-2014 04:18 PM
Question about "Exclusionary" Service Contract - Something doesn't sound right 00wabbit Class A Motorhome Discussions 14 01-03-2014 12:21 PM
Bounder: Question on New MH BarryN514 Fleetwood Products Owner's Forum 26 11-07-2013 08:34 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.