Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-22-2012, 02:20 PM   #1
Senior Member
 
lmcgill's Avatar
 
Fleetwood Owners Club
Join Date: Sep 2011
Location: White Rock BC
Posts: 137
Right blinker/tail light stays on in tow vehicle

Need a little help before I take the Coach in to dealer.
I have an issue with the right tail/blinker staying on as soon as the harness is connected to the Jeep. Took Jeep in, all is working fine, bought new cable for Motorhome to Jeep, old one was fine! Bought a quality circuit tester, found out the green wire(right turn brake) coming into the factory motorhome 7 pin plug had constant power. Circuit tester showed left blinker circuit working fine. I suppose the good news is that I have located the source of the issue, now have to find out how to figure out why their is constant power to the pin. Coach lights all work fine, it is just between the plug and wherever it goes in the motorhome.
__________________

__________________
American Coach 2012 Revolution 42W
*****SOLD*****
lmcgill is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-22-2012, 02:30 PM   #2
Senior Member
 
87Rockwood's Avatar
 
Vintage RV Owners Club
Join Date: Apr 2012
Location: Looking here and there.
Posts: 732
Sounds like a mis-wire. Do any other pins in the plug act like the right tail light? Some times there is a steady 12volts to a trailer for emergency electric brakes(charges a small 12 volt battery)
__________________

__________________
87Rockwood is offline   Reply With Quote
Old 05-22-2012, 03:53 PM   #3
Senior Member
 
lmcgill's Avatar
 
Fleetwood Owners Club
Join Date: Sep 2011
Location: White Rock BC
Posts: 137
Quote:
Originally Posted by 87Rockwood View Post
Sounds like a mis-wire. Do any other pins in the plug act like the right tail light? Some times there is a steady 12volts to a trailer for emergency electric brakes(charges a small 12 volt battery)
It was working before, so I don't think it could be a mis-wire. I talked to Spartan and they told me to check power in and out of the "Spartan Controler" in the generator slide. I noticed some corrosion by a terminal post so I am going to clean that and see if that is the source.
__________________
American Coach 2012 Revolution 42W
*****SOLD*****
lmcgill is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.