RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-25-2019, 10:51 AM   #1
Member
 
Join Date: Sep 2015
Posts: 61
Roadmaster Even Brake issue

I have an Even Brake that has worked well until now. When I run the test it compresses the pedal twice and gives a red light instead of 3 pedal presses and a green light. The receiver in the coach doesnít respond at all. I donít get a test fail or anything on the receiver. Any suggestions for trouble shooting?
Thanks
__________________

Kasey is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-25-2019, 02:18 PM   #2
Senior Member
 
TonyMac's Avatar


 
Monaco Owners Club
Join Date: Oct 2014
Location: Layton, Utah
Posts: 2,857
The Even Brake needs to sense the brake light voltage to know if it is riding the brakes. Is this wire still connected? The wire connects the brake light circuit to the Even Brake module on the dash of the toad.
__________________

__________________
Cheers,
TonyMac
2006 Monaco Safari Cheetah 40PMT
TonyMac is offline   Reply With Quote
Old 04-25-2019, 04:55 PM   #3
Member
 
Join Date: Sep 2015
Posts: 61
Thanks TonyMac I visually checked most connections but not that one. Itís an extra brake light switch I installed years ago. It is way up under the dashboard so 1st chance I get I will check it.
Kasey is offline   Reply With Quote
Old 04-26-2019, 01:06 PM   #4
Member
 
Triple E Owners Club
Join Date: Jul 2017
Posts: 71
I had the same problem this year on a return trip. I tried it a few times on the way home and it would just push the pedal twice and then fail.

Once home, I went over all the connections & they all looked good, nice crimps, nothing loose. I pulled & pushed on them etc. After that, pushing the test button worked as expected and the test completed successfully.
__________________
2002 Triple E on 2002 F53 Chassis
RV2traveler is offline   Reply With Quote
Old 04-26-2019, 03:05 PM   #5
Senior Member
 
bborc's Avatar
 
Monaco Owners Club
Join Date: May 2008
Location: MI
Posts: 316
I had that same problem last year. Found the wire came off brake aux brake switch.
__________________
2007 Knight 40ft
bborc is offline   Reply With Quote
Old 04-26-2019, 03:20 PM   #6
Senior Member
 
gerdutch's Avatar
 
Join Date: Nov 2010
Posts: 362
Had the same problem and to get home, just didnt plug in the transmitter, and it tested fine . Made it home
__________________
02 Allegro Bus
ISC 350 Cummins
gerdutch is offline   Reply With Quote
Old 04-27-2019, 03:37 PM   #7
Member
 
Join Date: Sep 2015
Posts: 61
Quote:
Originally Posted by gerdutch View Post
Had the same problem and to get home, just didnt plug in the transmitter, and it tested fine . Made it home


Thank you for the good info! I went thru my connections, pulled and replaced fuses and everything looked okay. Didnít get a chance to try it until we were headed home and it worked flawlessly. So I guess I had a bad connection somewhere.
__________________

Kasey is offline   Reply With Quote
Reply

Tags
brake, roadmaster



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Roadmaster Even Brake vs Brake Master Golfer Guy Toads and Motorhome Related Towing 3 07-11-2016 01:39 PM
Even Brake by roadmaster Kvtaylor Toads and Motorhome Related Towing 32 05-10-2011 10:03 AM
Roadmaster Even Brake - brake lite relay Meurigd Toads and Motorhome Related Towing 1 02-08-2011 08:52 PM
Roadmaster Even Brake w/2009 Jeep Wrangler as Toad Renipladlo Toads and Motorhome Related Towing 8 10-05-2009 11:12 PM
Brake Buddy Vantage vs Roadmaster Even Brake Howard Leap Toads and Motorhome Related Towing 24 03-29-2009 08:33 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×