RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-05-2019, 05:54 PM   #1
Member
 
Join Date: Jan 2017
Location: DOUGLASSVILLE, PA
Posts: 71
Roadmaster Even-Brake not communicating

Good evening all.

I purchased a used Even-brake system with the MH monitor, used, that came with a falcon all terrain tow bar and the safety cables.
I purchased a second vehicle kit that included the ICX monitor and all the safety components, brake away switch, wiring. I also purchased the diode kits for the lights and the tow assembly for a 2008 Honda CR-V.

my issue is i cannot get the components to communicate. i go through the procedure to have the monitor, even-brake and ICX and get a failure in test.
the breakaway switch does activate the even-brake so safety is no concern. we have an ITASCA 35F on a ford chassis.

does anyone have a similar set up and can enlighten me on what may be the problem? i have check and recheck my wiring and talked to the tech at Roadmaster and he said i have to replace the even-brake. I find it hard to believe that it is the issue, it applies the brakes on test but i get a red light, the break away switch locks up the brakes as it should.
i apologize for the lengthy message but at wits end, bought a toad and all the component and still have not toed it.
__________________

tconn308 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-06-2019, 11:42 PM   #2
Senior Member
 
Monaco Wolfy's Avatar


 
Join Date: Feb 2017
Location: Gig Harbor, Washington, Point Fosdick Area
Posts: 261
I had a similar issue with mine about three years ago. I bought mine used also. I can't recall exactly where the leak was, but it was leaking air from or near the units compressor. Check for air leaks within the even brake unit. If it can't hold air, the red light will come on. I was getting the red light also. I found the leak. Fixed it, and it's been working great ever since. Even brake told me they could fix or replace it.
__________________

__________________
2004 40' Monaco Windsor PDQ, Cummins 400hp ISL, 4 slides, Aqua-Hot, 1900 watts solar, Mini Cooper S, Gig Harbor, Washington
Monaco Wolfy is offline   Reply With Quote
Old 06-07-2019, 12:07 AM   #3
Senior Member
 
Isaac-1's Avatar
 
Join Date: Jun 2016
Location: SW Louisiana
Posts: 3,679
I also recently bought a used Even Brake system, and am in the process of setting it up in a TOAD. I have read over your message a couple of times and am not sure exactly what you have done.



Did you pair the receiver with the new ICX while both were in the TOAD, I think they may operate at limited transmit strength when doing initial pairing so must be located within a couple of feet of each other.


See https://www.roadmasterinc.com/pdf/25-3649.pdf


My used Even Brake came with a cracked but working in coach receiver, plus a new receiver, which I had to pair with the old ICX to get to function, so sort of the same situation you have, just the other way around.


ps check to make sure you have the right second vehicle kit, do you have part number 98400 or 98450? The Even Brakes built up until very recently use kit 98400, only the newest Even Brake units with serial numbers 27,497 and up use 98450, the ICX's look the same, but have different part numbers, so may be different.
__________________
2002 Safari Trek 2830 on P32 Chassis with 8.1L
Isaac-1 is offline   Reply With Quote
Old 06-09-2019, 02:53 AM   #4
Senior Member
 
USMCRET's Avatar
 
Newmar Owners Club
Join Date: Jul 2011
Posts: 1,871
I’m not completely understanding your problem. A test failure and a communication failure are separate issues. If you are going through the process of powering up/testing the Even Brake unit, you’ll get a red light if the unit doesn’t pass it’s self-test. There are innumerable reasons it could fail the test including too much movement of the unit as it is pumping the brake pedal...which is what usually happens when mine fails.
__________________
2005 Newmar KSDP 3910
ISC on a Spartan
USMCRET is offline   Reply With Quote
Old 06-09-2019, 08:10 AM   #5
Member
 
Join Date: Jan 2017
Location: DOUGLASSVILLE, PA
Posts: 71
Thank you all for the responses. I will try to clarify my situation.first off, I contacted Roadmaster and talked to a tech, I assume, and he nor anyone he talked to at his location could figure out what to do, they suggested buying a new one. They said they do not have parts for the serial number i have. Well, I know that they stop making parts after a period of time, I work for a major HVAC manufacturer. But when the breakaway switch locks the brakes up as it should, and the even-brake pumps 2 times then get a red light and and the monitor stays at 'press the test button' I think what is wrong is minor.

I probably explained wrong on the com. problem, I just thought that maybe do to it being wireless com., the monitor is not talking to the ICX, but then realized that it is a 'monitor'.

So, Update, because the breakaway switch worked and the MH, I could imagine, would be able to stop our 2008 CR-V we went on a 4 day trip to Gettysburg. All was well and when we arrived at the campground my wife asked what was beeping, i looked at the monitor and it said the breakaway switch was disengaged. Of course it did not but at least I was something different on the monitor.
When we leave for home Monday, And by the way I did have the monitor in the car when trying to pair, I will try to pair again.

I know this is long winded but really would like it all to work. Though I do not hear an air leak, when we get home I will check with soap bubbles.
tconn308 is offline   Reply With Quote
Old 06-09-2019, 09:46 AM   #6
Senior Member
 
Isaac-1's Avatar
 
Join Date: Jun 2016
Location: SW Louisiana
Posts: 3,679
Something does not sound right here, you may want to call Roadmaster again, as of a couple of months ago it was my understanding that all 9400 Even Brakes were still supported, and that they offered a flat rate $250 repair program.
__________________
2002 Safari Trek 2830 on P32 Chassis with 8.1L
Isaac-1 is offline   Reply With Quote
Old 06-10-2019, 06:25 PM   #7
Member
 
Join Date: Jan 2017
Location: DOUGLASSVILLE, PA
Posts: 71
Thanks You Isaac-1. I found it hard to believe that a company would not support an older product, that really looks new and I upgrade firmware and boards all the time on the HVAC equipment I support, even 12 year old equipment.

I will call them tomorrow to see about the $250 reconditioning that you mentioned. The tech did offer to sell me a unit for $800. if i send my unit back.
This transition is becoming a money pit and the market is flooded with tow dollys. I may put it on here.

Ya'll are great!
tconn308 is offline   Reply With Quote
Old 06-10-2019, 09:23 PM   #8
Senior Member
 
Isaac-1's Avatar
 
Join Date: Jun 2016
Location: SW Louisiana
Posts: 3,679
Please let us know how it turns out, I know that there are older models which they don't support, though as mentioned above I thought all Even Brake 9400's were still covered under the $250 repair program
__________________
2002 Safari Trek 2830 on P32 Chassis with 8.1L
Isaac-1 is offline   Reply With Quote
Old 06-19-2019, 01:36 PM   #9
Member
 
Join Date: Jan 2017
Location: DOUGLASSVILLE, PA
Posts: 71
Up date,

I sent a lengthy email to ROADMASTER begging for some kind of help. I received an email from a Benny Asonia. He was extremely helpful and patient.

He explained that my serial number was past the date of possible repair do no parts no longer available, ours is 019xxx and they support now only 022xxx.
He said they have a trade in program that I can participate in and there is no time line that allows us to send in our unit and receive a new one including the ICX and monitor for $800.00 I feel that is pretty fair.

Now on to the assistance he gave us. He went through a diagnostic process that by reversing the way i plug all the breakaway switch and power the even-brake and the ICX in reverse, he got it to FINALLY get a green light!!! WAHOO!!
he also said everything will function properly and gave us some other tips for use and we should have no more issues.
So I believe we may take him up on the trade in offer but first sell the tow dolly, and as I told Benny, the problem is there are 40,000,000 used tow dollies for sale out there, so we will see. Thank you everyone for your interest and help!
__________________
2014 Itasca SunStar 35F
2008 Honda CR-V toad
tconn308 is offline   Reply With Quote
Old 06-19-2019, 03:27 PM   #10
Senior Member
 
Isaac-1's Avatar
 
Join Date: Jun 2016
Location: SW Louisiana
Posts: 3,679
Thanks for updating us on this issue, out of curiosity do you know the build date on this unit?
__________________
2002 Safari Trek 2830 on P32 Chassis with 8.1L
Isaac-1 is offline   Reply With Quote
Old 06-20-2019, 12:46 PM   #11
Member
 
Join Date: Jan 2017
Location: DOUGLASSVILLE, PA
Posts: 71
The first ech I talked to when I first contacted Roadmaster said it was a 2009
__________________
2014 Itasca SunStar 35F
2008 Honda CR-V toad
tconn308 is offline   Reply With Quote
Old 06-21-2019, 05:36 PM   #12
Senior Member
 
USMCRET's Avatar
 
Newmar Owners Club
Join Date: Jul 2011
Posts: 1,871
Quote:
Originally Posted by tconn308 View Post

Now on to the assistance he gave us. He went through a diagnostic process that by reversing the way i plug all the breakaway switch and power the even-brake and the ICX in reverse, he got it to FINALLY get a green light!!! WAHOO!!
he also said everything will function properly and gave us some other tips for use and we should have no more issues.
Another anecdote on this issue:

In January, I plugged in my EB and it wouldn’t do anything but give me a red light. This unit was less than a year old at that point. I played around with it and discovered that if I reversed the order that I plugged in the power cord and ICX, it would power up.

I called Roadmaster and the gal on the phone confirmed I had discovered the workaround. RM was aware of it and did not know why that occurs in some units. I thought it odd, but went about the business of preparing for our winter journey.

I then discovered that the monitor was no longer reporting the volts in the toad. Nothing but a big zero.

I called RM again (out of warranty now by a number of days) and was told the only option available was to send it back and get another at a reduced price ($700 as I recall). That did not make me happy and I’m still not happy about it, since I first talked to them about it when my unit was still under warranty.

We completed our winter journey and the EB appeared to work okay, but I do not trust what is being reported on the monitor.
__________________

__________________
2005 Newmar KSDP 3910
ISC on a Spartan
USMCRET is offline   Reply With Quote
Reply

Tags
brake, cat, roadmaster



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Roadmaster Even Brake vs Brake Master Golfer Guy Toads and Motorhome Related Towing 3 07-11-2016 01:39 PM
Dometic & Onan EC30 not communicating corky.bailey Newmar Owner's Forum 14 10-09-2014 08:31 AM
King Dome Model #9702 not communicating Ragman Technology: Internet, TV, Satellite, Cell Phones, etc. 3 05-17-2011 03:08 AM
Roadmaster Even Brake - brake lite relay Meurigd Toads and Motorhome Related Towing 1 02-08-2011 08:52 PM
Brake Buddy Vantage vs Roadmaster Even Brake Howard Leap Toads and Motorhome Related Towing 24 03-29-2009 08:33 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×