Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-16-2015, 11:30 AM   #15
Member


 
Freightliner Owners Club
Join Date: Mar 2014
Posts: 74
Quote:
Originally Posted by IRVDoU View Post
I just installed the Blue Ox Aventa tow bar on my 2015 Allegro Bus and base plate on the Chevy Equinox. Got the RVIBrake2 and the towed vehicle battery charger. I think I will order the 12V adapter and install it as I don't think the internal 12V plugs will put out enough dedicated power.

Seems like a good setup so far - plan to order the TPMS soon....RVIBrake customer support has been great...the whole setup - Aventa tow bar, baseplate, RVIBrake2 and related accessories was about $2400 total...

IRVDoU, that is the exact combination with the Blue Ox Aventa and the RVIBrake system. That I am going to pull my 2008 Tahoe. The reviews on the Aventa tow bar said of aggressive wear on the connection (ball connector) hitch receiver. I would like to hear if you experience the same wear as the reviews mentioned. Please keep in-touch. Thanks!
__________________

__________________
Freebird1958 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-16-2015, 11:51 AM   #16
Senior Member
 
Join Date: Sep 2010
Posts: 216
Gemini, what year is your Enclave? I'm having a problem with my 2015 Acadia and GM claims it's due to my RVI system. Appreciate an email to joelyn5@verizon.net
__________________

__________________
Joel, Lynette and the pups, Czarina & Natasha
2011 Essex 4556
joelyn5 is offline   Reply With Quote
Old 02-16-2015, 09:25 PM   #17
Senior Member
 
gemini5362's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Posts: 2,078
Quote:
Originally Posted by Scottybdivin View Post
I also have the RVI battery charger. I discovered that my charge wire from the coach was not energized and it took me a while to find the problem. I couldn't get it going for our 1st trip towing the F150. It was only a 5 hour trip and the battery was fine when we arrived. Did you go multiple days when you found the dead battery or did it discharge all in one day? We may need it for a few long travel days heading west to AZ and UT in Apr. We probably will not unhitch the F150 along the way.

My dealings with RVI have been similar to yours, working through some minor setup issues. 1st class customer service.
I actually had it go dead over a couple of days and part of the problem was that i just stopped to sleep and did not turn the brake system off. So it ran part of the day that night and the next day. I noticed that the monitor said something about low battery but I did not realize it was the toad battery that was low.
__________________
gemini5362 is offline   Reply With Quote
Old 02-17-2015, 08:15 AM   #18
Senior Member
 
Scottybdivin's Avatar


 
Newmar Owners Club
Join Date: Jun 2012
Location: Spicewood Texas (West of Austin)
Posts: 3,380
Quote:
Originally Posted by gemini5362 View Post
I actually had it go dead over a couple of days and part of the problem was that i just stopped to sleep and did not turn the brake system off. So it ran part of the day that night and the next day. I noticed that the monitor said something about low battery but I did not realize it was the toad battery that was low.
Thanks for that information. Hopefully I have my 12V charging in place now and I won't have to worry about it. I can see how the RVI2 could easily get left on when you pull into a park after a long day.
__________________
Scotty and Kristen, Airedales Dagny and Wyatt
2007 Newmar Mountain Aire 4528, 450 HP ISM, Allison 4000, 8 Trojan T-105's
2014 F150 4x4 Crew Cab Platinum 157" WB
Roadmaster Blackhawk 2, RVI2 Brake System
Scottybdivin is offline   Reply With Quote
Old 02-18-2015, 06:42 PM   #19
Senior Member
 
gemini5362's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Posts: 2,078
Quote:
Originally Posted by joelyn5 View Post
Gemini, what year is your Enclave? I'm having a problem with my 2015 Acadia and GM claims it's due to my RVI system. Appreciate an email to joelyn5@verizon.net
I sent you an email with the subject as IRV2 conversation. If you do not get it send me a private message on here and i will send it again.
__________________
gemini5362 is offline   Reply With Quote
Old 02-18-2015, 09:51 PM   #20
Senior Member
 
jrgreen's Avatar
 
Fleetwood Owners Club
Join Date: Jan 2013
Location: NC
Posts: 177
I use the RVIBrake 2 without a battery charger and have not had any battery issues. Great product!
__________________

__________________
2008 Fleetwood Discovery 40x
2002 Jeep Liberty
jrgreen is offline   Reply With Quote
Reply

Tags
abs, brake



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My ABS Light Story: ktoutoor Workhorse and Chevrolet Chassis Motorhome Forum 19 05-27-2016 05:33 PM
Intermittent ABS light and warning Glen and Sal National RV Owner's Forum 18 01-28-2015 08:27 PM
ABS Reset??? MSGulfCoast Monaco Owner's Forum 7 08-09-2014 10:21 AM
ABS Light Causes DonL Spartan Motorhome Chassis Forum 2 03-13-2014 05:01 PM
ABS Error, Please Help bigskymt Freightliner Motorhome Chassis Forum 2 02-19-2014 05:59 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:01 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.