Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-09-2014, 11:31 AM   #1
Junior Member
 
Join Date: Mar 2014
Posts: 2
Rvibrake compressor wont stop running

Been working fine for 1.5 years now compressor doesnt stop. On the road now so any help would be greatly appreciated
__________________

__________________
granpoobah is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-09-2014, 12:46 PM   #2
Senior Member
 
Join Date: Jul 2011
Posts: 939

I have one of these units too. No problems yet. I thin you should call them M-F at 800-815-2159 and talk to customer support.

I checked their online FAQ and this question doesn't seem to be answered. I think you may have a leak in the RVI pump system that keeps it from coming up to full pressure and therefore the pressure shutoff switch doesn't turn off. Or maybe the pressure shutoff switch has failed. Good luck!
__________________

__________________
2004 Tiffin Allegro 27.5 ft. P32 18,000 lb GVW. 8.1 liter. Workhorse chassis built May 2002. 21,000 miles. 2012 Jeep Liberty Toad. RVi2 brake unit.
Full.Monte is offline   Reply With Quote
Old 03-10-2014, 10:48 AM   #3
Junior Member
 
Join Date: Mar 2014
Posts: 2
Just got off the phone with Customer Support. This company is absolutely awesome. They are shipping a replacement to the local UPS store next day air no cost to me!!!

Highly recommend RviBrake!
__________________
granpoobah is offline   Reply With Quote
Old 03-10-2014, 11:45 AM   #4
Senior Member
 
lllkrob's Avatar
 
Join Date: Nov 2008
Posts: 1,683
Did the same for me when I had a similar problem with mine. Awesome customer service. There are quite a few other companies that could take lessons from them.
__________________
2013 Tiffin Phaeton 40QBH
2016 Chevrolet Equinox LTZ AWD V6
lllkrob is offline   Reply With Quote
Reply

Tags
brake, compressor



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Found convection microwave running wstrace3 Thor Industries Owner's Forum 14 03-29-2014 03:35 PM
Running Electric bjo Monaco Owner's Forum 4 02-10-2014 07:29 PM
Question on running lights & turn signals 2003 monaco exec. lbaldwin Monaco Owner's Forum 4 09-30-2013 10:00 AM
Diesel keeps running but strangely Muledeer2 Vintage RV's 2 09-07-2013 12:32 AM
Stop engine light question becks Cummins Engines 4 07-24-2013 11:52 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.