Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-08-2012, 09:16 AM   #1
Senior Member
 
toneumanns's Avatar
 
Join Date: Jul 2011
Posts: 792
RVIbrake question

I installed a RVIbrake system in my toad. After pushing the green Auto Start button the actuator goes through 5 cycles. After these cycles the motor continues to run. Is this normal or should it shut off until a braking application is necessary?
__________________

__________________
2011 Itasca Suncruiser, Jeep Grand Cherokee toad
MSgt retired USAF 1988, AA retired 2005
toneumanns is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-08-2012, 10:19 AM   #2
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 22,792
It should continue to run.... For a while.

The motor is an air compressor if I'm not mistaken it will run till pressure builds up.

Give it like 2 - 3 minutes, If it's still running 5 minutes later call RVI.
__________________

__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 09-10-2012, 11:48 AM   #3
Senior Member
 
toneumanns's Avatar
 
Join Date: Jul 2011
Posts: 792
Tech support (company owner) called me this morning & RVIbrake put out units with an upgrade that developed problems. Although they responded quickly with a new unit I think they should have recalled their product rather than customers finding the defective units.
__________________
2011 Itasca Suncruiser, Jeep Grand Cherokee toad
MSgt retired USAF 1988, AA retired 2005
toneumanns is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.