Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 05-09-2014, 03:33 PM   #15
Senior Member
tropical36's Avatar
Join Date: Jul 2007
Location: SW Florida
Posts: 1,170
Originally Posted by JFNM View Post
Same here. I don't think it could be any easier. Maybe the difference is the transmission?? Mine is a manual trans 2010 JK.
Mine is a 2010 auto, but either shouldn't have anything to do with the wire harness and operating the lights. When I say plugged in properly, it seems that one could make a mistake back in the left tail light, when plugging in the harness there and if I remember correctly.

07 Fleetwood Revolution LE 40E_Spartan MM_C9 Clatterpillar_ Allison 3000
1998 36ft. National Tropi-Cal Chevy Model 6350 (SOLD)
Dinghy_2010 Jeep Wrangler JKU ISLANDER
tropical36 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Led light bulbs PAPA J Monaco Owner's Forum 19 08-19-2014 02:06 PM
2014 Aspire docking lights (bulbs): can't find same ones as OEM! JoyalRV Entegra Owner's Forum 3 04-28-2014 06:56 PM
2003 Sighseer 30B on Worhorse Chassis High Beam Bulbs StreetGlo Class A Motorhome Discussions 3 03-11-2014 10:51 PM
Microwave 40 Watt Bulbs Converted to LED's Dr4Film Class A Motorhome Discussions 6 01-28-2014 03:18 PM
LED bulb replacement issue..? (921 bulbs) Superslif RV Systems & Appliances 8 06-06-2013 08:10 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:58 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.