RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-15-2019, 03:41 PM   #1
Member


 
Join Date: Mar 2018
Posts: 88
So I'm Setting Up My Toad...

So I am setting up my 2017 Ford F-350 4x4 as a toad and for the most part things have gone well until I finished the wiring portion. I used a Blue Ox BX8848 4-diode kit and mated that up with a Blue Ox BX88206 coiled cable and 6 PIN connector. Followed the directions to the letter and thought I would use my wife's Yukon Denali to test. Used a 7-way tester to make sure her connector was live as this is the first time it was used and it was fine. Plug it up to my F-350 and nothing works - signals, brakes or running lights. Worried about a bad ground but threw my meter on the ground pin in the 6-pin connector and it tests fine. Truck by itself works fine too - brakes, signals and running lights. Any ideas? I stumped...
__________________

__________________
2020 Renegade Verona 40VBH
2019 Jeep Wrangler Unlimited Rubicon
2017 Ford F-350 Platinum 4x4
2017 Keystone Sprinter 325BMK (Our Backup RV)
jalewis is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-15-2019, 09:22 PM   #2
Senior Member
 
petrel's Avatar
 
Join Date: Sep 2015
Location: Urbanna, VA
Posts: 790
I just went through a very similar problem while setting up our new (to us) jeep as a toad. It was a ground issue. I had ground at the back of the tow vehicle, verified ground at the connector on both the tow vehicle and verified that it was coming across. However, the ground wire leaving the plug on the toad was not making ground on the toad chassis. I had grounded it to the bumper, but the bumper was not a good ground. So the harness would test, but the lights still would not work.

I had no good primary wire (long story) and had to leave for a trip, so I ended up cutting down an extension cord and running it from the toad plug ground to the battery (-) so I had a rock solid ground.

You sound a bit more technically savvy than me, so your issue is probably more involved. Just thought I'd share. Ground is the culprit on so many DC issues.
__________________

__________________
2006 Renegade Classic 3200DM/Freightliner Coronado Chassis/Series 60 Detroit Diesel 515hp.
http://www.irv2.com/photopost/showga...er=170823&sl=p
petrel is offline   Reply With Quote
Old 06-16-2019, 07:03 AM   #3
Member


 
Join Date: Mar 2018
Posts: 88
Petrel - I have a feeling you are going to be 100% correct about the issue. I'm going to test this morning by doing exactly what you did and grounding to the battery terminal. I have a suspicion that will do it. Thanks for the feedback and I'll post what I find.
__________________
2020 Renegade Verona 40VBH
2019 Jeep Wrangler Unlimited Rubicon
2017 Ford F-350 Platinum 4x4
2017 Keystone Sprinter 325BMK (Our Backup RV)
jalewis is offline   Reply With Quote
Old 06-16-2019, 10:00 AM   #4
Member


 
Join Date: Mar 2018
Posts: 88
I have solved my issue and the lights all work as they should now (turn signals, brake and running lights). Turns out it was not a ground wire issue. I used a Hopkins 6-Pin connector kit for the toad connection. It came with a printed wiring schematic that I used for the initial wire connections. The problem was the schematic was wrong. It had wire connections out of sequence. I pulled the connector and went by the connection ID's stamped next to each terminal. After doing that I tested it and all works as it should. Good lesson for me to learn - all that's written isn't necessarily accurate....
__________________
2020 Renegade Verona 40VBH
2019 Jeep Wrangler Unlimited Rubicon
2017 Ford F-350 Platinum 4x4
2017 Keystone Sprinter 325BMK (Our Backup RV)
jalewis is offline   Reply With Quote
Old 06-16-2019, 01:24 PM   #5
Senior Member
 
petrel's Avatar
 
Join Date: Sep 2015
Location: Urbanna, VA
Posts: 790
Glad you sorted out! Hope my suggestion didn't lead you on a wild goose chase for too long.
__________________
2006 Renegade Classic 3200DM/Freightliner Coronado Chassis/Series 60 Detroit Diesel 515hp.
http://www.irv2.com/photopost/showga...er=170823&sl=p
petrel is offline   Reply With Quote
Old 06-16-2019, 04:46 PM   #6
Member


 
Join Date: Mar 2018
Posts: 88
Not at all. As a secondary precaution I added another grounding point towards the front of the vehicle located on the frame. The rear ground point was a self tapping screw into the truck bed. While sufficient I suppose, I fell better having a solid grounding point. I have chased poor grounds in the past and that ain't no fun! Thanks again for your help!
__________________

__________________
2020 Renegade Verona 40VBH
2019 Jeep Wrangler Unlimited Rubicon
2017 Ford F-350 Platinum 4x4
2017 Keystone Sprinter 325BMK (Our Backup RV)
jalewis is offline   Reply With Quote
Reply

Tags
toad



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help setting up 2012 MKZ hibrid as a TOAD doit2010 Toads and Motorhome Related Towing 7 09-08-2015 10:41 PM
Setting up a Cmax as a TOAD pshoe Toads and Motorhome Related Towing 5 04-02-2015 07:41 PM
Setting up a Toad Kenley89 Toads and Motorhome Related Towing 2 07-28-2014 05:19 PM
Setting Up My Toad JustCruising Toads and Motorhome Related Towing 6 03-25-2013 01:43 PM
Setting up an MG-B as a Toad/Dinghy Phoggberg Toads and Motorhome Related Towing 49 09-05-2012 02:23 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×