Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-15-2013, 06:55 AM   #1
Senior Member
 
huntnski's Avatar
 
Fleetwood Owners Club
Join Date: Dec 2012
Location: Arkansas
Posts: 7,660
Testing a Brake Buddy

I have a older Brake Buddy that came with my 2008 MH. Its not the digital style like the Manuel I found, but everything else seems the same. When setting it up it preforms like it should. Test button activates, sensitivity lights can be changed and knob controls pressure as described.

Here is my problem! I have pulled toad with everything set up properly and sensitivity set at 4 then 5 then on up through 7 . I have never felt anything that indicates the unit is working, nor has the in MH monitor ever shown red except when someone pushes test button.

Is there someway to test unit to see if the sensing mechanism is working. I've done some quick stops when towing trying to set it off but still nothing!
__________________

__________________
Tim & Mary Discovery 40X. Chevy Tahoe. RVM32
"I've been lost now, days uncounted..."GFR"
huntnski is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-15-2013, 07:02 AM   #2
Senior Member
 
bruceisla's Avatar
 
Join Date: Oct 2012
Location: St. Lucie West, FL
Posts: 5,115
Quote:
Originally Posted by huntnski View Post
I have a older Brake Buddy that came with my 2008 MH. Its not the digital style like the Manuel I found, but everything else seems the same. When setting it up it preforms like it should. Test button activates, sensitivity lights can be changed and knob controls pressure as described.

Here is my problem! I have pulled toad with everything set up properly and sensitivity set at 4 then 5 then on up through 7 . I have never felt anything that indicates the unit is working, nor has the in MH monitor ever shown red except when someone pushes test button.

Is there someway to test unit to see if the sensing mechanism is working. I've done some quick stops when towing trying to set it off but still nothing!
When you say "performs like it should" does the arm extend and pump the brake pedal when you use the test button?
__________________

__________________
2005 Newmar Essex 4502, 2013 Caddy SRX
1997 HR Endeavor 37, CAT, 1996 Geo Tracker
bruceisla is offline   Reply With Quote
Old 04-15-2013, 07:48 AM   #3
Senior Member
 
jzick's Avatar
 
Join Date: Feb 2007
Location: Florida
Posts: 1,193
When we first started to use our Brake Buddy, I had DW drive the motorhome and I rode in the towed car in order to satisfy my curiosity about how it worked. Test was successful, I survived, not sure whether my method was legal or smart. Our sensor does activate, however, whenever the brake applies.
__________________
jzick is offline   Reply With Quote
Old 04-15-2013, 08:13 AM   #4
Senior Member
 
krivanj's Avatar


 
Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Oct 2009
Location: Fort Pierce, FL
Posts: 639
There should be a remote light system that lights up on your dash in the MH whenever the BB activates. If you have this, you know it is working. By raising the air pressure, you can feel the effect it has on the MH.
__________________
Revolution LE 38X C9 Cat
2011 Scion TC toad
1985 KLR 600 as a backup...
krivanj is offline   Reply With Quote
Old 04-15-2013, 08:19 AM   #5
Senior Member
 
CampDaven's Avatar


 
Join Date: Jul 2012
Location: Fulltime, USA
Posts: 14,453
Blog Entries: 1
I'm light. 20K lb chassis, 4K lb toad.

I can feel it engage and release while braking.
The red light died years ago.
__________________
Dave and Nola, RVM1
The Journey is Our Destination!

http://davenola.blogspot.com/
CampDaven is online now   Reply With Quote
Old 04-15-2013, 07:05 PM   #6
Senior Member
 
Damon Owners Club
Ford Super Duty Owner
Join Date: Apr 2008
Location: NAS Pensacola, FL
Posts: 329
Put the BB in the passenger seat. Secure it with the actuator facing forward. Plug the unit in, test and adjust it. Go for a drive and stop your vehicle hard. The BB should actuate. JM2...
__________________
Ted Fulltiming in the DreamCatcher a
2008 Challenger 371PE on F53 w/ 2010 Cobalt
R'V there yet?
teddyu is offline   Reply With Quote
Old 04-15-2013, 08:27 PM   #7
Senior Member
 
huntnski's Avatar
 
Fleetwood Owners Club
Join Date: Dec 2012
Location: Arkansas
Posts: 7,660
Thanks to everyone for the replies . Teddyu you have the answer I had not thought of! Was contimplateing DW at wheel, me in toad, but my brain kept asking me, did I really want to do that.
__________________
Tim & Mary Discovery 40X. Chevy Tahoe. RVM32
"I've been lost now, days uncounted..."GFR"
huntnski is offline   Reply With Quote
Old 04-15-2013, 09:54 PM   #8
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,232
I tested mine by placing on passenger side floor and driving about. Also make sure there's no rubber floor mats interfering with the unit sitting level.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 04-16-2013, 08:15 PM   #9
Lit
Senior Member
 
Lit's Avatar
 
National RV Owners Club
Join Date: Feb 2010
Location: Ohio
Posts: 207
On some cars (my 2012 Equinox is one) the socket that you plug into for power shuts off after 10 or so minutes, this is something you may want to check out.
__________________
Lit
2005 Dolphin
2012 Equinox
Lit is offline   Reply With Quote
Old 04-17-2013, 08:49 AM   #10
Senior Member
 
huntnski's Avatar
 
Fleetwood Owners Club
Join Date: Dec 2012
Location: Arkansas
Posts: 7,660
Thanks Lit, I have checked that, I really checked out your aviator . Loved it!
__________________

__________________
Tim & Mary Discovery 40X. Chevy Tahoe. RVM32
"I've been lost now, days uncounted..."GFR"
huntnski is offline   Reply With Quote
Reply

Tags
brake



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.